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29 fsaetféar M3 fsesuie
(WEB DESIGN AND DEVELOPMENT)

AAS 1: "< - ufggr= (Introduction)

mfg & €E7 (Lesson Objectives) :-
fen wiferm & »ig f&9 3t feg a9 € Gar T A<4r ;

o TENEdITcHE T EEHE MRS T |
o MAAUHS T (Expression Web) € GEH & g € |
o NTEIIIATEE WAHUHS < F (Microsoft Expression Web) §wid f€eaer § AHSE € |

Adfag A7<=arat (Relevant Knowledge)

gAt &9 UAT § g8 € B WY A MH AT I MAMH AT (HTML & CSS) €t =93
mmﬁﬁlgﬁwﬁﬁﬁﬁa&mﬁ(“ ) fey =&t SgrTete 3w aas
B, 398 ngwamémaﬁa fAr &% IB3tT I € et N Uer
F e I& | gAt g9t 3§ ST 99 Fa© T 7 fa =t fEmuT st g S BE R
SElst @ 4 feyeT ffq yafas o I fan fg féa ne'sas Sanele @ a2 3 fagr oog
A'd IEAf& T, f§39, HeeifamT miaet »irfe mHs gv I& | 3wt feg faat yafas evds
35 e < ¥ »rafdar g% (authoring tool) € 93" d9 AFE T |
ﬁmmmﬁwa%@mmewama@@ErM|mﬁww
wEted & ST maEfdar eww fagr mrer T | feg §unustans 95 & IUTS sE AT AN
wamwwmmwmwwﬁmmﬁrml
w.z’r.w.wmsﬂzag’@wh;r(wvswve What You See is What You Get) W3ted fagr
#Arer J | feg fen raTet aaa fagr Aer T fa€* fa fon fSg 7 AT fsadls ea € feg Sue
g B9t (7 fasa® O =9aih) mBeye 3u6 =9 aﬂ@me’”@vmw@?’rmwsﬁg
ufast W A A S Aistes @ fd mewels 2 Aetet & fsmels aigr AT g G 3
WﬁWﬁéHfédlﬁﬂ@?ffé’i‘%ﬁ@ﬂ#éﬁ%é%%@%hﬂﬁ?aﬂ?
e J|
gy YfHg A o.M Wates € &g »fenm (Amaya), W39 SIH=t=d (Adobe
Dreamweaver), dUwd (KompoZer), HEIgHee MaAUHES < F (Microsoft Expression Web)
e IS I5 | ¥ F JAfSIT 2§ AElet § MaaEls f3uels aos € afeur &
HJIEMHT Fa= 8T I UT feust € et frmmer muts =8 f€edd e goans ef Agas Jet J |
I IAAHNT W3Ted (HTML editors) & B9 JdoF faa IE 75
o fETHCTIT IUB T IF & g='@ T J (Generate Standard Compliant Code):
faewug & feg 93T d95 & &3 &t gt fa at WA AHAT 5, AtHAAT 3
wfe @ HUES MEHTT ST fapdT T A 59t | vigted HUEs e fods dusT T |
o WMIANHNT I AT WA A It SBBHET (HTML & CSS Validation): feg nfenfas
gd& Bet fa feg I@3tit (errors) 3 3faz § M3 /AT fipnd € wiggy 7, a3 & 39
FEs 9 F i3t Al I




o fog WU aset falige =@ T (Generate Compatibility Reports): #W3ted
aHUefgset (compatibility) ‘3 »rarfaa falae se@er I fan ST Sy-Jy 598w
o I TIAS I IS |

o AUB T (Spell Check) ): Wted AUTEar €t a3t 9 dos &et fen daee § <95
UAfHar Aree=ma (Word processing software) 37% 9°d g€ J |

o MUSHTEIR AWE A MHAS (Optimize HTML) : #Sted mea3ter 33 § asa
Wﬁm?ﬁmé‘éé&aﬁﬁ%je' J 7 A%<l 38583 I € Har g Aer
J|

o MBI Infsgrs /a8wa fe@+ (Multiple Resolution/Browser Views): m3ted
WMrelaEt 39 ageT F wruS SFIT/E AT § HeUS Fadls & Ue oad e
(Smartphone, net-book etc. WWW@WHWW(MOZI“& Firefox, Google
Chrome, etc.)

o WA.EE (SEO- Search Engine Optimization): W3ted fer a1 7% S gArele sa@er
Uhmm%ﬁawﬁéﬁmﬁ?ﬁﬁﬁmw@a‘f@?maa?m

o WNFWE BE AfgGar (Support for Add-ons): #sted 3rd yrget Wz - wrs &
AUTfE3T gaeT J fAgsT =7 mdEr o8 A9 AHAE (HTML) #dted & ivs
FIETJ |

o WBIUS yafsfiar HasH (Multiple Publishing Methods): #3ted Fured €t GaraT
T BT MBAT-MBIT WTURS ©F 93 ader J fa= fa FTP, WebDAV »ife | 3 fade
dfues I mrust TATee & yarfaa aaeT J |

HEIg ATee WanUAs < ¥ (Microsoft Expression Web)

HEIG AT MAAUHG < ¥ gt M 9.2t MHM® (HTML) #idted 7 M3 29 faarfes Areeanma
&% HTEIgHee g/aT §3U™e qaeT J | »iH.E.39few (MEW) € fa Hos fermst feg
fa feg 9 Um & g=8< W3 Haw a6 et HTML, XML, CSS, ASP.NET, XHTML, PHP
W3 JavaScript €t 293 ST J |

&< fem HfsGw® € fAge welgAee Waau s 29 & T93° ATAAUAT
(HTML) 3 &efgg a95 Bt aist aret T

J&t &3 mgng #H g 39fsw (MEW) 3 & J4:

1. HElgAee MAAUHS 2 F 4 € (3T M3 YI'ET FIr6) HEIGHSS . a™H
(Microsoft.com) 3° 38&&FT J9 |

2. 95t fegtut gerfest e User g9d férne™s a9 |

3 .Start > Programs > Microsoft Expression Web 3 af8a &7 |



et safeg (MEW) féeaen
». g 3afsg (MEW) gag féeaen § fars das™:
1LHE °39 (Menu Area), Hg MreteHt
& feu@er fae efes (File), wiste
(Edit) mrfer|
2.2%9'd 439 (Toolbar Area), HE —
nfger € wirelars & feu@er -
3.g®aan (Toolbox), f&w
MIAMHAS & I3 M3 ASPNET
wfeeHd IHs 75 |
4.2 U (Task Pane), 839 fane
fe€ feg ffq Sanreie f<T B39,
fogg nrfe & few@er 71
5. m3féar 439 (Editing Area),
fer@er 31
6.A¢eH 979 (Status bar), feo =7
FgHe Juaeta & feur@er 7|
7. ACTEI® Hie 439 (Style Sheet Area), feg Aefes Hiet § Haw ager J |
8. Medtfa@en 3 WM&M<e 439 (Attributes & Element Area), M 9.2t HHAS
niedtfaGen 3 IBGH (value) W3 HEAH.MA Judet ¥8gn § feu@er 7|
g

dot f&3 o1 § dds BT FUTg YIT Wals 9:-
53T &9 aH (Activities)
NI AHAE (HTML) MS1ed € 819 3 9997 dd&T g M 9. HHA S
1 (HTML) misteq & 3&aT f&9 1 et As (HTML) Wistes € g9
J9 Areadt B Bet feahitstyr € 93 J9 |

H&as
got &3 ymst € €39 fe6:-
1 MM HAS (HTML) W3ted € efee €/ ?

2 JE YA WA AHAS (HTML) mStedt € &F € ?
Jot fost ust g=t 39|
1 ATAAHAE (HTML) AT & ————— Aeeend fagt W9 U m® (HTML)
a3 feg s=@er T |
2 , F————- gt MY A MHAS (HTML) mistes T




SgnEle € R Jondlet w3 SuuAt § geger

(C:REA;TI NGWEBSITESAND WEBPAGES IN AWEBSITE )

mfgmma € €€/ (Lesson Obijectives) :

fen wife € #i3 f&9 3 feg a9 € Gar T A<4r ;
o &<t Afee g=78< € Warl
e STUT S ITBT MI AT AIS T |

Aefua A7=adt (Relevant Knowledge)

AT MTUS f3ATEE &% S gATEleT 5T AGY 7 | AT @9 UAT I IH Jd Aae J fA= f939,
AeEl® Hiet nife | AT fen € o7& Hae! oot eeist § o Sans (3839) f<9 Aea
Jdd 34 A< J | feg 3973t Hew adar:

o Ha1f&3 gfgs Bet|
o faie Aa=g & ATt Miaret fee WUS 3 aoaT Ae IAT MuSt L IAEE § YaHI JaaT
gde T

&¢ : gAT gwe T few HisGw f&e ude o fadar

fea SgnTfee g€

ffa &<t S°gATee g @er,

1. Site © New Site... (J53 A< 4Y) & fAdde ad | € s=f 3fedar gran srg mger
J | (J&8T IA<ta, 7)) |

ETET
S I
e e e e e
| Teirgdales [T S WA e
Optoae
- =
Site -
i il Specly the name avd locabion of Lhe res sile
I MNew Site, .. Cerl4+Shift-+M LRt [ ommrts T et o Sy B umarisvarwabstel ST
[ Open Site. .. Crrl+Shift+O A S e BT
Recent Sites r |

(€) One Page Site & fidae a9a AT fEa um 3 ffq T gAfee g7 AaE T |

() Empty Site & fA®ae a9d At B 3° ffd T gATEle g7 Hae T |

() M I.AMHAE (HTML) T 9 Arecand €F Hee &% IAT ufgst 7t fifq S gAete g
9d I, 3UTg MTUST LIATEIE € dH & Adt JuS BET WM. 3E®E (MEW) € =93

JI&T 993 HIal T 1ufost 3° 5t T¥t S EATeie § AH® §9% ST Import Site Wizard &t
TIT T |




2. Empty Site § A& ae ad M3
SIHEIC @ & #ied dd, Beuds
T el :MyFirstWebsite afsa OK

3. ffq gATele g=Tet aret | IR
M3dR<e &3 € o f fea &5
&few aaar

IHt €7 BaHs § B9 fAg SgAEle

Hed e%3d MElas 3 i3t AT | %39

wretars 3 fors fe6

wfad IT8TEeH fas

939, e@nwahing, Iy s S

Thaw are na F ez 0t Folder,

Fle  Edit  Yiew Fovoritss  Tools el | i
U?r 3- HZ'IEH le' 7’H"'f€' @Bu:k - T 7 |/ goarch |1 rolges (153]> | WY Falder Syre
W W %H- m e’ Adcroas [ Stpocuments end SettingshLabAMy Cocoments = Ga |
Rk = | Name = | size | Type | Date Modred
f%‘g’ H%H ﬁ' Frlaﬂ'yyrr | File and Folder Tasks = My Firsthw sbsite File Fokdsr 412013 10:53 AM
o Make a new Folder _vJ
Av

Ud § gST8<T (Create a Web page)
ﬁmwwmﬁ?w@ﬁww@?ﬁé@ﬁléﬁﬁﬁw@zw
& &y #igHg a9

1. FlleeNewéPage . ?"a‘fﬂ'ﬁ"—orc’a?r? Pege

| gl 5
2. gAF W Bt 3BT (MEW) & 293" &% | swes=es ] v Terciae
I AAHAE (HTML) 3 EARAT (ASP) | "= RN
I3, ReTfew Hie (CSS) nrfe € &< Ua CE I e
g AaY J | f8Ae fE9  HTML & Select

a9 1 OK’T affT a9 | 20 ffa &=t
Ug famaforrdI3nsiodard FERNORL

3. Untitled 1.html feg efe® ara™
¥ | Fgete T ufgsT Ua 3asT
JHUH J<dIM | AE 398 d&<SSHS of

Z93 At default.htm, index.ntm 3
home.htm & 5™ &% AT J9& BET  Jd AaE J | fem UA § A< d9& &et File> Save &

frsae aq |
4. TES BT 5™ default €Y g9 M3 Save & B e 9 | 3T feg ERe &t BF &t T
fa .htm A7 . htm| WaAeHS 7, feg 9 Ur @ &9 Wys »y orfus I ATEt 7|
I3f&ar efew Mamews (Handling File Extensions)
AIIAMHAE (HTML) #Steq fae gt safew (MEW) efes © w3 i html Hamnens
& MU Y It B3 MEATT &ar feer 7| 3T M. AHAS (HTML) #Sted § Taeiar
F95 BET Tot &3 IT IS MEHAT .htm HAHeHS HHS &F Ao T |




1. Tools > Page Editor 2%

Options - i)_ fﬂ'gﬂ? a9 | color Codng | awhonng | pizwee | Ruerandcnd | ireslsense | Font Familes
o . zaneral ALoThumicnai Defoult Fonts Codz Formnath 55
Page Editor Options rmmil ; T f "md] s | cRRans A
ﬁ a ¥ pubcmacicalky enclosa form fisds \wihin 2 Focm
&TH gTdH f?ﬂ?'r 3) | ] Assign unique s o nesws E=hles
(IAST MAAGe) [¥" Hake 10 wrig e on pect
[# Lia <strong > and <eni> whan using boid and itakc tooibar butkans
2 -n,l-raﬁ'a-l- (Authori ng) —zra- E"')— I nutcmacically swkch keyboard to mabdh language of surraundng best
N 2~ LA [ Autematically sdd |5 sttributes ko nkematione b=zt
I) B ddGT (SA<IT JoT J) [+ Proropt Foe accessiilby croperties when inserting imagss
~ . spelling
3. fU‘*H"?)'o'és ISST&HC STAH CH peling ptions, . |
ey & fAdae aga HTML Defaut Poge Languege: | Enclsh (L5, =l
© It Default Document & Cuf and Paste Crtinns

fﬂ-gﬂ? aﬁ-, gﬂ 3"'@'?)_ )?r(')_ m@' I¥ Show Paste Cotions buttons

Y o Coda e Opti
Tes MaHeHE & A ae dda &t ok n
= [~ Word wrap [+ Hghlight ineealid HTHL

html - Dafault HTML File @ o nden I¥ Hghilghe Ingompatble HIML
Extension Wums &  fAS e ¥ Lmeonkes

= [ Selection margin

aﬁ- l Securty Cptions
It it Affa wew A T AT o stk s |
w3 feg meg &3t At 7 fa felten

Document Type Declaration& HTML

557 A &9 | T=l
i u e @ fymy e OETETTESS— 23

o = ~ Gereral | autoThumbnsi | DefautForts |  CodeFormatting | €ss

far memets wie o UsS ITHS ColorCoding  Authoring | picture | Rulerandérid | InteliSense | Font Famiies
ggdt YaaH fae fa ¢ U3 newbocmens

hoose the defaulk bvpe of new documents and the defaulk file extension of new HTHL

E:T' %B@' ddo 8-8:1- 3Fﬂ_ éia- documents,

Coreel |

by T 2 a = Defaulk Document: add a byte arder mark (BOM) when
ma-m:! HO ?=>_ doeldld aa- Hd< IHTML LI creating of renaring LITF-8 doc urments
a_ fal T —: [l Hu_a_ with these File extensions
ISse’®c didl I<d = Diefaule HTML File Extension: b.htm  [Pls
. . -~ . TN . . @.htl‘lﬂ D-th
A 35 | I6T &3 MawT G Sl e
" htm W dwt [ xml
1.Tools=>Application
OpthﬂS E';)— fﬂ-ga? aﬁ- | Dioctype and Secondary Schema
) . = . o Choose the doctype declaration to be inserted into new pages. & matching document
App | |Cat|0n Opt|0ns 'reg schema will be used to drive incompatibilit v notifications and Intelisense for HTML and
script, If & page has no doctype or an unrecognized doctvpe is declared, the

m g7 W ﬁ- Secondary Schema will be used,

Diocument Type Declar akion: Secondary Schema:

~ —
(gﬂ%ﬂa’ e-tr) HTML 4,01 Strick Internet Explorer 8.0 _'_I

2. Configure Editors & fA&dae e
~ chema
dd (B'HE:]H JoT U) This schema determines what is available in €55 IntelliSense.

Schema wversion!

3 gfe® ManeHs w3 = =
nuBtans <% forrs fe€
7 fa fsruss iarcns & [ | coneel |

J3% Ja&dr |




&c: 68 ge fan <t Aféar § 39t &7 a9 |
<9 Ud 3 o 95T (Working with a Web page)
HYARHAE (HTML) #ated 20x]
fae fa ﬁn—re‘fs‘aﬁwgr (MEW) €7 General Configure Editers | Reports view | FTP |
fegrg T s efeer feg T fa Speciy file extension(s) to associate with available editorts)

== f -~ Ll LS 30X
3—33 HUST dF Hlec<™Md Extensions = Editors |
omTgT 'Fg-fu')ﬂ-r W ﬁ- | dEXprESSIDn Web (Open as HTML) (Default)
= :z; o dExpression Web (Open as Text)
< -~ ~ v} ~ _.pu . ‘JExpression Weh (Open as C55)
1. §3tuz9 < ffg dot foaT fapur b arccashx asi<ac |l B Norepsd
= = bak
2TElY 99 (AT <F) bat cmd
bmp i
htah crd Fah
(€) My HomePage < |

M ake Default | Move U l Move Down |

(") This is aWebsite created using a
HTML Editor
A€ At dce & gTgeT
gge T 3T wH.EIEfEw
(MEW) »mu@ iy 3t U9 <=
ge% féer 7| Sﬁfm 1 My Hotiepage
WEhe fAe ‘P’ (Jost 3n=ld
TH) §dce TS g T
TR € 378 &< A13T J=dI | A IHI Wed i ©F 293 Jde 9 3T MH.EL.FEBT (MEW)
oA U9dre s g9 féer I fas’ fa =93 yAfHar Areeenwe € fSg digr Afer J|
2.3 “My Homepage”
bame § 9E WS To 93 Defut Font
MESHI IT

SteView | defaulkhtml® =

This 15 & website created using a HTML Editer.

(None)

(a) g®Eg & {9 Style 3TU
305 & dae a9 (faz | Paragraph <p>
SURCRESED Heading 1 <ht>

(b) Heading 1 <h1> &fgme h.. . . ..
f&5 M@ ae a9 |
3. e “This is awebsite created usinga B 2= v
519 e 5 Heading 3 <hd> & frdare ff ==~
dq | ‘
4. R =t 71 f a3 fapw I View T s sntng o s et
(Menu) > Page - Code & i@ ae ag  Eomm
(A Aen g9 € §uad Afez Code & fAd ae a9) | feuret aret In<ts & =far 30s &
3IN<IT SHT HTEGT |

M chezas




5. fonrs fe€ fa Sane IfSar mahie (h1 W3 h2) AHs stagT famr 31 (CTRL+S) € &%
ferUm g AT ad |

faQfa miztes 393 et a5 fouer T fon 52t gnl dee g8 3 fors feG s faas

feues e €3 !

AT &< 3T I fa yI-fase AS3as Wa.dtms (HTML) Watien g€ as fagst &t

93 A T HUA © I Aerfes s9v 376w 1ig 9 A8 de a9 a9 Aae T |

g< gy faaets fe§ € f&9 77 & View> Page > Design § fid'ae a4 |

#H et safew (MEW) € &9 f3s fe@ Gud=u & : (The three views

available in MEW are) :-

1. fsarfes fe§ (Design View) : feg fsese fe€ T »3 fige dee § fewBer I

2. a5 fe§ (Code View): fer € 33" AT 37 Ma. T 9H.HS (HTML) #sted evmar fay are
Ao 33 § YT Set I3t At I A A IAl MB < feande a9aT Ige 7, A Ae 87
a3 & €U JI&T IIE 9 7 HI.AHAS (HTML) misted € f< Gusay sat 91

3. rufge fe@ (Split View): fer €t =93° 8< i3t AEt A< AT &= feufes M3 a5
fe€ & mels-ge-AEls =93e ode T

HBSIUB 29 g8war e feA3H® JdaT (Using Multiple Web Browsers):
H3A MUS ST UR § 9 d9aT 9ge J, 3T feu ngg fe3t 7iet 7 fa fen § waetus 29
g8w9 € 93’ 578 SHe J9 | Ug fere et s 987 feHe Ae a5 ©F Agas ugant |
WSS 29 §8waT & fagufazs aos et IoT 3 MaAa a4 -

1. File - Preview in Browser - Edit Browser A=

List.... & A& ae a9 | Edit Browser List ket bt i Hhe b b5 Slest the i bun B B et
= . =~ will be launched when using "Previes in Multipls Brovssers®

STesTar Fan G T | T NRR——

2. fons o6 fa g T Qe St fome ufgst | e |

It wrfvs 15t 98 I | A9 IAT (EnRféar @ S|

B'E"]') éﬁg TQT—lH ?;’_ H™HS ddaT w@- a- 31— “T;":;:'f;’;“’“ - [ 1D24 = F&B I Lepm 102y
Add ?:3_ fﬂﬁ? aﬁ- }Hg- é:a- ‘i"@m E:]' g&ca dl [ awtomaticaly save pags before previswing
(executable) 8T€t® €T gHIT &Y | e

(8=mg9a & &E: C:\ProgramFiles\Google\Chrome\Application\chrome.exe)

3. gt feg fen € 293" Aadts InTBEHs & Ae 95 et <1 g9 Aae J | feg 303 et 6«
Frgerfed I AdET § A Al MTUS F Ud § AHdees AT ¢ude & §°3 Sre adaT
IYE T 7 T MBIT-mB 1 Aadls InfsEHs e =93 qa9¢ 76




mfgm™a

Fot foTtt gt fafamrst a3 -

B3t &99: aH (Activities)
1 Jot fi&3 fan <t fem € €3 gl 56
(€) dfufes gars (7& 3 Fafen)
() gt

g9 fa feg fas faaels 3 o€ g5 | »H.gt3efeg (MEW) € 575
fea &<t yst Sgrrete 976 fon feg We-ue 2-3 29 UA IHS J4|
M3 AT AHAIGT (deT) & UN dd 99 < 8% »&ar-ms 1 Wa.St i ms
(HTML) W&tien fas’ fa Ifsar, idar (strong) »ife €t =93 a9 |

2 nifse g9 fere <9 HeteT elaean (Mozilla Firefox) § W3 d9 |

H&as

dot a3t v st g=t g4 |

1. 5=t Aete —— iy <9 fuset 7
2. , I Y9 € UAT § 58T BT MY HHE (HTML)
WSted €t =33 3T ATEt T



A. 3: e XA '}‘H@' ﬁ = ﬁ Aw =

(TEMPLATES AND IMPORTING WEBPAGES)

mfgmma € €€/ (Lesson Obijectives) :

fen nifgomm © iz &9 3wt feo a9 © Gar T A<ar ;
o SUBC O I3 & SUATEI I 8T T |
o FrElet & feriae d9s © |

Aefua A7=adt (Relevant Knowledge)

SuBze € AUfe3T &% WAl WueT AT w3 fHosa 99T Aae 7| & gATEle € BTt
SuBe &9 vy 39 ‘T WI.AHAS (HTML), RLARHH (CSS) W3 feran eetst avs
gt g% fagst & 93" st 575 fer 3gt Ewt Tamrfee § g wEt JiSt AT
AaEt | 3HT et ATee WaaU TS < ¥ € <9 fage-fes (Built-in) Sude €t =93 S gnretet
& femrfes q9s et Jg AaE T |

2UBC Tt AoTfesT &% ffq =t &gATfee g=8<=T (Create a new

website using templates)

#H.etsefeg (MEW) f&9 993 A9 (19) _ -
fase-fes Sude as € 75 fAgst et =g’ | e | e
SAElet § sTgT St ISt AT Aaet I o =

anete sele Bet gt fawefes Sude T

gt 293 ot &3 migHT J9 Aaw J:- e = B

1. Site> New Site...... & fA¥ae aqg | 3‘:2{.“,, 4 —

2. Templates & fAdae da w3 feq Sude eERT 21 e
€e95 T Bt Organization 5 & fBHe f&G et sismyi wrmmmmeas T oo |
g ool
- Carvel

3. fen gnrfee € 5= a1 Gergds € Bt —
Company01 ST€l¥ &4 |

4. fen Sgrrete <t Baws § w6 w3 fer Sy B ]

ATEte & C:\Documents and —

Settings\Lab\MyDocuments\Company01
fSg 7eég a9 1 OK ‘3 afST d9 | SuBe
Organization5 & €°3 mufag fea SgATete

rormation_irks
-~ ~. Y e 55, L
g A4t | (fas 3=t feg e
EN —_ -~ 9] — [jslﬂa:
feufemT fapnT J) 1e®3d fore @ feg &seg o am S g
-~ . — . au -~ fﬂrrastu.dwt maszar.oek ZIE dwt 4fi (2013 1 235 PR
W3 TEIBT & 8¢ J9 | IS IHT L EATEIR I

e ¥% Y J | s




5. THUH T o 99 BTt default.html B
‘T & I IBT | IAT fer =9

ﬁ?r o7 Jd% JTdl U'T dcd Ho(‘é J : Organization
ﬁ @_.ﬁ F'é_._ ﬂ. auv a . N isnizatisn Description

g9 § 3t v et safsg (MEW) s 4 ”‘
st 3efsS 2T (DWT -Dynamic —— . /
WebTemplate) €t 293 9T J | - ‘
v S Sr R sea—y 'k _
s feu femae aw ugarifen | °

Uw f&9 San § mifse ai3m 77 R
T
6. feT Tue € et fa Sunrfee fedles & fas <t fenatt, gnt fen SaAEle § gEwa ©
f<9 Sy Aae T | fen SaAfee § 870 © fRo Sy € et muS FIEas T F12 &
g | TEAee fae®e 29 870 € €3 awa mBEt I | g7 AT & U € BT oHuA
T YY UH € d<idms f&a Tt €93 ad |
TBHE WIS (HTML) #Sted ©f S93° 996 BEF g% ANT BaeT J Ud IAt 83t It
gg3 It ufe A’ € 9 3 993 We a3 € &% < ¥ Ud Af Ale § 9T AT |
fevaféar Aveten (Importing Sites)
Had AT fai gx #E.dMHAS (HTML) M3ted € 93 AT cane Wisled € <93 &8
TE®T gETEt 985 3T gH Gust & mrust SEAEle § f€lde a9 Aawe | A€ IHT
»H gt 3efeg M. AE (MEW HTML) #W3ted § 93T 9de & #F 3T i€ aHs
SEATEle ff MBI ar eEtst § ydfuz aaar 9ge J | 3AT MH.Etsefesw (MEW) &F
93 &% Ufost It Ire I Fatt (I gatnt) Sarretet & <t felde g9 Aae 7|
8TU9s € BT 7ad AT HeBT efest gereht 96 M3 fegst & C:\HTML € f&9 A=
di3T T M3 gt feust & félae daaT g€ J 3T Jaf &3 Mgng gert &t UseT a9 -
1. ffq &<t SgArfee g6 w3 ferer o fe€ | §eg9s € s IMPORTWEB |
2. Site = Import - Import Site Wizard... & i@ de ad |
3. Import Size Wizard &< sfesar gan ferer T |
4. Connection Type : 337U 3785 Hig € ST <suw €t fane § ST a3 |
5. Connection Type : STUFEE Hig

¥ f&9° File System »uras & N

e 53 | Import Ipart Frlum w Package..,
6. Browse 525 ‘T afsa oF M3 - Tmport Ste Wizard. .

e¥ts o s CAHTML foafag AL,

ad | Select ‘I FfEF AT | Site Settings...

7. Next 3 If8F 9 |



8 fé’)—lﬁﬂ? fE?FBB' Import Site Wizard - Welcome i i |

C:\HTML ¥ f&5 »ms
e o fea amt
ge@eT 7| feg gomst
FET Heedrd § Adet &
fa@fa feg nims eels
€7 39T g9t JET T | Next
‘T IBFT T |

9. Finish ‘é- a'ﬁiﬂ- aﬁ- | T T T I — I~ Irclude subsites

eetsT €t foa fene
&Hd WeEt I | Ut
&<t Sgntfee @ feg

Yo can impart Files From an esdsting sike-or from & Folder anovour compuker-oc:
retiwark, :

How doyou want bo get the Files?

Cornecion et [File System =

s Folder on your computer or on 4 nebwark as the remobs
==

Locaion

Loz ation: Ic; YHTML Brovse. I

féuge g95 »et At

= Rarl | Bt = | Cancel |

fea mzq <t yat
ot T T

S WiE

D

i Pubkshmg Setings

P o ~ Sa
TEIBRBFT & fAdae | reiwrmtmrmaeoivas @G S x o B5im%
= Hems | Stskosz [ Madisd ] Hame | Staae [ Hosfed |
-~ = ~ _o3x. o — .
JddHIE JIHddc<c & TR T
= | ] atibige s 1Rl ah [ § T - & atnbuke sa.. Unchanged 372013 L1:43 ..
a— ~ VLN S Brd_onm 3)19jZ013 B:24 A & Brd on s .. Unchanged 3142013 B2 aM
fE'LIH?' addé & 8-8‘1- yq @iard cn_a W A)2{zo0Lz 333 M @jard or_a W, Unchanged 4)2l2013 3399
|] czs.hbm 331013 RSN _#] res.hbm Unchanged 33112013 =51 FM
ﬁ?)_ @' '@% FFB"]';HT AiCSEEredsel.. . A7 2013 LES .. A CoSExerche0... Unchanged  3LT{20L3 LLSE ...
= (3 defau.binl AJFEOLE1EL P =T HTML Refee.. . Unchanged 31402015 12115 PM
.m_re:]?)_l_i_ o = I [ZHTML Refira.. FHAELT 1TIS PR & himis.btm Unchanged 301312013 200 PM
?__)_ g? M3 é | ] hidS. hitm EFE0L 200 FM SEHTM S g, . Unchanged S0L3E0LE 207 P
- ~v = ElHTMLS -, FFFA0LE 307 PA #] EssonCOLREm nchanged  3PL4EI0LE L1 .,
rey fﬂm? a9 | |#] lessarn i1 Hem AL 11550 8] emrdE i Unchanged L4200 5 14 50
= |8} leszori 02 hkm 42003 X4 PR &awﬂﬂ:.c:s Urchanged  WL720L3 1141 .,

Allmystdecss

fE'HTé' aTé- ?)'3:1';? é&' Hloperdiparto...

=] ory_attnbuee..

fours fe& (Irsta Ia1) i

= sapile. st

g IAt féldae diatut k< Anite g

Jehrdtefestat=es |
Jd HAE T | A% efest

FUM20L3 4L 'i_llnpa-ldpm.n... Unchamged 300312013 647 4H
FLE0LT 047 A &) prg_stirbube, . Unchangsd 300402005 L2ZTFM
IHLAZOLI 1227 FM e pump monpd  Unchenged  WLIMZOLT 41 FM
3)13/20L3 3141 P EHjrrebg Fuc Unchanged  3)S1{2013 L1 1S PM
3312013 115 PR B sarnple. suf Unchanged  3fLAfA0L B2'53 &M
31472013 B: 55 A £ sample_mpeq.., Unchanged 11372005 %25 &M

LL}3/E006 5:25 A B surset fpg Unchanged  8/=3(200L LO:30FM
=J23E000 1050 PE = Thembe. db Urchanged  3L3/201S 207 PH
SHAE0LI 307 PI

. o s O h i1
C:\HTML € f&@g gfest |t wm e T

@-ﬁ- ga-r W W U?)_ | Foldees | Pubilshing

Repots  HWR

dot f&3tut aretmt fafemr=t 99

%3t &599;

aH (Activities)

gY% AoY J |

g)AUdS AU (sports shop)

fawe-fes aHUB e € Hee &% IAT S IATEIC 9T Aa< J | (J&T f&3t aret fene
f&9 AT 2fud 9= AgE T ) IAT MTUS TTECEEH € &8 HBE A8%e ITGSSH

(€) w3dg =w3T & AuBTET (household supplies) (W) ATa=ar & HI™& (Pet care)

(W) TIgm® THE=M (virtual mueseum)




gt &3 ymst € €39 feb:
1. JU&< € Hee &% S gATEle gege <t feut msg ?
2. TEAEle § ferlge aos © Ben & feut &7 meE ?

dof &3t yat g=t g9 :

1. fame-fes Sude & faest ———— 1

2. SyBe &t fI3& gt : E§ 5 |

3. Sude s € feg Gudau ger I

4. U 3 AT § Tue (Yfe® J95) B8t —— Sams aby ©F =93 A3 ATEl I |

5. fertae mfee femmas (Import Site Wizard) Arete Hig (Site Menu) € —————— Ra\s
feg fuser 7|



A% 4: fene, eoiféar, AUs s »3 eEls 3 foudw o
(USE OF LISTS, FORMATING, SPELL CHECKAND FIND &

REPLACE)

mfgna & €7 (Lesson Objectives):
few mifgnm € iz fee At »ii gt sefeg (MEW) € 93" 5% feu d96 € @ar g Ar<dr
o fBHc I AN TIS T |
o JIAC TINC |
o AU® 9 €t 993 Jd& € |
o TTEIF M fIUBH muns ©F 293" 995 T |

Agfag Ar=ardt (Relevant Knowledge)

fue® fns S IfSar M3 Uaqre 3 aW 9aT fHftr I 1 AT #iH.etsefsw (MEW) €
fEg Me. s (HTML) mahie fae fa fare, fornm, 29s »ife 7% <t oW a9 Fae
Jl
MEMTI3d3 f&Ae I=78<=T (Create Unordered Lists)
fAs’ 3t =93 ymfHar Aeeenm € <9 fone et At @7 391 =far 3wt fere ger
AAY T | MEMTI393 fere se@< wet ot fio 3 gent St useT a4 |
1. <t Ud 9278, 3 few U= & unorderedlists.html &7 A= &7 |
2. J&t &3 18 2ane & ey J9 (den ¥ f&9):-
“An electronic book or EBook is a book published in digital form. It consists of text, images, or *
both. EBooks are readable on computers, net-books and Smart phones. EBooks are available in
the following formats:”
3. I JIAT § MBS Uggre 3 9 |
4. Style dropdown Mg f&9° Unordered List & fi® ae ad |
5. 3ot f&3 mignd ety a9 (I3 fed »iedt 3 gfe meg Un aq)

®) Djvw . ot e e e e e peeras s e
= <wl
() EPUB e T T
= <1i>EPUB< /14>
(¥) HTML 6 <1i>HTML </ 1i>
. 7 <liz>iBook (Apple)</14i>
(M) iBooK (App|e) s <1i>KF8</s1i>
L= ] <AIA>LIET (Microsoft DL, ALi>
(U) KF8 Xl « Fenl >

(&) LIT (Microsoft)

6. T¥ 9978wa € 9 (F12 Key € =93 &7®) fau®e § 9T d9

7. M EL.398T (MEW) § AfeS 3 M3 View->Page-> Code & i d¢ a4 | .St AHAS
(HTML) mSted enar miamasds fene &9 fou ae d93 & &< a9 | (3A<ta §ug J)




¢aAe & I3% ads™ (Handling Text)

IHT MY AHAT (HTML) W3t Hig € Jo7 aHs e%e9 © 9 Afgz mruns & =93
IId MBTEIE T SAAC § SIHe I
Aae J| feg 95 yAfAar (BT >

Aecand € &8 ﬁ-le’ae'-ﬁe’:e' U,qgwa’&ﬁweh’vmwe’reﬁé‘éﬁrﬁm
(Formatting) M3 ¢ame & fewGe set it Aiet I |

IHT AUdE Ida 5% gBE (Toolbar) f&9° mrfeers § i@ ae a9 Aae T M3 IHT W™
FIH<C 3 IH Jda & <191 fena dH Jd Hae T |

Y. MHANS (HTML) MSted 303 Bt aF fouar | A€ At AdW 93 § Su< € BTt
ZHEd MTEleH € 93 dde 7 3T 8¢ Code View § AfST &3 |

AU® 9 MJ HHATEH (Spell Check and Thesaurus)
e A dde § sTge 3 fomrs fée g 37 §€° gAt g9 AUTETT €t @3t a9 Aae J |
ferer % d9s BT IT§ M. MHAS (HTML) #3tes fase-fes (Built-in) AT® S
{9y &t gfeyr féer 7129 UA SO AU'® 99 dd& et 9ot &3 gent &t user a4 -
1. ¥ I € &% S 9UH § U8 (79 IU'F I I8l %3 HEE &d1 I 3+ AUf&ar &F a3t
S IT AL IITG) |
2. Tool->Spelling->Spelling=> (F7) & fAd ae ad | forrs feG Al'® 99 € igs3 =95
UATHST Areeamad & <faT AU T&ar €t ars3hrr § S aaet 9|
3t fawe-fes ga8w Mruns € =93° Tools-> Thesaurus & A& ae d9d 9 AAE J |
e s MI faudwH (&ane) (Find and Replace (Text))
Had At S gATEle € ST B3 f&y 91T yd AT JUST €T 5T €83 I9d< J 3T IAT at
gadr ? f€q 9 U A ATdt LIAEet € 9 Sane § gese € STt gl eets 3 foudn
FfesTar a7 € ¥93° I Aae J | fene oW J9s <F feut =93 YAng © 8% fHeat-gs<t
J I YH SaHc § $9< € BTl Jo' &3 ger &t UseT aq
1. Edit>Find & @ 'ae

_ X i
od | Find and Replace & Sry ™ |rcpace | rmv rass |
&% 3T B IfesTar  Andwna
S A= N
I9H &Hd MeET & =
ﬂ N DN a Y
( a 6 U-) 2 a 3- HTML Rales.. Cleat rules
fuv: I-'X h-@- 1 mr 2-8-a H Search options
- Flnd ’ Find wihere: Direcion: Advanced:
Eﬂ'l' 2'8' Replace, mg' gﬂﬂ'r i al pages = all [~ Match case
: -~ N = Open page(s) £ p [ Find whole wordionly:
ok | HTM L d m Jd | 1% Selected pagels) 7 Down [ Ignore whitespace differences
- - o -~ = . 7 Current page I Reguar expressions
2. AT € RO A UAT | |nresiie ™ Find i sgurce code S
Y N . N~ o ' i
e e ffaummae § L
\J ~ -
¥g< € &Lt Find What: _
a ~ puv Fird il I Jose I
CAdHZC 9'dH € T€d HUST



2y a9 MT Page “|Lne | Matched Text Y
Find All & =) Private/Data et [1/5] i <IDOCTYRE hil PUBLIC ™J/W3CHIDTD $HTML 1,0 Transitonal/JEN' ..

Sy iy 5] Private/Data.tet [2/6] 1 ... Rkl PUBLIC "//WACH[DTD XHTIL 1,0 Transitional[EN" "hetpef]...
frs ez ?_‘f ! = PrivateData.ta [3/8) 1 oo fEN" ikt e, w03, 0r g/ TR fehéml] [DTD ehtenl1-transitional. ded">
s3tAT IF| =) Private/Data.bet [4/8] ! . 3.0 TR xhtl DTkt -Aransitional ">
feyre are 3| _PrivatefData,tet [5/] 2 il xmins="http:  fwew w3.0rg 1999/ xhiml" >
STt & =) Private/Data bet [6f8] 2 <htal xmmlns="http: [ fwwin . w3.0rg/ 1999 xhinl" >
f&g far =t ;J _Private/Data.bit [7/8] 5 <maka content="textfhiml; charset=utf-8" http-equivs"Content-Ty. .
S =) Private/Data bet [3/3] 13 <JHml>

o o] default tml (Untted 1) [1/2] 21 This i & website created using a HTML Editor,

TIABITIE W itk )2 2 HTM,
3 TElsTfEes
J8 IMIIT
T WIS nny |Faund 10 oceurrences of HIML' in 2 pages.
SEARRIER T

AeT J gT ufas 3 Hge SaAe § 9€5e © BT Replace €Y § 8% I < |

eET MI fouBH W9.d AW A 291 (Find and Replace HTML Tags)
Had A HY RO 29 T SIS JaT s Ae Ai3T I w3 g< 3t fen & fam ga dar e
fST geser oge 7, 37 IAT df Jddr ? fen dH & d9s © &gt efes w3 foudn &
ATIAAHAS (HTML) 29 €t =93° a4 | fenet =93° 575 At medtfage § fousdw a9
AaE T, 89 A 68 3 g ydt <9 rrfee € f<9 291 99 Ao I+ | fen &taq € =93 995
Bet Jot &3 JeHt & user a4 -

1. Edit->Replace & fAidae d9 |

2. HTML Tags ¢¥ & fAd'ae a4 |

3. Replace action: 397U 378% Hig fS9" €a=t Muns & fAdae a9 | fAgs aH J13 A7 A<

5 §ust dnf &t feae § 3 ad |

Find | Replace HTML Tags |

Find tag: I ""I

Il[m:lne

— 1= =]

Replace acticn:

W recrie
Replace tag and contents
Replace contents only
Add after start tag

Add after end tag

Add before start tag

Add before end tag
Remowe tag arnd contents
Remowe tag

HiviL Risles. .,
Search options
Find where:
= all pages
O
P oy Change tag

£ Selected d set attribute value
 Current p Remowve atkribute
=

Makch case

Find wiole word only

Ignore whitespace differences
Regular expressions

Diisplay results in: Query: = Gl
= Find 1

 Find 2

Fed sl | Close |

Fepizce &l I




R I

-~ . ﬁU ﬂ o ﬂ o ﬁ ﬁ . aﬁ_:
&3t S99 M (Activities)
1. Jot eI W a. MU NS (HTML) WE&HeH €t 293 a9 M 9.2t mH A S
g 9379 :

(©) G393 fone 3 3<1aws fBAe (Ordered List & Definition List)
() §8F, e f&an, M&3d8Tes 3 SaAe MBTTeane (Bold, Italics,
Underline & Text Alignment)

5 ufgst geTet S aATEle IS B3t § old 996 BE AUS 9 € <493
aq |

H&aS

Jo faghyt yst gr=t g9

1. W9 AT (HTML) m3teq € f&9 grl W9 s (HTML) 33 § U 3et

— &A@ gead|
2. —— H'gede ot € T93° AU 9 Jd6 BE a3t Al T |
3. — Fdede dM € 93" TEIN g% & IBET B ISt AtEt I
4, —— Wgede dM €t T3 fuBH g% & IHE< J9s et i3t AEt I}



~ AV

AH& 5: 29% M3 A% (TABLES AND CELLS)

mfgma & €7 (Lesson Objectives):

fen wife € #i3 f&9 3 feg a9 € Gar T A<4r ;
o MY .E.3EfEE (MEW) € 93 7% 288 & s © |
o A& & Haw M3 AUfEe J9s &t |
o A% € ®Et fond §aargs & <9< |

Adfaa A7=arat (Relevant Knowledge)

A AAHAT (HTML) & 293" &% 298 978 € HAfGS aH § »H.e.39fsw (MEW)
¥gJ ATGT 37 (Rows) M3 ITHH (columns) & &78% HyT §7GET J |

¢¥% § g8 (Creating tables)

fea gsweg Tuw § 8T et Jo &3 gent & UseT a9

1. fdq s=F U7 976, ferv UA & tables.html 31 7% AT &4 |

2. Design View & Af<9 a4 | 8 & 3 d9nd I8 fAg At s s ade J|

3. Table> Insert Table & fAdde a9 | 3T 3T§ 3IA<I9 <9 feue nigns & Frfewmar
I9H &Hd MEET J |

4 55 s_H—_]_ ST WS T ®M ot fE’IE?"]', 2l =
g7959d ATEIH, 79859 dar e & Bous B cobrer
fEquag a9 Ao T 1 feT F95 € B aemnen: ooom S & e
Jor fd3 MoA T qeHT ST UBaTdgd : e foorem =l E—
(€) Size fiama € J&T Rows & fog e I = Lmnien
10 & Tfeu aa | | T
() Size AoH& € & Columns & e —
fSg 10 efeuag| = ta.,.elm, LA
(¥) Border AdHG & J&T Size @ ff9  sscaraurm
3&eTfeudd| ,
(MBorder Agma € J&t Colorsay | Browse... | _ropertes, . |
FEE G ST HIE S B TC TG | 1 oot cort 1o memioti
(T)OK T BT FT | e |

5. IBUST I3 < fa Iu$ fed faa
53T 8= € B fdait a5 et Briest faueht Uit As | g Ma.dmHAs
(HTML) 33 & €4< &gt View->Page>Code & fidae a7 |

6. Design View f&g AfST a9 1 i'® € & § 9939 § 50 o3 ¢u& ¢ 9 Ad A’
& fM&ae a9 |



. 7=
7. Table>Table Properties> =S58 HE
Ce” ?;)_ fﬂﬁa? aﬁ- | Ce” Horizonkal alignonerk: m I SpecFy wickh:
. - < 2 I pizels
Properties 3TesTar TR ertical gigment:  [oefau j'j P Eh
@. EN ~ .2 Rows spanned: Il = ™ Specfy beight:
Z;IIH > Ul(g”éla Ua U) e Il ﬂ |_| i I plxels
EN -~ V] . In peicert
8. Borders Aama © f&9, Size L ,,
=~ 9 —_ -~ P wwrap
o &g 1 aeluad 1m3 Color:  secders
39U 379% & f&9 Olive S ' =
" e EN —_ - Colar: I vI
(CmER) § MBacad 10K ‘S sxchamurd
s Z Colr [ automasic =]
aa- I I Use background picture
9.UH § A= a9 M3 (F12) 5% | oroser, | [Poperics |
Eiw?;aehveﬁ| e 0 o
»H.gt.39f®T (MEW) AeTfes

Meedgdge@erdmM3 saurae Refseseegufieduféerdigeas =g
feg Af<T a9, Aad IHt A AAd® A9e J€ JIHd & U AT GUT & & A'Gdr 3T 3T
<style> M3 </style>#BMe € ST I3 feuret €< |7 Ades & Jo7 & a MG 3T 3076
9% w3 A& @ ST sarfenr fapdr Aerfes feyret €<ar | fere &% It miysT 593
T W3 Hos3 997 BEt 7 |
A®T & Had M3 AUfde adaT (Merging and Splitting Cells)
AT feure g 2u% € ge=e MeA'd fEd <98 UART € | ]
f<g ¢u% gefon At 1 3u76 @9 Uw, § 87 37 eus YU %I:II:I
J95 BEI 993 9T 33 fBue &f Agas J | | I |
fen a0 € et AT HHAE (HTML) #sted e fen 397 fensHs aaa™ WS J | 3973
J&T WEHAT Jdd6 Ot BF J-
1. 3=t ym 5278, fem ua & mergetables.html a™ 57 A= & |
2. 295 & feanae 99 (Bewds € B, 2 30

"3 2 ) | 20
fAdae ad W3 Table> Modify> Merge P ol W LS —_—
Cells & fAdde aq |
S a .» - v po : =1
4. feir 37+ A® & Mufse 95 © wet g fifgrs | Humber of columns: 2 =
A% & fA¥ae a9 | Table> Modify-> Split
Cells & fr@ae &3 | Split Cells  f&w 3a7§ oK Cancel |
Ffe®Tar ITaH FH9 MEET I | (IFST I&T J)

5. fem A& & U7 39 (rows) € &9 Aufge aga € et Split into rows & fdde a3 W3
Number of Columns: € f&9 5 efeu g9 | OK 3 IfBT ad | fonrs feG AT eam dee &
AT J96 € BT MUS MY W3HHC g AT J |



6. Code View & AfST d3 M3 <style> "3 </style> ¥ R dz dev Ifencum € fg fausr
AeTfe® T BarfenT I 61 § [uT © ST IS d4 |

A% W3 295 € st fenw §aar€s € =93° a9aT (Using image

background for cells or tables)

A% w3 298 € &% At fera § §aarg's <9 34 Aaw 7| Jo fau gent & user gaa

AT A% € 5% §aqre's o fenm & Juy Aae J|

1. 327 UH 927G, fem U7 § Imagetables.html 3™ 57 A< d9 | (TG HAFCHS & fous €
Aga3 &4t J)

2. ufe-ufe 2 e (Rows) M3 2 &M (column) T &% 2% § fearge a9 | fam As © &9
3T §99r8'F Id< T J9Ad GH A'® € fEg 30|

3. A 925 JfSF a3 M3 Cell Properties & fAdde a9 |

4. Background € J&T, Browse 3 af8d 4 |

5. 89 w3 fen fera & fM@ae ad 1 Open 3
BT a3 M3 fen3d’ gmie OK 3 IfFT J9 |
fors fe€ A'® © f<o fonw Saares ==

HHS J It T | (3A<1T J&T J)
6. AT I3 M3 (F12) € 5% fen § ¥ ga'gra © f[Sg ev |

A% AT 29% A 3 aW d3&7 (Working with Cell or Table Size)

w™ 39 3 TTS AT Agls € S8 8% #Aer I 7 Aahdr oyt § i &9t BaeT | ae-av

3TS HS AT S98 €7 Aeid fsaufas 995 €t Agas et J (Bewds € &et, 8¢ § fewGe

®e1) | .t 3efsw (MEW) € 293" &%, AT A% 3 298 € Afed fsaufas a9 Aae J |

A% & Aeld 3 utddl 8T Bt JoT fdd JedT € UgaT 4:-

1.37t fAR A'® €7 U™ ATEl AC dd&T 9 e J BF A® € <9 gond § 34 | i U afsa
dd M3 Cell Properties & fid de ad | Add IAT fuams & Arfed fsaurfas aoaT gge &
3t gfse A ygHseA € f[ST a3 |

2. Layout € J&*, Width: & fAd ae g3 w3 (fuams € f9) 100 eEu a4 |

3. Specify height: & fAdae a3 M3 200 (fuan® € f9) Tfey d9 | M3 OK 3 BT J3 |
A% @ Afer 3 fors fe

’

& ane f&9 g=®<T (Converting Table to Text)

IHT AT AN AT (HTML) #ted € fS9 Table to text WTUHS € 93 Jdd 298 & dlcc
care € f[SU TEs HAE § 1SoB & cane R se8 M3 I © ge8= § T4 |

1> 1



R

J& faahut argtt fafanr=t a4

53t &99: M (Activities)

SH% MI.AMHAS (HTML) mBHe &t 293" a9d W9t HAS
(HTML) U & 976 |4 7S € §aqres €3 fena & Ae g9 | ufast
I & Had ad w3 Bfez a1 fek i

H&as

Jot f&3t yst gr=t g9

1.

1. 39% & feande a9a e muns——— iy fSg et 7|

2. 799 AT fam A A% €t §9qrg's fegurfas doar gge § 3 3A ——— mirums &t
<93 FdT |

3. Table to text € uAs—— Hig € ffg dev J|



A& 6: IA<taT (IMAGES)

mfgmma € €€/ (Lesson Obijectives) :
fer wifer & #ig f&9 3t feg a9 € Gar T A<4r ;
o M. FEfEE (MEW) & 293" &% 29 Un € &9 fonw & feange M3 istude
IS T |

AY9U3 A<avdtr (Relevant Knowledge)
fas fa 3t Aree T fg 993 Aat InSler § 29 UA € <9 mBIr-mIar sesem gieT 3
JueT Ryr X &4t T 1 Y. AHAT (HTML) mSted Sn<ler § mst 7% 3y fer 7
fene eare g5 fAe fa GIF, JPEG, PNG, W3 BMP |
JA<IT @U® JdaT (Inserting images)
Jot &3 aeHt & User a9d AT fend 3 IfEunae § €u% J9 Aaw J:-
1.3t U geg, fer Ua § Images.html 3™ 57% A< &4 |
2. Insert> Picture=> Picture fromfile..... & fA@ de a9 (IA<1T I&7 )

3. g8H J3 M3 MU Picture b gl FromFie. .
afueq f<5° an<la 'g':_>' Media 3 From Adobe Phatoshop (.psd)...

@ geaq, InsertIafss 7 7
a9 | Accessibility Properties & f&9 sTfesTar san &rd W8@er I | (IRS1T I&T J)
4. Alternate Text:, @ f&9 (ALT
neage) € cane § fagufaz a9 |
Gergas @ set, Sample Image for 7 Aemetsteit |
Demo & efeu a3 w3 OK 3 af8a Long dgscripton: | Bronse..._|
ad | fE'Fl' 3 g FREUAT f%'? IE) Tt I# Show this promot wheninserting images ok I
fesHde T A=t !
5. Save 3 IfEF &9 | Save Embedded Files 57& 3TesTar 97aH &Hd M@ar J |

g 3efew (MEW) fena € anit § Sanele © %39 f<u Ae J9e J | oe J4 fem
Junrete § fedtean € wet fioa fone dfufes R e m—
83 Yy Tag I3 AT AT 713U SfUSTT [y - o L o

o &9 €T Bt IR St Ugg=aitdT Had
AIAAHAE (HTML) UA 3 IR<TaT & ar
MBI giet 3 AeT St IEHT g5 | feg
fonfez 95 © &et fa Inlar SoAfee ©
WUST ORI © [ AT das S Agas J1 T 1 o

Accessibility Properties 2

Zancel |

Save Embedded Fles




W AHAS (HTML) - 21
a - . -~ - Qriginal file: Sunset. jpg Drgnal sizs: 69,52 KB

MSeT € % I foHA & changediie: it

M&SIT-HSIT 313-)?2- é- fe“q é‘-u- = GIF Eact For line art and computer-generated drawings. Only 255 colors,

Insuffickent calor For many photos,

Ha@' ﬁ' | fga' 3@8'1' éﬁgﬂ'rgct? I ;PEG Bios: For phokos, Accurate calar and small Fis size. Bad Far lins ark ard

- o - - =~ - computer-gensrated drasings.
g .re—g fE-H_‘l'r © STdH< ?=)_ = pmE-3  Simiar to GIF bug with better color support,  This Format isn't Yery cammaon

F' v N | ﬁ andisn't sapported by al browsers.,

TBI ITT Jddl [ PME-24 Smilar ko JPEG buk with lossless compresson and usually laroer Fie size. This
WE’T fg):';r H-rg’-];r E’.')— METS Format izt wery common and isnt supporked by Sl browsers,

:\ (é’ ﬁ ﬂ= %_5'_1_) Setkings: [ Use image asis.
=~ a. a_:/ a \= ’ Emity: !Tﬂ
Hdd SHI < dH'CIC =) HTE?'?'- Lowering Eheimaslity redoces theifile S22 of the picture
S weQerude I 3 fewer el B
= - - _: ~ - é’ Etlgiisﬂiﬁ iiliEETﬂJ-—:Iit.-' wersian of e piciire and'gradial i
fSeform § a8 aaa &
TY Hae T |
Picture File Type.... 3 IfSd gaa gt fend & gnifeet 3 eaHe § €% AaE T | Picture
File Type € f&9 sfesmar gan sad mBer I
(©) GIF § fAd ge a9, Aag 3wl fona & Ud da1 5% g=geT 97g¢ J |
() Agd AT AT gnfeet st fonw fAe fa fawte® avg €t ¢ & Tus dasT 9de

g 3T JPEG & @ de ad | 3HT fHag JPEG gaoHe Bet gnmfeet & »awne a9 Aae J |

(%) 7ad I feBHeHaH A AddiaHer € @93 dd6T 9'9€ 9 3T PNG-24 & fadae dq |

6. fer mifg™ et JPEG & fAd de ad | Use image as is: f<9° 9 § ger fe§ w3 fenet
=59 & faaufaz a9 | Begas € BT, fener 75% a1 MASt gurfeet € Bet Jus
THI 75 Ae ad feG |1 Quality: € Bet 75 § efeu dd M3 OK 3 € 9 AfBF &7 |

& Agd AT fena wated fa: fa Adobe Photoshop €t @93 a9 99 & 3T JPEG IA=TaT

wmuE vy feret @faet M3 Arele § Mag® J9 feet g | fed fag ot © &

feng fewr 3gt afoe fe€ | fenw sone 3 AH J95 Bt IT§ H'idd AT &< 8

IWIYA ABII € Aga3 J |

fen forw & fem < anrele © &9 AT d9 Aaw J | forrs fe€ Bfexs a1t fena efew &@s9

fone f<9 a9 m8er T | ge 34, feg »mw fore &f fifq amut dut get I | fer »et Ag9

form &t gurfeet At Arely feo oot a3t 9 At I 37 3wt fen 3 g9 aH 99 AT |

Cancel |

fer# € yusdta § ges<T (Changing Image properties)

Had gt fene & feande d95 3 i fenet yruaeiya § ge8eT 9ge ¢ 3T Jof f&3

FeHt S UsST a4 -

1. fore 3 € =9 afSa &9 | It Picture Properties € 293" (3R<1d J&T 7, ¥9) Ffestar
gIH & Tue Bet w3 fenet Afdar § gese set g9 Aaw |




alx 2y

Generel | appearance | Generdl  Appearance |
Picture: ‘Wrappng sode
|Fureet.po Broe. ., I Edt... |
Pictura Fila Twoe.. I D D D
Mane LafE Right:
Aneszbiky
Layiut

¥ Akminate Tegt: |5ﬂnple Image For MEW Demo

dlignment; |"qu$ 'I Hevizonkal margin: |_D—:i

Long Description; | _';""ﬁc_l Bovider thicknesc: | :I Yerticd margine |0 :g
Hypestink: Slze

Lacztion: | _Bronsz.. | ¥ scedfy ses withe o0 4] gt oo
Terget Frame: | i?] Parametats. . | * Ntk o natiak

1 npergent i percent
W kzep zzpect ratin

o | coed | [ o | v |

2. few fersr & Al se®< &1, Appearance tab €8 & fidae a9 | (IA<te €ug T /)

3. Had IAT fen & »Ast AvetH 97 50% Areia § we@sT 97de 37 In Percent &
fA&ae a9 mF Width: m3 Height: €& € atH3 50 efeu &9 | OK F afda a9 | forms
fe€& 3uvé fen e nizvAe 13T Ifenm Arete feuret €<ar | (F12) € 578 AT 2 ¥ §'8wa
€ gE®'T § OY HAT 7 | fods 5% S8 migedae Sane € a3 <t &ad mEEt |
et 3efsd (MEW) T 98 »3 fend © #Mehie © &t fagsT a3 s fapr
TEREeu

Wt feg fradt 3n<le &% dW a9 99 7 fAdeT Aeta 993 &37 J (7 Adt Addls & d<9

gde) 3T AT feHd €7 8¢ T9As (GHE®) a7 AT 7 | fAng fa A< afda atgr Ater I 37

AT € MAS ATElE feyret fder 3 | feo aet 3A<iar € &% < gATele g8 f@9 Hewe

gaeT J fARg IAT ST d9d TH Hae T &7 J 3137 J9d, 7 fd U< € &9 Ao Saer I |

HIAMHAE (HTML) wiFtesd € &9 mus Wy 8Has ge8< <t mida J w3 feg

fera € st Arfen § f&a aoer 71 e ® g8 wet Jof fe3 gent et user ad |

1. 3=t U 9@, fem U7 & multipleimages.html 5™ 7% A< J4 |

2. Insert>Picture>From File.... & fA@aec d9 |

3. Ctrl+Click € =93 ™% IHt 993 Aal In<lar & fdae a9 Fae T (fem mifanmr € f&g
3% 3-4 FF AEIH BT A< € Ag93 UEal) |

4. Insert & fABde 99 | MBedde cane & &3 fe€ fen & gnt gwme <9 &t AHs a9 Aae
7179 feq foriw & &et feq @7t OK 3 afSa ad | fevw & Aelw 3 fonrs ek

5. fore & fAdae 99, HA™ ¥es AfBF I3 M3 Auto Thumbnail § fAdae a9 | gat gat
ferm € ®et fen fedt & gaa6 | P ——

6. Fa TR T T s fewret a2ar File>Save |

3 a8 AT AAAT (HTMU) Aetes e | oo
&% IHI gaT fedd § A< dd& & dfin o9

Aae I M3 Iot 3rfestar gran feuret €2arm| | Auto Thumbnal



7.32 99 fanmg efes € s RIS o 2l

&% small @- 5T fga-“ dH@qldi Embedded fies to sare: | — | FiCLure previsw;
v N Mame Falder Ackion
€THS ﬂ'ﬂ? Ji fEU & wirter_small jng Save
WA AHAS (HTML) B wirter jog Save
= - - I ﬂ Water flies_smal.jpg Save
NIted © &% g°¢ I ) viater e jog Save
9HE S € 906 I& 10K T B curast vy o
et
Ffsa J9 | (F12) € 3% It %:: B sl e
fer 29 UH & Y Aaw T | Ja =
forme & fors 7% €1 |
o ~ = T 99 i i e
HOH & 678 = Jd Fenanme Change Feldar. .. | SebAckion.., J Pickura File Tepa., |
fena & Y Aae 3 W3 fone

o I3 TIAS THS HEl femy ok | oo |
BT 9 |
8. MM E1.398T (MEW) & AfST a9 »3 35 § €4 |
oS € A § gE€82T (Modifying thumbnail size)
A'd 84 ® © {9 fore e fea nes9s el der 7 | feg o.M s (HTML) m3teq
ot fse®e Aféar 71 3T& : x|
WW%W‘@?@ ol Coding. | futharing | F‘il:t|v..|r: | Fuler and Grid I IntelliSense I Font Familes
N = P Ganers| AutaThumbnail Defaull Fores | CodeFoematting | g5

#1993 J few = prfew forie _
3 9U3 g7 d<dr fas fa :
IA<T AT ITF BT 8¢
Afeq =t forna e »igg
JI&T HAfA® J<aT | BHS S
T AEld & g€ BT 96
&3 gert €t useT aq;

1. Tool-> Page-> Editor
Options...& A& ae ad |
2. Auto Thumnail tab &

fAd e a9 | (IA<T IoT J)
fsewe <v9 3 fours
fe€ 1 avz © <9 3aetst
d9d IHT ATfed & €%

] st Jlio =

Aod J |
feq =79 A< feg Arfed 9%
Aer J 3T e 3 e A o | concel |

3 ﬂ. — o -~ @-\ ﬁ'
It §F gefEmT Ifewr rrete S9fdT ATeT T (Ud'eT §HE S (98d®% WA% §Ha® & ATEH

g1 IIam) |




ISt 3ASteT § Hg®eT (Handling large images)

Hod g8l IASIIT & 3T TIns B 9t &5 € 9 feyforr arer 37 feg T Aaer J fa
SRS § TUS BT olar g AreT fedied § I &7 Far | feve 7% st At Insia §
&<t @3 @ &9 4% Ade T | vifAdT 995 & &t ;

3. TSt n<tg € €3 Hrr ges Jfsa 21
dd M3 Picture Properties & et brarires peoe Comman teegeks
fﬂm?a = - Page Default (none)
ad | Same Frame
Whole I_?age
4. Hyperlink Aewma € f&9, Target News Wil

{none)

Name... € »a® g5 &
fA%ae ad | Target Frame &%
FresTar g &Ad MEET I |
5. Common targets... fave @ fS5° Lorget selting

New Window & fA&ae &3 | OK ! : .

3\_@_%13_ ﬁu a%lﬁ gFﬂ- l-:n"::_,_ninrr:j__u‘

U § A< J9 w3 ferel ¥8a (F12)
v 3% g8w9 9 2F | ufgd 8Ha® 3 afda a9 M3 IHT fegrg f[<g eoa &4 |
6. "H.et3efew (MEW) f[<T 928 M3 I3 4 |
IA<tar € mBTE&ar adat (Aligning Images)
IHt San dee € &% <t AT § feand (ETfes) a9 AT T (98 YATHAT MBEtane
o 397 | JoT €3 et & ugeT g9d AT fen & fean d9 Aae o

Cancel

1. 5= Ur 9275, fen & textwrap.html € 3™ 5% A= &7 |

2. form & feswge a3 W3 fenw € JoF AT Gud g3 Sane &y |

3. fenm § @ ge a3 M3 Hw 9¢& 3 AfET g3 M3 Picture Properties § i@ de a9 |
4. Appearance tab & fA® de a9 | Sane JU J9& Het JfidT Aeets & g de a9 |

a2 Av
I

9 259 & B de a9 (7 Aga3 J)|

5. Alignment: 337U 378

6. Border Thickness: 155 {9 8T M'ed dd6 HEl IR €7 §7959 (690143 JT |

7.OK 3 AfBF J3 | (F12) 3% A= d¢ 3 < ¥ g0 <9 fen & g8q &4 | fer #aci=iet
< BET AgH 93 <t < |

3A<tg & wifse d9aT (Editing Image)

fawe-fes for goug & 293 5% It forw § wifse g9 Aae 7| A= & IJU JIs HeT

oM

, O & We-TU A ded™He d9s © BT AT § Mfge a3 AT AgeT I | J&t fe 3 gent
&A™ FH fed g&ag & Hew &% fedid 3 dH J9 Fae J |




1. 3= yw 276, fev Uw & editimage.html 3™ 5% A< J4 |
2. fee & feswae a3 M3 View> Toolbars> Pictures & fAd de &4 | Picture Toolbar
feyret g=qtt (In=te Jo7 J) |

FERER cahdoosel v FrBme %%

3. IHt et famy © SamaT @ 293 dd Adw J fA= fa:
(€) M TS e efdy mrums € <93 575 A< & efdy a9 How T P
(1) femeat 91a AT @9 (brightness or contrast) f&9 =g A wrer Jer 3fder I |
() I3V (In<TT &< fan fIw &F Ages I €7 & ot du=t )|
4. I3 95 € BET, I3V 2F g & S Fe a9 | ferw & IV F9w €t Ifan a9 (B 39T fre’
ST fai gH Aeeen@ € s B AH 13T J) |
5. A2 J9 M3 (F12) 3% < ¥ §78w9 © &9 feret v&a ey Aawe 7 | fen waci=ie! f<g Han
dz S ey
fede @ grare 3 X J9aT (Working with image formats)
7e gl fena & fearde gae T 3T A 9. AHAE (HTML) #Sted § 256 dar At ufe Jar
TH RS & Bt GIF grare M3 256 3 frmmer dar @75t In<ta € Bt JPEG gane <F
93 JaI¢ J (feu Uit ) 378 et =7t faewe feegg & gese & Ages U Aget J |
A< AT frmeT39 AGETS Ae € &% fan @3ue erdee fama a9 30 7 376« PNG &t
T93° g9 A J | fer & Aféar & gese AT Sy &et It &3 ger & useT g9

1. Tool->Page Editor

Options.... i e &7 2/

M3 Picture Tab & fA&ae
- General | AutoThumbnal | Defauk Fonts | Code Formatting ] 55 ]

J | Color Coding | Authoring  Picture ] RuerandGrid | InteliSense | FontFamilies |
2. JTUFEE Mg © feT Defauk e Type Settings
Value 3 fors fe€ (gif Mz Click File Type Sektings to change the default settings
ipg) | SFﬁ' for 397U 3_@_5 F:;jan:erting files and pasth: images,
ﬂ ﬁu—..ﬁa a\—\ Default File Type C i Paste Setti
3 a‘rg' = (] ypE. ONYersion and Haste I ngs |
= A~ . - - Use the Fallowing farmat when converting or pasting "
feraeaie S ges Aae T images with 256 or Fewer colors: ’
@?"UH?)_ @- B-g'-]- =r=n fg):'ﬂ- Use the Following format when converting or pasting : =
= . . NV images with more than 256 colors! £
256 dar A few 3° <y dart
TE fumet T 3T €< AT
AYAAHMS (HTML) WSted & PNG ferw eane € 93" J9& eI HAYd Jd6 © BTt
Use the following format when converting or pasting images with more than 256 colors:

39U 3795 Mg ST PNG & fid ae a3 |
3.0K I BT FT |




fen § 99 d96 Bet Jot ff3 gent & yseT g9
1. 3T UA g6 |

2. A4S AT &< BE vy ot §33 3 Ctrl+Print Add1s € 293 94 |

3. UM S A= &3 |

4. forrs € fera graie PNG manens &7 feyret e<ar|

3A<TT § =T8T M3 MEIH FIaT (Creating and optimizing image)
Had AT S8, WiFte qI5T AT MEgH JI&T IY T I 3T USHES g¢ mIIfEar Areeenid
fa=" fa Adobe Photoshop, GIMP (Open Source), Microsoft Expression Design (Freeware), Google
Picasa AT MT&&TEIS METed Argeand fa= fa Pixlr (www.pixIr.com) €t <33 ad A T |

Jot &bt aretwt fafenr=t &9

%3t &99 M (Activities)

fonm & fearge aos et HI.AAMHAS (HTML) UF § 576§ w3 Aat
1 IASTIT T ALT SIHC HUTHT Ja=76 |

gU3 At AT M3 EH® € % M Y. MHAS (HTML) Un § 576

2 ~ o pu om o opu  w py - o =
w3 fend fea msar @3 € ST ¥o< BTt Jafcdd dd | THeH BHaS &7
AT 50*50 fuaHs g6 |

3 fers zwag &t <93 &% fonw & 9Ha § I8 |

H&as

Jot &3t yat g=t 39;

13T § e B el gt — Mg S g3 qg Aae I |

2 & 3* frmme IASteT & S8 B8t —— Frede ot €t <93 di3t Aret 7|
3 fse®e 8Ha® € Afen § ge8e e ——— \ig & =93 A3t AEl I

4 form gBg9 § — fe@ ilg &% gy disT Arer gdter I




A& 7: IeUaf&a (HYPERLINKS I)

mfgma & €€7 (Lesson Objectives):
fer mifgmm @ wig f&9 3t feu a9s © Gar T A<ar :

o TENIGT T 5% STl g€ T

o TTENIBT &8 T-HH% MIdH T8 & |

o TENEfET T e s ¥ Tl € R gn S Um g€ €
rdfag Areardt (Relevant Knowledge)

IEtuaf&a 7% W adaT (Working with hyperlinks)

Ho9d 3T a% I¥ W3 & a 95 3F 3074 97 fousT viAs J2ar I Ug Add S 9 UA ©
feg a<t f&a wiis g g (B <31 Anar &t asusT ag fan f[Sg aet 7 S g AT & Ager
Uer J), 3T %39 dF & feus aet yafas der 71 f6a gt Ae.davms (HTML)
WFted € T93 5% dF § MTH'S 9T AAE I |

AT € &% JITEUIE T adsT (Hyperlinks to websites)
WI.AMHAE (HTML) »ites ST oetuaféa 3 aW a9 &et Jot fo g gent & user
. e 43
1. ?ET ﬁT.r WI'@’ fgﬂ' ﬁT.r ?;5_ Link to: Text to display: |www.g:0gle.c0m ScreenTip... |

links.html 3™ 5™& A< dd |

2. URL & eetly a9, Gewas €
gt www.google.com MEI UH
a9 | fors fe€ 2ame MU

Lookin! | o MyFirstebsite j g g
, : !‘ links Atml {open) a Bookmark. .. |
Curent (1 Biue fills

@j Elue hills_small Targek Frame. .. |

| default

images Parameters. .. |
lirks

WY N T ATeT I I Rror
U glua I‘Eﬁ a X IéH |@'€| 5 I = (8] Sunset_smal
§ - Ji - @% Water llies =
3 ﬁ_Q" aﬁ' 7}1'3\' (F12) @' 5% é"—a- 5 Address: |nttp:,l',l'www.gougle.can ] Remoe Uik |

E-mail Addrass

TEme e fegenifenan e o | oo |
e Hon a3 S 28 | Add AT ggw 9 fa URL &9 Same § sefen a2 37 Jat &3
FeHT &t USeT J4:

4. " 39f8T (MEW) &9 AfST 33 W3 IaHT & TEIULféd =& Sane 3 J4 |

5. 77 9¢& 3 IfBF g8 M3 Hyperlink Properties.... & fAd'ae a3 | Edit Hyperlink 57
STe®Tar 979H 5Ad MEET I |

6. are g9 & f&9 Text to display:, f&¥ ¢ame Google & www.google.com 7% €& | Ok
3 IS a9 | fonrs fe€ Tame getuaféa & f<9 gvs farir T (feu f&a g <t Gussn
I




feahuistn § san@e € BT Hew®! TEheféd eus d9s T3 Jo° fed gert &

UBITdq

1. 5=t 4= 978, fer U § manuallinks.html 3% Ae g3 »3 fAg 3rt oetuaf&a Jfteur
J g9ng & € I |

2. Insert>Hyperlink.... & fi@ae a9 | (A 2%
CTRL+K Heae &b € T93° 99) Insert Sireenti test:

Hyperlink 57 3Tfesmar aH sAd m8er I | |

. a ~ py o . Moice! Cughonn ScresniTips ks supporked in Microsof e Inks: et
3. TEXt tO d |Sp|ay2 CAHCHAH & hq Wl kIpEdIa Expiarer @ verson 4 or later,

Inca da (feag @9 s T fagsT grt feyBer
= = = ok Cance
wde T) | B

4. 7€ 9T & TENLf&a & €3 UnfenT wier I €€ f&a € Gen § fewGe met
ScreenTip... 9¢& & fA® a< 9 | Set Hyperlink Screen Tip &7 3Te®Tar §7aH &Hd
meer I

5. Use Wikipedia to learn more & efeu a9 | OK 3 BT &7 |

6. http://www.wikipedia.org in Address: & 2oy &3 "3 OK 3 BT J9 |

A= 3 M3 (F12) € 3% 2 ¥ §'9w9 © ST fenet v&a 2v | faase 8 (8w & gretuaféa

3 Y= &9) | W .EL.3EfEw (MEW) ffT 988 M3 35 § €4 |

fen® W3IH © BE gEluafda ge@<=T (Hyperlinks to an email address)

1. 32 UF 976, fer U & emaillink.html 3™ &% A= a9 M3 fHE IEtUaféa I dard &
Su 3u |

- . st iparink )
2. Ini?rtéa;):r:erlmtk... [} T —
g nser e |
aidress:
Hyperlink 7% 3Tfestar Eusen ot 15“
I9H & MEeT I | . : f“’“
3. E-mail Addresses & il e T peromens,.
fA¥ae a9 | %
o Creats Nes
(©) Text to display: f<9 Dot
&8 efeu 99 (feg : =
ferersH I A7 Y gEwe | e
2 feg feyrehy ar<am)
(™) E-Mail address: € fe9 & €& W33 H ety 949 | (Ev9s © Bet
feedback@example.com) | fors fe§ mailto: Medtfege few ffg My iy wivs T

THarJ|



() Subject: € f&g a3 & ey a9 | (8€was & &g, Feedback for website) feg govst
"% & 89< &9 Hee J9ar fa feg fag" mret Ty g9a §€° A 3wt € eis mzan
ot <93 aet Gen € wet aov 9 | feu faefon a3t et T fa fefres & eizga § feds
IS BET T MBIT T-HS WSIA €F <93 ddat Iatet I |

(M) OK 3 IfFFT a7 |

4. A= I3 M3 (F12) € &% 2 ¥ g8+ © v fen & s5q 2v | fons 575 ehis asrfee
GUs T IMUS are M3 3T & IAS THI Seled © B ENS I3 § Ul 83¢ 9%
TH® MIIH MI ATHdE MUS MY HTHS J AaT J |

29 UH & &9 WHar »&dr AdEs 578 f&d d9aT (Link to different

section within a web page)

WY AAHAS (HTML) M3ted €t 293 &% Inl ¥ Un © <9 »sar aar ianst § f&a

a9 Aaw J | fer ydHteg § mHs< &et Jof fE3 aert & User a4:

1. 3=t e 9278, fev Ud & sectionlinks.html 5™ &% A= &9 |

2. WYAAHMSE (HTML) 3Tgie € f&g We e € Aans 976 (Faws € f<g =g &t
Aun & 3 feb, Bust fegarg ufe-wie 10 &elat) |8ewds € &et, Adns 1 M3 AdHs
2 (AT T&T ) |

&< Un ¥ Qu3 gy AuR § &7 febi

Bl untehed 2 (imtaied_2 sk} - crosef Exareasian Wikl

Fie EdE  Wiew e Tows abie  Sits DishaVeews Ponss  Andow  Heso
R-Ew-E eSS DD D
Fotder Lt p Shm vess  Linmlied 2 el
L R R e
Y e e
Bookmark 2
Bockmnark name:
Oither bookmarks on this page:
Clear I
Go o I
K I Cance! I

3. Section 1 (Tret®Tfee) ¢an & fAd a< ad | Insert->Bookmark.... & fAd a< ad | Bookmark
&% SESTa IFH &7g MTEET I | (RSN I&T I, HA)

Bookmark name: f&re &9 anH® 3™ 3 fors fe§ 1 et sefesd (MEW) mruE Wy

3T BEt U9 g7 feer 71 OK 3 IfBF J7 | AT AdHST § FaHS A9
»et feg fen gt €91 § €909 |

4. < AL AGG® § U 3 & F A§ g fa f&a & I e 71



5. Insert->Hyperlink... & fAdae g9 | Link to: & 3&T Place in this document.... & fAdae
Eoll

6. Texttodisplay: [y
ﬁm @- 1%4? Link to: Text to display: | ScreenTin...
Section 1 2TEy
Jd | FIHdT &
Jd&t Section_1&
fBae a3 10K 3
BT 3 |
(JIHIT & HeT
CTRL+G §=393)

Select a place in this document:
] Bockmarks

Section_1

= Section_2

Targek Frame...

f I

a S~ oV
7. HIHS 2 € I<€d

X 1]
EITE:]-UB-F&—O(- AHS E-mail Addrass |

18] 4

Cancel |

BT § TEIIT |

A= 3 M3 (F12) € 3% 2 ¥ §'8wa ¥ f<U fer €t 35a €4 |9 39 fa gethusféa afea
96 3 X 99 fagr I | gt FEfsw (MEW) i se8 i3 a5 & 4 |

&C: Ha9 IUTS BareT J fa ITF gA9T yat 3T AdT IdtaT Mus g © gege = fFx
At IS &% o1 &dt o9 faar T 3T feg Wy ane @ &9 fAn € a8 UA @ 578 Jetuaféa
M3 HaHG 6 fegdrd ufe AUR 9 a9d T AdeT T (BUd I&T AAd® Jd6 © St 993 &3
G )

SgAEle € fega9 g4 €9 UA &% f&F a3a7 (Links to another web
page without a website)

gt ffg Gt Sanele € fRe fa ST Um & €4 29 UF © &% & a9 Aaw I feg

feriicand & U3t LUl f[S9 € AaHs § vye ST Hew qdar fan fRe 303 <&
fomr €3ume AT Aafer 979 ATeaTdT I Aaet J fAgst fa IRt HaehT qa=@e T 1 3a7 fea
geHT € UsST J9d IAT € UAT § = < gATfee © <9 f&F a9 Aaw 9

& I M IS (HTML) efest € 293" adar 7 fa gnt ufost sevga 7|

1. 5=t e 527G, fem U7 & weblinks.html 3™ &% A= a9 »3 fag At oetuaféa duer
Ige T J9n9 § €7 dH |

2. Insert->Hyperlink..... & fAd'de &3 | Link To... & J&F Existing File or Web Page &
fAgae aq|

3. fors fe€& Samrete € <9 30§ ofest &t fone feuret e<art | nl A<t € &%
Jet 2t erfe® g Hae I 1gd0 R ¥ UAT € &5 f&d a9s © &t 3078 fage f g uyAt & ot
A& de gaaT grater J | fgre & fE9° tables.html & A& ae aa | Text to display: & f<9 Tables

& Tfey a9 W3 OK 3 If8a a3 |




4. AT d3 M3 (F12) € && <9 g'8wa € <7 fon &t s5q €8 | 99 99 fa getueléa afsa
95 € §°3 I gaeT I ? #H.eL3EEE (MEW) ST 928 M3 35 & € |

Jot fe3tut arehut fafanr=t &3

3t &99: M (Activities)

1 ufe ufe Ur SEAmele’ € BT e Rf&d 578 7 A I AN AT (HTML)
T Bt He3 € fI9 feGedh® Um daer T IMTUS 8is m'san § Teluaf&a
TH HHS d4 |

5 fug® wifenm fIT a8 g yAt € Bt Il 9a78 |

1 getuaféa mirums = f&g fuser 71
2 —  Wdede at TEtUSfE § fearae aaet T

3 AoHG & a9 Jd6 BE—— Hdede ad <93t Aret J |




AR 8: TrEluadfda -2 (HYPERLINKS I1)
mfgma & €7 (Lesson Objectives):

fer wifer & #ig fg 3t feg a9 € Gar T A<4r ;

o 3IASIT € TI3° & TEUIUI&T g @<= T |

0o

o fEcddfes e €t TdT das & |
o Jeale €t 293 ads & |

mafug Areamat (Relevant Knowledge)
fues mifgnm feg gnt Sam ST odtueféa & se@< g9 iy ga 71 3t fors fasr
g fa SErrete € &9 gelusféa § Aoer se8< € &gt AT af SgAeter § f&a ags
€ BT 3RS AT gea € =93 J13T gt 71 IHT i gt sEfew (MEW) € e ufost 3°
Hg< Afeur €t 293" 799 ferw & oehuaféa =7 =93 Fae |
IA<taT @ =93 7% TrEtuafEa  (Hyperlink using images)
At 3ASIT € =93 &% f&F g Aae T A fa@ 3v§ Meddfes ges A IASII §
TESfEa @n T93< < afeur féer 71
1. 5=t U7 G, fer U= & manuallinks.html 3™ 5% A= d4 |
2. ferm & feanae a9 | fena & fAdde a9 ,3 Insert>Hyperlink....§ fidae a9 |
3. http://www.download.com & fAdde &3 |
4, frmmer3a gretueféa & G feg <9 dfenm ater I fan § fedteaw Syer I 1 Hag gAt
st g9 fa ferited 309 fuAele § &3 3T It oEluafda & Sa v o<t g € fSs
U T B T S IR G REAIRACTI
Tetuatsa & fg ot 45 @ foT dme @ met Target [
Frame..... & fA@ae a9 |

5. 391 €3 & ABde g3 m3 OK 3 IS 7 |
&< BT 3In<tat fagst © &9 oehuaf&a sSfaprr ,,:m'"‘j,"f'wmmmw
Jfewr ger I €T eane fAas It feurfemT fapur &
& feu Qe g% ( Ag9 At SHEEHs ST UA §
WYAMHAT (HTML) wstes € &9 dger
gge J 3T Ctrl + Click € €33 a9)| A< IAT
WIS HHMS (HTML) #ited 3 oW dae 7 3F
feg gost oetuafda © f< fora €t ufga ags
feg oo qger J |

— |

lUSB Crl+Click to Follow a hyparlinkl




6. OK3 TBT AT IAR II w3 (F12) T a B g gErd e o fen et ssa e Igaad fa
TENSET FfBF d95 3 IH FaeT J | "H.EL.39@T (MEW) & 9% M3 335 § ©F |

féedafes ge5 € <93° adaT (Using interactive buttons)

gt fonrs fezr g fa 29 uw € <9 getuaféa & oeiwele d9s et faus ges

=33 SISt At T | It In<taT AT €6 (Boring) ¢ame € af At feg féedafes ges M3

fesden & g=rg< € Bt ».et.39fsw (MEW) €t “féedafew ges” &f afeur & =93 Hae

JI

AT JoT fe3 FeHt @ »igHT feeddfee 9e¢& 9T Ad< J;

1. 3=t U7 g9, fer U= & buttonlinks.html 3™ 57% A< J4 |

2. Insert=> Interactive Button... & fA®ae &3 | Interactive Button ™% 3Te®TaI 926 &1
meer i

(€) Button: ge&t f&5° At AeEl® & g< Aaw 7| §ewds € et fene <9 amm
U 15 B ae a3 |

() SaAe & f<9 Button Text & fan <t 5™ € &% 528 | §€79s € g, Morzilla

(¥) Link: € f&9 URL & efeu a9 1 8emds & &, hitp://www.mozilla.org

3. OK 3 IfBF a9 | AT g3 M3 (F12) € &% = ¥ §'8wa © <9 fen & s@a €4 152 ;
3A<T & AT d9& B 397§ A &t Yfewm Afer I 3 307§ 99 =4t OK 3 IfBF Ja5
o Age3 It I

4. 9F g9 fa ot TeUef&a IfET q96 3 N J9eT J A &d1 | M .ELFEfEsw (MEW) fEe
gO8 M3 dF & EH |

Jenten & 93" &7 (Use Hotspots)

fer Jenuen fea ot fenm € g% 391" €t <93 WHI-HSBIT = ¥ Un AT {&an € et gger

T 18TU9s € B, IHt T9%3 € 390 & AT € 3T HHS dd Aae J M3 fen 3A=ta €

NEI-ABT 91T § < AT © &9 f&a g9 Aae T fAneT 99d €F € Bt Suar dee

J=ar |

e AT fere € g% 9791t § AU fAs’ fa 9, S anele A 8% M39H 5% f&d aaaT

gde T 3T IEUSfE S fHa® fene © g9 9791 ©f =93 a8 aees Jenlen § g8 Jet

dISt 7 Aaet I | Jenden § s &et Jot &3 et & useT aq:

1. 3=t yw 275, fer U & hotspots.html 3™ 5% A= 3 |

2. form & feswge a9 (87 foriA €t <93° a9 fAn € HBIT-HSar Iar & TI83 &0 &
TINET BT A3t A Aae! T A"’ mBar-»@ar voreiut § few@e € &eh) |

oy
|

3. View->Toolbars->Pictures & i@ e ad | 3A<19
)|

9 ZBYd SHJ MTEdI (ALY I&T



EREN cahCoese v FrBme %

&< 39 e »reter &7 H3BY AHST Bt 99 T MElas I qgHT & 8 J AF |

4. IR € g&d fE9° Rectangular Hotspot & fAdae 99 | gonad § 98 (Us &t
3q feuret €=, Aadwa AT T IS § ISP BT UTH 439 € §°F 391 a9 (few yar
gabT ITENURT& T g A=) |

5.yar I 3, Insert Hyperlink 7% 3TesTar g7/ &Hd #TEdT |

6. Address: € gt URL €U &3 M3 OK 3 If8F a4 |

7. A< g3 w3 (F12) € ™% < ¥ §'8wd © <9 fen &t s« 20 1 99 a9 fa &g gretuaféa
BT q9& 3 IH FaeT T | "H.E.39%T (MEW) ff9 928 w3 35 § ev |

mfgm™a
JoT feghdt arehrt fafamr=t a9
B3 597 X (Activities)
HIAAHAS (HTML) U 9278 M3 mE&aT-msal fenat & fearde a9 |
1 MBI-MBIT <L IAEIET § BT &3 € <9 19 a9s € BEt fenar € gt
WMBI-MBIT TENI BT 576G |
Jot fag g fefipnt € 5" Sa<t fora © 7% M. mH s (HTML)
Udq 957G |
- (€) H& Tt fermar &t 3T (Anatomy of human brain)
(") HS Y AaTa € 39T (Anatomy of human body)
(¥) §%9 © faw (Parts of Bulb)
(1) SfuGeg & faw (Parts of a computer)
(T) e &t 39&T (Anatomy of a flower)
feeds e 3 niactas fae fefafustm fe9 99 Aoms @ g9 U Jev T
g9 IENIfET HIEHT aa=Tfe © el fona Jenlen €t €93 ad |
3 feseanidele 926 ©f 93 3% < gAee € A9 UAT 3 SIS Hig
75 | MTUS H3Tfaa ges € &1 fe6 | (Fa3: wa € &g HOME &t <33°
)|

Haras

Jgat f&3t st gr=t g9

1 feedafe= ges g &% fesnae digr AT J |
2 feH® JerlUed ——— g&Y9 &% gSTef Afel J |




A& 9: M6 W3 316 (AUDIO AND VIDEO)

mfgna & €7 (Lesson Objectives):
fen wife € #i3 f&9 3 feg a9 € Gar T A<4r ;
o WH.EL3EEE (MEW) €t 293 578 29 UA © ffg msie m3 SifsG dee §
fHsB= o

e JFUA < 9 87 (Flash) e7fe® AT =T & €48 95 € |

o T UFT fTT fAm=amrele (Silverlight) deT & NS J96 € |

AY9U3 A<avdtr (Relevant Knowledge)

ST HGIAAHAE (HTML) Hi3E® € 9 wst6 w2 1516 dee § e agaT fHfumr

J | At ATAMHAS (HTML) #ites € 293 w3t w3 St516 dee & i@ emz

9 AdE J |

BT I MIAMHAS (HTML) 5 mStE w3 fef36 mighier &t =93 St ag Aae T B

& feanae a9& Bet a3 <€ & =93 39 | fen mifgnmr © iR st vz SE6 afEu e

g% AUS famma v |

WEE M3 |FIG dee § AHS 95T (Including audio and video content)

WG IFFY & AHS J96 € Bl do' &3 Jert e UseT a4 -

1. 327 U 9278, fer U & audio.html € a1 &7 A< J9 | J9nd & G d4 fag grt mste
UBHd ded® & JuST 9ge J |

2. Insert->Media>Windows Media Player..... &
fA@ae a9 |

&2 W Ersefeg (MEW) mrue iy (fserse) fige

St eelxt € gat 9t few@er g # fa &3 vighur

STEI® el € 5% AYU3 e I8 | Files of Type:

FIU 376 &9 All Files & i@ ae a9 |

3. w36 AfSy & B 'ae a9, Gevds & e,
sample.mp3 | I Insert 3 BT T |

4. Save 3 IFBF a9 | (AL Yfen Arer I 3 fen mrstG IfBy § mrust Sarrete € a7 % A=
g9) | PH.E.398T (MEW) ¥ &9 fonrs &7 farse & €8 | (3In=i 29) |

5. AT g8 M3 (F12) € % 29 g'8w3 © <9 fen €t s&a €¥ |

&2 A¢ Ud & dfgp wier § 3T S1S16 afdu mrus »vy udn (Play) § Aet 9|

Had AT fen S516 afsy et Aféar § geser gge 7 3T da 63 aedt & useT J49:




6. »MH.g1.39fEw (MEW) f&9 988 3 Windows Media Player Control 3 € 79 af&a
&4 | Windows Media Player Properties 5% 3Te&ar a0 A3 M8 e I 1Gusgu ded®
3 fonws fe€ (3n<te Iat I)1

windows FMedia Player Properties >
Giereral | Advanced | Obiect Taa | Parameters |
— Source
| File Mame or LIRL: rm Erowse. .. I |
Conkrals lay ook
Select & o [Fan caeraucs =1
FPlaver = eambedded with the scscus windows, sesk bar, placipauses, stop, moce,
nexkt, previous, Fasec Forveard, fase reverses, and volume conthals n additior b I:he
wideo oF wisualizabion vardow .
“Plavback aptions - — Yalums setkkimgs
I+ aukc stare I P
...........
I Stretch to Fit wolume: rir I (2 BT
I Flay full screen N s .-FI. M e
I
Flay counk: I 1 E_ Balance: L ) =8
| Ok I Carncel I ey I

7. d¢<T & UBM 95 BT, d3d (CODEC) (7 fa fed Areeen@ dusd e J fAnet fa udsa
EE’fﬂdds get 9) ferles € dfuBes f<T 7ge Gudwy ger gdter J | 79 feg aat
fiser 3t gAY Aon & I38A (CODEBASE)W@WWMEWWW
g |hﬁ2€?w@mm(CODEC)8§aﬂa€W & Wiedifage a39H (CODEBASE:)
v <9 fsgufes a3 URL 3 57€%83 qddl-lﬁmgwwmaw
JJar |

&2 : AT URL € B¢t AUz S9ATEle @F g% fef | 303 set fg 99 wiH <93 <9
T % URL'sfEa I o5 ;

dee ey 38583 BaHs (Download Location)

Quick Time (WAV)| http://mwww.apple.com/gtactivex/atplugin.cab

QuickTime (MP4) | hitp://www.apple.com/gtactivex/atplugin.cab

Flash (SWF) http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/
swflash.cab#version=8,0,0,0

8. TFIG AfBU § AHS J9s BT fer a1 § T I AT q9 M3 (F12) € 7% 2 9 §'8wd
v f<9 fem <t g3« 2 | et safeg (MEW) ST ge8 »3 95 § €4 |

eBH MaHAs § fesAde a3aT (Inserting a flash animation)

Hdd AT TBH HSHHAS & HHS Jd6T g9« g 37 I f[E3 gen &t UseT a9

1. 3=t Ud 276G, fev Ue & Flash.html a™ 5™ AT J4 |

2. gqoAg § GuIH fa g At eBH MatiHs & JueT 979 € 7 | Insert>Media->Flash Movie. ..

afﬂm‘c'am
3. THH MaHS & 5 mI Mdae a9 (e .swf HaneHs), Insert & A& ae o9 |
4, H—eravmy(F12)€W€'88T@?|H€fevfsne°rm€mws°rs¥rfmr(MEW)

fSose@ w3 dg g ev|



Had IAT FISIE & IHE J96T IgE 7, §€U9s € &t fA= fa Youtube.com, 3° d&t f&3

FeHT S USeET 39

1. < U7 9279, fer U= § Youtube.html 5™ 5% A= &4 |

2. 39nd & §F JIu fig AT |feQy (Youtube) FIF16 & Ty gde T

&< ufeQy 3 36 § fearde ags € et 3ud fene a1 § AHST € Agas J |

(©) Youtube.com3 A& |

() fea fefs6 afeu & M@ ae a9 |

() fefsE € W7 9es 3 IfST a9 M3 copy embed html & fAdde a9 |

3. View>Page->Code § fa@ae a9 |

4. 93 & UAe 99 (8€99s € Bet: <iframe width="640" height="360" src="http://
www.youtube.com/embed/ieM93xFIGCc?feature=player_detailpage* frameborder="0"
allowfullscreen></iframe>)

5. AT g9 M3 (F12) € &% < ¥ g9 ¢ <9 fen &t s3a € | »1.gt39fsg (MEW) f&T
g8 M3 a3 & 2 |

&< fer mifem © &t 38 I8 7 feedd ¢ Toans & Agas J |

fAw=g ®ete dee § AHE ddaT (Including Silverlight Content)

frseg srete f€a MUStans soH=ad J fAn &€t 93" =ubr feegd @ Mustans & faus

st Jist Aet 7 fasgs 87 397 fAe w39 8w § g8 et fenet =93 dist At

TUPHT feedd @ MuBtaRsT 87 29 MUSBtaRsT 36 7 9us M3 o dds 9 ASSIF

SAFeY MuSBtarsT € 3g7 It Saehdt 95 fae fa marGféar Aeeena, =93 yAfHar

Areeend, fera Halusféar Areeama nirfe | fAgeg deT § udn d95 Bet gy usar-

few gdt Aee=ma ©f =93 aist At T |

YA fﬂmaa??fﬂaameﬂmﬁ—g W ( MAC)WMWHTW f<g

Tt USH 3T AT AgeT I | IAF St R : e
uysdr-fes yasrete (Moonlight), €t Lock [ < 05 275 k. 1 0r o
93" Biean g°F dfuBed € €3 Fr | s
dee § ¥US TTHI d AAE I | il 2 oo
a9 A mue Uw @ fe9 fiseq ®
3T JoT I3 FeHT St U BT d9
1. st A g, fenia & e
Silverlight.ntml ™ 7% A< &7 | o, 8
(VTS iy Compuler
2. qaAd & §F 74 frg gt frsea |
deec S JusTIde I . | 5 ;
o Wy Blatwirk Fils pame: >, Upen
Insert->Media->Silverlight g Sl o il i
i

fA® e 99 | Select asilverlight XAP
file 7% ITfe®Tar gaH &Ad MEeT T
3. fAw=g Brele efes e MancHs XAP J | g78wa M3 e7fe® § fAd'ae a3 M3 Open &
A ae ad |



4. AT g9 M3 (F12) € % <9 g9 € &9 fon &t 35a ¥ | fors 75 figeg sle
dee & g8wa € <9 28 (udar -fes aam) | wi gt 3efew (MEW) ffT 988 w3 a5
&y |

AT daeHs & frgeg dee € f<u gese wet §3ue faw’ fa =g srele aa=deg

(Powerlight Converter), PPTX2 fA®=d BTele aa<ded, Mo dt 93 aist Aet 7|

R

gt {3t aretut fafenr=t a4

%3t &99: I (Activities)
) fue® Arst @ &9 g=Tet aret S 9UTEle € BT fY-IY TS egHe &
&% AEUI3 M3t S8 afsy eus a9 |

29U § 98 w3 fer T ufefy & 1516 § s 33 | HTML, CSS,
2 Expression Web, XML, XHTML %3 JavaScript & fiue set f&an & fed s
d9 w3 fegst § Tam €|

1 HiZHT UBa ded® ——— Hig € ———— 3TV 378% S8 eus disT Arer gdie

2 TBA deT & feande a9 B —— nums 3 —— g ffe—— sgu €= vts
o =93 dist Aiet 9|




ARG 10: SdH, fEeasTElEs @aH M3 Bmd ot <93

(FRAMES,INLINE FRAMESAND LAYERS)

mfgma € €/ (Lesson Obijectives) :
fen wife € #i3 f&9 3 feg a9 € Gar T A<4r ;

o TIH, TEBEE TIH M3 BMd € I3 JIs © |

AYU3 ATedrat (Relevant Knowledge)

At WY AAHAS (HTML) HsE® ST gaN, feassfes eov €t =93 ada g9 fifumT T
gIH €t =93 ¥ fHias 29 uw € feu € At feg 3 Tu uwt § fewGe st st miet I
MBI MBI 3T € SIHA T AT § SIH Ae faur AreT T I et <93’ 9 g8ma & few
fea U7 € f<9 wB mIar uat § few@e st ISt Atet I 1 3At wv Eh.s9fsg (MEW)
pfeur €t =93 dH 3 feas®Els g9H § 29 UaT ¥ @9 AHE d95 € BTt dd Aae J |
gdH (Frames)

A A TAAHAE (HTML) 33 €t <93 T3t € €t 293 d9& 79 fAfunr I 1w &t sefeg
(MEW) ¥ EdH AETEIST & HTHS ddeT J fAdat & IAT MBar 3¢F <93 Aaw J |
fawe—_fes gan €t =93 5% ¥ UF § g8 BTt Jof f&3 gert »igh'g Jq:

1. File>New->Page... & fAidae a9 |

2. Frames Pages & fA® de 9 | M&aT m&al AeTest & &7% Iuvs oM < fea fane feurst

o=t | TR a1
-~ 9] Pa
3. fsHe & f&9 Header,Footer 1 —

w3 Contents & frdare a3 | [l L otk T vk e
OKI afdgagifamses | gw

- - - 53 Layoirs WAL C=5
S dd | ] Hastar P Ry

SrAu St | [rprsmic Lstst Templats
4. ﬁaa- S'Fﬂ- Uﬁw g- )?Iﬂ_? Framas Pages g:;::smm

au au _au - ER

HIAAHAS (HTML) N e ———

ngﬂ'&-r' é%ﬂ? WW% [T Crembe From Maste Face. .

J 3T Set Initial Page... &

au = - Qpthrs

fAg'ae aq | fugst mifgmm S

e wee far ; o
HI.MHAS (HTML) ]
-~ o av — -~ - 4 I Cancel
A S A8 dead M3 OK 3

IS FT |

5. 799 IHT 9% T fa M. S (HTML) %3Ted gat SoHT © set & a=F ud
g=Te 3t New Page... & i@ e a9 |



6. File->Save (CTRL+S) &
fAgae a9 | 3Ht €0 99 &
5< U & AT Jadl o fa fen
SN = fIAT T | S dd WT
(F12)T a9 g8maa &
feo fen &t s®a &8
e safsg (MEW) e
gE8 M3 I3 & ©H |
Hod IHAT 9N © &9 a9
g UA & Fyd 39 3 nifse
FI&TIdE I 3T G0 T et
J9 a1 d9&T Ige J 3T few
faerfow a3t ATt T fa g9

Page i

General
ASPKET
55 Layouts

=ty Shests

—=—y |L] Macked Herarchy
T Donn Hirarchy

) Berres and Corteris
L] contents
L Fockar
= Fooknotes
Ll Header
_.i__.] Header, Foobar and Conkents
L] Horizorta Spk

i Werbral Spit

2=

De=crphon —
rasces & barrer frame = the bop,
whth a conbent e and main framea.
Hyperlirksin ts berrer changs the
conferts frame,

Cphons

= 1]

Cancel i

e & TUT 39 I dfen A= (TES fane fR9 eEls € s § §8) | yar 9< 3,

frames.html & M.t H

M (HTML) msteg At 9 g8wa € fRe ¥ |

WS (HTML) a3 €t 293" &5 MreledH ©f <93 Jdat Ry ga J | AT uie

s'wzﬁmewnme%sm(MEW)ﬁmmﬁmwmm

wMretedH (iframe)
ELIR =R RN
WTEtedH g=8< Bt Jot feg
oMt T U'SST 99

lL.astymges, ferua &
iframe.html 3™ &% A=< &4 |

2. 399 § ©°F 39 frg At s=t
WMTETGIH YT g T |
Insert> HTML=> Inline
Frame & fi@'ae a9 | fomrs
feG s=tean fem ur v
feande T famm T

3. Set Initial Page... & fAdae
&9 | Address: €88°rhtt Wi

en.wikipedia. orq/W|k|/|frame?>‘ ZTETua‘o’

M3 OK I I8 I |




4. 72 39 »3 (F12) € 575 <9 98w © <9

- N ed 1
fen €t s@a 28 | v gt sEfew (MEW) RS . @
8?’8‘ 77"@ 5(3 ?;')_ @-a- | Tnkizl paga: |I'iJ:n:He|1.wH|:vada.-:-ru.l'-.l.lh.I]frm Brpws .
- U . - o THe |
wEledH & ey & 8T & eI & foresee
fr@ae ad w3 fen 3 € T AT T 1 Inline - e ;
Frame Properties STe®Tdr g7aH &5 MTEer e [ S
N . -~ o ~ = FAht: Ll . 5
J | gHT fere Aela § 928 AaE J, HaAs s
HHS Jd AaT T, ¢aF o M@Elane icad o "
-~ - . o ~ - . - Waddh: L2 :l Dizels
ASY J, AAIBEd & JCT HAE J AT MBIISC e o= e
ZIAC HIEPHT Jd<T A< T | Spliors
W (Layer) igriret; Defmit =) @ Show bardar
Sorolbars: [F Needed "’i
Z%THB' fé%( 7’718%"’)13 %ag 81_-” 5’ f?rﬂ' E:]' eag- Altemebe besk: egye brawsar does nat support nlng frames or
~u Cae ~ ~ A~y axn. o ~ em.  ~ o currerHy carfigured not ko dspley inbne Frames,
SggmtSgund fegddedgadiece ey
3 B dd6 HEl dd Aaw J | AT fenet =93 = iiee

€< aoe J Ae € fedlca g um § Suer I

3 FHT Ty 3fAAedns eaH A Hig & ATHE J9aT 9ge 7 |
Bng ffadee s fae faferma A sousBarlg g uae
feg fea It urtvs 3 Afezs due fE9 Hee I3 AgE! T | wdd
& AUEs wiEiie fae fa fa= (DIV) & ydfuz stz Aier J |
B3 & feaHde I35 Bet Jot fE3 Jent et UseT a4

BeRawnors Layers =

1. 3T U7 927G, fer U= & layers.html 3™ 5% A< J4 |

2. Format->Layers & fA@ae ad | Layer Toolbar feyret €<ar|

3. 2899 {39, Insert layer [ & f@ae a3 | fene Jot fa <1 Bniq feanae T A=<t |

4. 33 IIA § B ae g9d AT Bnd €7 ATeld <UT AT WeT Aae g W3 fen € wet fen &
ddsd 9 g | fen & fan I9 gf Jue &€t Arugs 39T 578 AT &»id g7an § {9 |

5. g< fer Bwg <9 3In<te § Tus Jq:

(€) Bnig € niwd Jand & J4 | Insert-> Picture> Site View  Untitled_14.htmi® x
From File.... 'g'i_)' fAgde aq | |-:Z-hl:||:|'1-.f}; cdivitlayer]

() ferea & &9 3 feange a9 | fonrs fe& '
IR B @ feg = |

6. I THUA ¥ S gy dee eety aq | fomrs fe€
g e fRevgefoimddce e a B a® &7
I8 Wz fagst uvtns €93 3wt Ae aist At feg
gudtag JI




7. A= &9 M3 (F12) € 5% 29 §'8w3 © <9 fen & v&a ev | gt 39fsg (MEW) &
fSose@ w3z dzg & ev|

&< : ®n@ feq &=t ugaT I W3 fen § Mg &et Ag fammer wife™ J95 f Aga3 J|

fea gt 8@ € 3u 3 I HBSIUS Bnidd § Y Aae T

(A=t =) |

feg =7 Fnga & TUS J9d M3 Bus' € yriEs A 94

JI3T 7T I | 31T gBE9 (Toolbar) € 93" 375 IHT =Y

Bnd & fesHae g9 Aae T |

Fnidd ot UfAHs AT d9& BTt JoT f[e 3 JeHT &t UsaT dq ;
1. View>Toolbar-> Positioning & frd ae aq |

Right Bottom with ([EZERED Heioht ([EERIT Z-Index LA’

2. 3T € fRE W AAHAS (HTML) W& § fearge a9 | §e0as € &, Fa 2vs

23T MI 3TBH E 5% M3 ¥ & fAdae Jq |

3. 39U 3G Hig urins: f9° fixed § fABde aqd |

4. forrs fe& yrtnf&ar goea € ff9 s fuarsH (Pixels)
< &% feyret aret T

5.3 U ¢ f[Sg dee & erfeu aos &t afan aqd | fomrs
fe€ cum < fean Urtws & fS9 T FREHET SR

&< : Ufraf&ar W3 U™ 99 AT WA AH (CSS) 378 o Jd& & feg §37 AMT Bdidr | 39

Gerggst € Bt AIY feAs W3 IBY e €f <93 39 |

d&t fagbut arebt fafamr=t a9

v [Mone)
position: absaoluke
position: fixed

position: relative

Al iarirad g ekl

3t 599 M (Activities)
Jot f&3 o fmfes & fewGe st v um e fRe fSs s g6
1
Cesign O1 Desigr 02 Design 03
| |1 |1 |
L |
[ ]
| |11 |1 |
fugs nifgmt &9 g8 77 99 Ut € &% ferer f&a rgfug a9 |




2 | w@ar il < gnrfeet & fou@e wet feswls gon € & ffa g U7 576 |

3 | uIe vz 3 G=I&fUar $md & g€ W 79 T Fwia © 9 IR<1T § AHS ad |

H&aS

Jot f&3t st g=t g9

1 IH U —— Hig € &% gSeT AT J |
2 WEedH ——— Hig € —— SIU 378% 3 feasnde d3T AT J|
3 B0 gBET —— Hig 3 =93t AT AaeET I |



ARG 11: d<9 fedde, HeT MEBHe M3 TeaHdd ©f <93

(HOVER EFFECT, METAELEMENTS & WATERMARK)
mfgna & €7 (Lesson Objectives):
fer wiferm & #ig f&9 3t feg a9 € Gar T A<4r ;

o SYUAT fEO N BN d =93 a5 & |

S ad

o S UA Y 9 =g feedae €t g3 ada € |

o Y UH ¥ &9 TcoHod €t =93 Jda € |

A9 U3 ATedardt (Relevant Knowledge)

A MIAAHAE (HTML) a5 & =93° 7% W9 AHAB (HTML) #ghie fas fa
TEtes, fangtuns, dvees »ife €t =93 agat iy g9 J | fed fad #istiet § mmrst
3% HHS Id6 BT IH M I.SMHA S (HTML) mistes @t Sd3 St aanae T I feg S aa
feg 7 gwt Afdar a5t T v fage a4 un €°3 Tt niusTet gt I

1. <t U7 9278, fer U7 § meta.html € a™H 57% A= &J |

2“ @- ﬁﬁ- g- 5 aﬁ-’ Page Properties ﬂﬂ
ﬁ?r U: Uaéli.l ?:3_ f IE?V 9| General |Furrnalj:l1g| nidvanced | custom | Lang.la;el
U JudeH 3% srfesmr
99H 5Ad )'HT@?T ﬁ- | Locationt ic:.l,l'.l'E:.l'Dc-:umu'B and SettingsiLabiMy DacurmentsMyFi
Title:
3. Title: Some oA © feg eeles  Eundesuiniin
& fasgufaz ad | Page e

Description: <o a1 © f&g9

Biage location: i

éWfﬂ- fges ii’_ 7;\'1?3 CE) Defauk tarzet frama:. | _’1
w3 fen Sanete © &9
aheds ©f €93 Jd5 BET e
Keywords: ¢AC §aH € 93" Lowtn [ owss..|
&9 | M3 TTEI I : i F— < ¥ torere
() Title: € fS9 Webpage created o | o |

using HTML editor 2T€lU &9 |

() Page Description: & f&g We offer great web designs 2y &4 |

(g) Keywords: € f&9 Web Page Development, Web Design, Website Development 2T€tU &4 |

(M) OK 3 IfET a9 |

4. AT g9 M3 (F12) € &' <9 g8wa € <7 fen < v&a &8 | my.gt3efeg (MEW) &
fSo seB M3 Iz § ev|



fonrs fe§ fa m gt s9fsm (MEW) U »my 9. @A S (HTML) #Wisted M3 Wishiet
v fdgdecd g fder T
‘élﬁ‘o'rr@—a' & gusaT goser (Modifying background)

- = =

v f<o gwl fors e §aargs 3 da1 fagufas a9 Aae I | §aqrgs € dar & Ae
qIS mﬂuo' ff3 grant St usaT 59

1. View> Page=> Design & e | o ] ——
ﬁ ay - - zenerd  Formatting | adwancad | Custom | Language
dd | Backaround
ST =~ 9] = I Backgrourd prture
2. wgﬂ?raz?;gsrf&—oraa, S
Page Propertiesd fRi@aeaa| | S| e

. EN o au — ol

3. Formatting 29 & i@ ge ag | -
= : W cuomate *

4. 9%d AIAS € a9, Tt W asonctic | sekedhipedris | B Avomaic o+
Background: 39U 378& Htg itivehyper [ M avori ]
f&9* Silver & A& e a4 | pvered pernic | M aora: 7]

5.0K I AfFT T |

6H‘<’&HM§(F12)€W%‘H |

gwe € i fen et s@a e
we’rsafmr(MEW ef‘e—u'mwasa'em

f&a &t feuy § ge&= (Modifying appearance of links)
3wt feu St fogufaz ag rae 7 fa <9 uw @ ST f&a fa< sAg me | I=9 fesae &
WMUBTEY d9& FEt JoT [ Tent & UseT a4
1.53=7 e 9=7G, few Ua & hoverhtml 3™ 7% A= J4 | fer f[dg wWe-we € 7 fi3&
TENSf& T TUS T |
2. 95t € §°3 AH g & fST a9, Page Properties & A& e 99 | ganféar ¥ &
fAdge aq |
3. I%dH : HAHS € &'% J61 e 31 289 § M@ ae J9 ¢
(€) Hyperlink: € &t Green |
(") Visited Hyperlink: € &€t Silver |
(€) Active Hyperlink: & &gt Maroon |
(W) Hovered Hyperlink: & &gt Teal |
4. OK 3 If8T 3| AT 3 M3 (F12) € 575 2 ¥ §'w9 © < fen & ssa v |
g 3efew (MEW) i[9 98 W3 5 & e4 |
TTECIHTIT 25' ggeT (Inserting a watermark)

Had I Sheiled § ©AST Ide J fa At o8 Tunfee & Snféar ag ag ¥ w3 feg
Egfee T8 geTet AT ot T I IR fene wet 39 U € Y Teo9d § AHE 99 Aae




J | TegHad § fHeBe wet 9ot €3 Jen et user a4 ¢
1. 3=t U 96, fer um & watermark.html 3™ 7% A< J4 |
2. 93t € W 9¢& 3 A8 d49, Page Properties & fA® &e ad | Formatting 29 & fAd ae
dd |
3. Background € »ats background Picture & fA® ae &3 | Browse: 3 af8a a9, fAast
fene 3o Teorda € f[Sg glet T 87 & M@ de a3 W3 OK 3 IfBFT J9 |
4. Mark ita Watermark & & g9 W3 OK 3 If8d d9 |
5.9 Un © fSg gy dee § ey a9 (ufe wie € At fds uAt &t Fgret It gatet 9) |
6. AT g3 M3 (F12) € &% 2 ¥ §'gw9 © < fen & s8a €6 | U7 § I&T d3 »3 fors
5% €4 fq §aqrQs Mruet ywins 3 7 A &dt, feg dee & <9 3T &at A7 faor|
"MH.EFEBT (MEW) € ST 98 M3 a5 § &Y |
H9Hs 9 gE€&'e adaT (Changing the margine)
AT LY UA © S5 Un § fewfes 995 @8 St HaAs (Margin) § Re g9 Aae J | fene 575
SIUH St ATEST 3 g% Aq)T AT AUR uET 3 &3t Aiet 7 ffg gt gmie € <9
nTdefenre & JU AAE T | A& § MSHAC Jds BTt Jo fE3 gert &f UseTr a9
1. 5= UH 9278, fem U7 & margin.html 3™ 7% A= &7 |
2. 9731 € HH 9¢& 3 af8a ad, Page Properties § fAd ae ad | Advanced¢g & i@ ae dq |
3. Har& Aretd (fuan® &t gfse € fS9) § fsgufas s et efev a9
(€) Top Margin: € &gt 301
() Left Margin: € &gt 60 |
(¥) Right Margin: € €t 60 |
(W) Bottom Margin: & &gt 30 |
4. g7 dce TTEU T | A= I3 M3 (F12) € &% = ¥ y'8wa © f<u fen et sua ev |
"H.E . FEfET (MEW) € ST 98 M3 a5 § &Y |
gmr & fegurfax @™ (Specifying the language)
gHt feg St fagufaz a9 Aae T fa 9UH fagst gmr & fE9 gefour fapdr I | few
AEaTdt € 93" AI9 fére goar fE3an g8 et m3 fedled & g € W 531+
feu@e et Ji3t Afet 71 T9UT € <9 =93 I de € IHT § AHST € BET Addls
159 Arecen@ ©f =93 J13T Ael 7 | feg »UE Wy Wg e Jd6 8 & (Aeeamd) eF
=93 JI¢ U6 o= fa 9 uyAt § ffq 3w 3 gt g © 9 ge8e 75 | g fosaurfas
JI& & BET I&T MESHAT dJ:
1. 5=t U 978, fer U7 & lang.html € ™ 578 A= &4 |
2. 8T € A 9e& 3 BT 9, UH Juaeta & @ de a3 | Language <9 & fABae ad |
3. Mark current document as: 39U 378 € J&T English (India) & fAid ae J4 |
4. 0K 3 IfBT 3 | AT a9 M3 (F12) € 3% < ¥ g'wa © <9 fern &t s5q &¥ |

w8t sy (MEW) @ &9 5e@ w3 a5 & o8|




&< : AT 9 Ua € <9 mzar war iy 3 fowrs aat &3 few & =93 fige »iegst
A9 fére, Aadts disg A g78+9 € 9 Fist Aiet I

R I

dat faatmt et fafamr=t a9

»3T &99: aH (Activities)
1 UfgsT™ §=78 IIE S9UH © Bt Her s e fas fa eretes, famafouns
M3 THIIS & IS T4 |
2 TN © &9 IASIT § IS aT |
J=q fegae & a6 :
(€) Hyperlink: & &€t Dark Blue |
() Visited Hyperlink: & &€t Dark Green |
(g) Active Hyperlink: & &gt Black |
(W) Hovered Hyperlink: € &gt Teal |

e Hars :

(€) Top Margin: € ffg 101
() Left Margin: € fS9 10 |
(€) Right Margin: € f<g 101
(W) bottom Margin: € f&g 10 |

H&as

Jor f&3t st gr=t g9

1 HeT WBHE —— WTURS & 578 HHS d13 AT Add J& |
2 Had At FaHaq € g In<e & 293 J9aT 979¢ I 3T EAET € 95T ITE ——

Ay a a
Jdd dd&T IJIET J |



AH& 12: @91 ©F <93 (USING FORMS)

mfgma & €7 (Lesson Objectives):
fen wife € #i3 fS9 3 feg a9 € Gar T A<4r ;
e TIH G TTQT T I

A9 U3 ATedardt (Relevant Knowledge)

SHt HGIAAHAE (HTML) a3 € 293 578 e g8 fiffenr 7 | fae” fa 3og usr

g fg g & =93° fediled 3 Areardt & fedsr aaaT A feriled & fene &% A¥uz forse

few@e et aiat Afet T 1 HT.dAHAS (HTML) WSted & <93 &% gat 29 - Arfee &

fS9 e & A &9 AT T |

g9q & g=T8<T (Creating forms)

fea Arggs WY HHAE (HTML) oH § a8 BTt Jot fe 3 gent et useT a4

1. 5= U7 527G, fer U7 & form.html € a™H 5% AT &4 |

2. Insert> HTML- More HTML Tags.... & fAi@ de &3 | HTML Toolbox &wd m™@eTd,
Jot ¥% AFd% MF Form Controls €7 fergd a9 | (IR<1T JoF T)

3. €94 & 78T BT AF 3 UfgST T4 T0H FedB § HTHS Jd6 € Aga3 J ITOH §
H™ dd& & &g Form Control f&re f&9° Form

o Auv —_ Tl.'_l hib

& fAdae aq | L
4. BT I3 M3 fig AT ean § JyeT Ide 7 » Tags

W 7qT 3 29 UF € 9 gouan mm & 99 ~ Form Controls

o S o NPT - =2 Advanced Button
3U4 T9H 3 A H TIG BT ¥ MBIHST § HHS 536 &F s i s
Hg93 Uit | JET faAH € SO0 ded® M. AHHAS Form
(HTML) ¥ f35 Qusay T 1 €egds & et, fedlea & Group Box

g - N W3dH § fedar d96 et At SaAe TaH MBI € 93 Jd AaE J |
5. €91 ded® fere &9 Input (Text) & A& de a9 | fer & gar 439 € »ied Far w3 U
dd (IA<TT =) |

2l
flame=: |
Iritial |
walie:
farm.beml® = Width i char acters: I L crder: |
Password Feld: - Y i+ Mo
| P I Cance ]




6. fen €% € €TW 979 308 Urd & TR ©f 7ga3 J | fen § ad& ®et g7 MdiHe ©
€3 T =9 af$d gaT US| 7 Input (Text) 55 I o< feamae AT TR €T &

VN A

=79 AfBF T | Text Box Properties 37Te® g/aH sAd m8eT T (AT 36T HA J) |
(€) 7dd IUS aF TN et i 3 frmimer Eto3 g8 3 feust § B9 M3 WAt 5%

AHS< &et At feust § 7 ufgue fAd s & fe€ 13 & AH® d9s e, Name: ©

f<9 Email § efeu ad |

() fer Swz € 8€n & san8< &, Initial Value: €1%s 9 =vg § efev aqd I feg Hg
v f&g feyrel A<t ug fen & fertes € € W& W3IH &% gefen™ A7 AaeT J 1 g

Initial Value: €%3 & f&9 Enter your email address § efeu & |

() OK T AfZT I |

7. WISt Ffes f9 A< et Enter § YA J9 |

8. few gman & Aefiie (AYT) I9s Bet 378 T ded® et Agas J |
fEHErEE’rEEI"?F Form Control List f&F* Input (Submit) &t =93
aa?ﬁ@aﬂﬁzrlfsﬂzghvlnput@ubmlt)afﬂm?a? fem g

Stz Wiy fom, himk® =

«fotm

Enter your armail add
aubirrnil

firg w3 fagst 3wt ufast Input (Text) 53 g=et T ERe EIFEI’EHQEWE"HH
Jot feure »igng ferer gg I A<ar |

9. g ITS for TN & Tafede q9& 20x|

€1 7ige3 J | feviteg gvar & - H&
WSIN I9& 3 T, MBI YATHTT
Bt ean ©t f3¢® & Ive =3,
39$ 89 URL fagurfes g9 &t 83
J fig fa Areardt 3+t A<t Iotet
JI

JSTH & )'-TT-T UH JfEF &3, Form

Properties & fA% e &4 | Form

Properties 5% ITeSTdT g9 &

weET I (3RS I5T J) |

(€) Options.... & fA&ae ad | Options
for Custom Form Handler 5™&

3TesTar I SHT MTEeT T |

(i) Afgue & g+t aret AreaTdt & 31 s

et 3T Action: SIHe ITaN <9
URL & fagufes a9s &t Ages J,
7 fa w= =@ m <9 fenst
HarifagHs (Execution) €T fomms
JU9m 1 URL & ey a9, @eraes
& ®et http:/www.example.com/
submit.asp A" submit.asp |

Whate to ckere recuks

(™ Serd to (Requires FrontPage Sarver Extensions)

File name:

Brrimse. .. |

E-mail address: I

(™ Send ta database (Requires FronkPage Server Extensons)

(' sendtoother |Custom ISAPT, NSAPL, CBL, or ASP Script =

Faorm properbes

Form name: |

Target frame: I

)

i J!l_l:luanl:ed...l i 4 ‘ Cancel |
o
Action; l
Plathod: |D25t j
Encading bype: I
(B4 Cerzel |




(ii) 3T fene a1 § ¥r< €t 7ga3 T | fa@fa mwt s7er 37 39 ot few &8t POST & g ae
ol

(i) OK I AfBT FT |

10. 94 & It ga=t aH o€ 7 fa gost Samfee € <9 =93 I°© mII-mBTT ean &
29 I9& &9 Hew adar | fer mifgmm &9 Newsletter ey 9 W3 OK 3 IfFT 49 |

11. AT g3 m3 (F12) € &' 2 ¥ g'8w0 ¢ <9 fen & v&a &F | my.et3efsw (MEW) €

fSoges M3 dz & ey |

&< : 397§ 87 URL € Ad3 €< € Agd3 J fAne d& fen ean § »iar UAW 9496 & Bt

Afque I 1 7 AT fAge 30 BTt 289 § HIEMT qee7gT T 3T 3737 €9 aH &It Jdar |

feg <t AT MI.AAHAT (HTML) eor € fus® 67 § Mg Aae T |

d&t fa3tut arebt fafamr=t a9

%3t &599; aH (Activities)
festea & First Name, Last Name, Email address, Date of birth "3 Favorite
1 fagmat (fA=" Science, Science Fiction, Statistics) €7 37eT feaaT a9 Het
feq fHa® fABaHs Ty 976 |

1. TIH MBMT nurs € fe fise 95 |

2. oM ¥ &9 u=9s Sto3 & 93 996 BT ———— dedw® & =93 J9at It T
3. IV 3Q% e & @< &g, —— ded® € ¥93 JIat Igtet I |

4. T9H & niwg fangiurs HIEMT Jae8< B8t ——— ded® € 93 JaaT Idtel I |
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AH& 13: AT, WA . "H (CSS)

mfg™ & €7 (Lesson Objectives) :
fer wifer & #ig f&9 3t feg a9 € Gar T A<4r ;
o Wefe® Hiet (CSS) se e €|
o ydt Tuwrfee € &9 Aefes Fte § MuzTet d9s €|
o fed® Um B AL AT (CSS) I & MUBTe! J95 © |

AY9U3 A<avdlr (Relevant Knowledge)

99 AT forrs f&3T =T 3T At A7 I1E J=J7 fT AW A (CSS) € <93° 396 578
HIAMHMS (HTML) a7 93T & ubum an 71 M. mHAs (HTML) mtes
ALAAAMA (CSS) € ¥93° W3C €49 Ae Ji3 U'H ACIIT § I8t due e 3u3t
TgAEle § TomET @3 fen § miwfes 95 et daer I |

ydt SEAEle € &9 93" & »et f€F Aeels Hie § s=@<T (Create
a style sheet to be used across a website)
grt SanEle € &9 muzTEl stdtt are I @t
AeTfes Fiet St g Here T | HT AAHAMH (CSS) [N |
s & & fgmet rerfes Hier se@e oo RNt
fAfimr 31 Jot f&F €1 &t =93 o9a AT a0
€1 39fET (MEW) €t =93 578 Aefes Hiet ger
Aa< 3 :

1. File> New-> CSS & fadde o |

Apply Styles Manage.., * Ll

Mew Style

Mew S 2lx
Sebeckon: 1“ —I I Ay roesy 2yl b dncumant selection

. o o Qe [Gare e s |

2. AT Style g&gan € 293 (IA=T .,

J&t J) AeTfes® Hie (style sheet) & L T
y . S N — i

fSo refew § se@e st ag Aae | O — R
J | (7 feg feyret &t féer, Panels> |5 e e
Apply Styles.... & fa@ae d9) |

3. New Style.... & fa®'ae &3 | New
Style &% 3Te®Tar g9 AT R | o
ETT I (N9 2N) | o |

4. Selector: 39U 37EE € T3 5B B e

A 9T WA HHAT (HTML) MBtie 3 Aefes & yafia a9 Aae 7|

(©) €v99s € BT, MYANHAS (HTML) € §3T W@ BET 4T/ Aféar musTet a9
THI :



(i) Selector: 33U 376 ® Hig € f&9 body & fAB a< ad |
(i) Font- family: 39U 378& Hig f<9° Verdana & fAid de ad |

Untitfed_1.css™ =

Gike View

B body |

font-family: Verdona;
(iii) Font- Size: 3974 378 Hig f<9° Small § @ e aq | color: #a08R;

(iv) Color: 397u 378% Hig f&9 Gray & fAi@ de aq |
(V) OK 3 BT F7 |

(i) forms fe§ At A m (CSS) 33 mruE wy fafiT gier J (IR<ta Gua )
() TS MBI T BT yH Aféar muzTet a6 TS, New Style.... § fidae a9 |

(i) Selector: 3T IE Hig T Table & BT a7 | T
(i) Font-family: 394 37§ Hig f&9° Courier & i@ ae a7 | DD;I'_Z:: e i
(iii) Font-size: 3974 378® Hig f&9° x-small & fAd'ae a9 31:31_.1:3:;“ : 48_'?%{:'

(iv) Color: 537 5787 Wiz <" Gray & il ae a4 | . e

18 }

(v) OK 3 If&T aa | ”

vi) fonrs fe€ A »imm (CSS) a3 muE my fafuT Arer 7 (fAe” In<ls feg feyrfemT

)

3¢ 39 fa Hge a3 3 g © R ds & A3 &3 Ater I | feu iget Aefes e & ses8e

feg feg 3o st Hee aaeT I |

5. fer eet® & eEl® € 3™ 5% AT d49, §€9s € &et, mystyle.css (IT7E STEIS WA SHS
& fayue ©f Ages &dt 9)|

ydt SEAEle € <9 Aerfew Hie & musTet 357 (Apply a style sheet

across a website)

g< guvs fen Sanele € 9 Ad f&at & fen Aeels Hie 5% A3s ©f Ages 7 | feg M

39 3 TIF UA & &9 <style> mIF </style> W@ME & {999 AHG Tda 3T 7ET T

HYIAAHAS (HTML) 3073 &et fen a3 & AHS g9 AdeT 7 | L gATele € <9 Arg At

3 fen Aeel® Fle & MusTet dda BT Jot 3 JeH &t UseT 9 ¢

op =

1. Apply Styles € »qt® Attach Style Sheet.... & prssresmpe. ] %]
fAg ae &9 | Attach Style Sheet 7% STfemTar | :
. EN ~ . 2 LRL: s .
I9H &Hd MEeT J (IA<T I&T ) | - e
“ mu Mtachto: O BHTMLpsgss  Attachas & Lnk
2. AttaCh tO: W g m A” HTML Style £ Sepked pagssy [ Import
Sheet.... & fA®'de &F | AT AT 3T HG UAT & B Curark page
f&g At (CSS) a5 & e Age T Af & | one |
fen Aeet® Fie & f&9 A wAwA (CSS) 33

€1 993 &% A9 U &% f&a a0 Aae 7| fen Aeels Aie § & d95 st aret
wfF™H 99& & fegd T 93 fAeTfon st AEt I fAs fa :
I




(©) fea fiar® Fefes e € gnaT ITF aF ATl Al & U 3919 HaH dds &
deaB T |

() feT AeTfes Hie @ fEa e seo< 99s &% e ge%= A9 29 AT © g g3t 3¢t
Hefes Hie € &7% MUS WY WUSTEr § ATeT J |

3.Link& A ae aq |

4. browse.... & A& ae 99 | fAgst AeTfes Fie 3t ufos gseret I 67 & M@ae a9
(mystyle.css) M3 OK 3 AfBF 7 |

8¢ : A9 29 Ua § f&a 95 € <9 g3 At &a1 AgeT 7 | feg Sonfee € &g At &

fore3t € €3 faggg aoer g 1 A€ Yyar T AfeT I 3T e GU U HRA & 8C J9 |

5. feg woits g8 < et fa ot 6 AU T farrT I, SgATfee @ fRo et S M I M HA S
(HTML) UH &3 | View-> Page-> Code & fA¥de &3 | <head> ™3 </head> W&He &
f<9 mystyle.css f&a & 82 J3 |

AeTEl® Aie € f&a & ge@=r (Removing Style Sheet Links)

feq fias <9 ur € <9 Aeets Hie f&a & ge@e B¢, Aeels Hie € &% f&a a9s =3

az et gfes § ger fe€ 1 a9 29 At &9 Aefes rite € f&at & ge@e set aet fda 2%

Ud 5 framer & rerfes Hie 7% T M3 It &3 aent St user a9

1. Panels> Manage Style.... & fA@de dq |

2. CSS Style: € niuls Aerfes Hie € fane § B ae a9 |

3. i U'H If&8a &3 W3 Manage Style Sheet 2=
Links.... & fi&de a3 | Link Style Sheetzms -~ =

) Semied pagsy]

SESTar ITIH a6 MEET I (AT TH) | & curen page

4. All Pages & fA@ de a9 |

5. URL: fere f<9° nerfes Ate & M@ ae ad |
6. Remove & A& e ad |
7
8

.OKZ af8Taq |
. Continue 3 IfB8T T |
< & WryS wiy /g 29 uAT @ f&9° ge AvEar|

fed® Ud & f&9 AtWAMT (CSS) a3 & =93 JdaT (Use CSS for a
single page)

A< AT fAde U™ UH € BT MBI AT Hie € 93 dd&T9de J 3T I U R 29 Ud
T e ALAAAA (CSS) €F =93 g9 AIE T | 4'H UH ST Y™ ALAH MR (CSS) & 93
THI JoT fE3 MEHAT 5T Ao I ;




1. 5=t U7 9276, fer & single.html a1 fe& |
2. Format-> New Style.... & fA®"ae a9 | New Style 7% 3Tfe®Tar §7aH &7 W@ e |
(€) Selector: 39U 7€ fone f&9° Paragraph matie & i@ de a9 |

() Font-family: 397U 378 Hig f<9° Book Antiqua g
A8 ae a9 | L.

(2) font-size: 37U 7€ Hig fF9° medium & B g a9 | ; “titiesin rﬁtﬂt;ﬂt*':;:r :mm
(A) Color: 337U 3765 Hig &9 Lime & fid'ae a9 | o T
(T)OK J afsaT ad | 1z <kt
3. View-> Page=> Code & fa&'ae a9 | fomrs fef, 1 P

ATAHAAH (CSS) a5 fAge fer 9 um € <9 iis aia

farrT 3|

Y !B TYPE Rtml PUELIC -/ rW3CA /D0
B <hitml ~mlpa="http; *Swww . w3 ores 1t

4. igrare #WENT @ 293 &% I¥ deT TG | AT q9 7T (F12) € &% 9w & f&g
feret! s®a 24 Aaw J |

B
Jg&t fagbdt arebut faferr=t a9
%3t &9q: aH (Activities)
1 HeTE1% Hie 878 M3 Jo' &3 Ie Maien § ygha aq
¢ Body-background color - light grey
o Paragraph - leftaligned, Times New roman Font, size 12pt
e Table—Border color—Green, thickness 3 pt
¢ Heading 1 - Center aligned, Times New roman font, size 20pt
e Heading2 - leftaligned, Thoma font, size 16pt
e Heading 3 -leftaligned, Georgia as font, size 14pt
fegs™ Arg 29 UAT & SaEle € <9 »musel JigT AT AgeT 7
ACTEIS Hie 97§ W3 Jot &3 are Mdiet § ygha aq
¢ Body background color—Dark Grey
e Heading 1 - Left Aligned, Century Gothic, size 18 pt
¢ Heading 2 — Left Aligned, Century Gothic, size 16 pt
¢ Heading 3 - Left Aligned, Century Gothic, size 12 pt

o Paragraph — Left Aligned, Verdana, Size 10 pt
fegst & fAge 90 Uw © <9 mumTet J9 Aae J |

Jot fa3t yst gret 99
1. MAACIs® AeTfes Hie § se8e 38t —— Hig & =93 a3t At 91
2. Aefe® Hie & f&d a9 Bet ——iedifabe & =93 A3t At J|




S 14: fad<hiad (BEHAVIORS)

mfgma € €/ (Lesson Obijectives) :

fen wife € #i3 f&9 3 feg a9 € Gar T A<4r ;

o fUSMIA € ® IH JI& & |

AY9U3 A<avdlr (Relevant Knowledge)
fag<tw ufgst 3° ygrfazs 13t gett Afgue getit g5 7 fa g um € 9
feedactfect e d9v U5 | Geuds € &et, A feied yH cane € Gud wew &
fog@erg 3t G 3t “tip” S feurrae T |
o IH fagt fan A= Aafoue a7 € fau fau<sion & s Aae § »3 A3 Uue 3
TIATHSIT YU dd AT T | MBS IHT & et IT74 A< Ad(dUe € T93° dd& ©F

Hgd3 UTdit; wmézﬁmwwamewﬁw few fag<tnign
it &t =9 9 AT T e I

o AT Gurde ‘T AT 13T AT I 3T AT IH AT |

o Ad GuHdC ‘T SIB-ABA A3 AT I 3T IE IH Jq |

o 7Y AINT § Garde € Gud* uhfenr AfeT J 37 det IH ad |
Msafda (Onclick)

A9 AT < 7 fa In<ta @ €73 af8F a9 ‘T fFa Twdy 9790 &Ad W< 3T JoT fag
wmwe’rwaﬁ.

Eehariors

1. 5= U7 =G, fen U & popup.html € & A= 39 |
2. few & feaswae g9, fena § @ a< &9 | Format->
Behaviors & fA® @ d4 | Behaviors g&gTg feuret féer 71
3. Insert 397V 379% Hig f<9° popup message & B 'ae a9
(A= =Y) |

4. Popup message 3Te®Tdr a7aW aAd mreeT T | fAgst

Insert ™
Call Script
Chanoe Property
Change= Property Restor=
Go To URL

Jurmp Menu

TR Mena Go
Opeen Broweser Window

Play sound
fsimstepZ)zﬂTthfemaﬂsﬁr@Fr@%ﬂ@‘feﬁ?a Po;u:;mga
Prela Imadgeas

Ffsa gaer 7 3T €< gAt 7 feu@er vde T €u wng
el 99 1 8¥9& & &ET, Image popup behavior |

5.0K 3 IfBF a9 | A= &3 w3 (F12) € o8 g8wa € <9
fen<t s@a @F | fenw 3 afda ad w3 feue Guniy ‘3
foirs o (Ireta 1 3) 1A et Sufew (MEW) 2 g -
A< M3 dF § e |

IMaEze PO WS EeEs o




W8 =3 (Mouseover)

Had AT UV J fa A=t & AfBF J13 3 fast e feries A<t € €3 wEm Wwer

J 3t 8% R iy a9 w2 3t fere st dof i3 Jert &t useT a9

1. View-> Page-> Design & fA@ae a9 |

2. form & fAdae 99|

3. Behavior g&¥™9 € f&<°, Event 337U 37€% € »uts, onmouseover & A& 'ae a9 |

4. AR JI M3 (F12) € 3% g8+9 © f<U ferel sa ev IfeiAa e Qua aang S He ad 3
fors &% €4 fagt afda a9 3umd Yuniy feuret e=ar |

5. WH.E3EfEE (MEW) € fRe A M3 5 & 4|

dtsTfedae (Redirect)

7e fere € €ug Jorg & Y= disT ATeT A Af8q Ji3T Aer J 3T EF At ferles § en

Y UA A EAEle € €73 37 Aaw J | fewted & Jot &3 JeHt migag disfedae disT
AT HIET T
1. 32T Um g6, fen UA & redirecthtm|  EIEEIIT T 1/
TEHSE AL d4 | satn Lo ovee. |
2 fenw & feande &g, feu walat g6 =
A — Cared
for gn<ta fAd'ae T aret | = |

3 Insert 337U 379& Hig f9° Go TO URL
& fA® de a3 | Go To URL &% STe&™ar 79H a7d M8 e J |

4 An URL 3 %23 d9 18e™ads € &, http://www.youtube.com M3 OK F IfET T |

5. AT &3 M3 (F12) € 3% g'8w3 © fTT fenet soa e¥ Ifonm I IfBT g w3 s ad €
2y fg U gfe@¥ € &% dizfedae der I | g mu.gtsefew (MEW) € ffRe ige d9
fedStign €t <93 995 & I J3 |

d&t fa3tut arebt fafamr=t a9

%3t 899: M (Activities)
gt fe 3 Ie fageen € MegAT T UA S 979 ¢
o fi&q 3RS € 93" a9 fAng A 398 JfSa 3T Aer g 3T 8€ €9
fetites & fan SgAele 3 & A< |
o forie &t =93 &% ferted SarTfee 3 € @9 IS ddeT T |
fea 3* frmmer fornAt § feswge a3 W3 g9 HiAm 3 Tunfy HfAe &
feys (onmouseover) |

1




H&aS
Jgot &3 aF yast € €39 feb :
1 8995 € 5%, fag<tion € §n & fengd s7& mee ?

Jot fa3t st g=t g9

1 feg=tes MuAs ——— Hig € 95 fiset I
2 Ae feieg fonm € €3 qoHg & He qae & fadehem fea Tumiu WA &
feu@er 3|



HAS 15 Mad&3T (COMPATIBILITY)

mfgma € €/ (Lesson Obijectives) :
fer wife € #i3 f&9 3 feg a9 € Gar T A<4r ;
o MBI-MBIT LY g8 © fFg TuEle S mggs3" § 9T T35 © |

A9 U3 ATsdardt (Relevant Knowledge)

E'?I‘ a'r@?ro' T 5 HETHIT ?F I FI&T (Checking compatibility with
other browsers)

Wﬁmmxmm?wwmwawfwmamz
307 WAlE 9 e-uue-af%rwﬁm@ﬂwﬁmwaﬁamﬁgﬁ
ﬁmﬁwmﬁw@mEmWEWWﬁMMM- g IS m?r
>a4?ﬂ'«.v>3TEl—oﬁr(compatlblhtychecker)e’raa?raﬁrﬂae’zr|fsztr3«*:115'THwEEJT@a'fe—u'HGT:r
9T M3 FTTS LIAEIC ¥ ST 99F 9 UH A Meted & 9 Jda € AgI3 &dt UL |
Jot f&3 Ied™ MgAg AT MEIHIT ?__)'tl S Id HAE T :

1. TgAEle & 88 3 AT feng 9 ad |

2. Tools=> Compatibility Reports.... & fA@&e &d | Compatibility Checker 7% 3rfesTar

oA Y G T | i
3. few @ A I ¥ w9 T fo fog miag@3T ::klm
%V_o(a’ areyrey H"B:I' QZHHTFE‘J ?:_; ﬁ%( EﬂET Hr Check ibere: check HTMLJHHTAL compatiilty with:
Aeer T wd feg g g dm §mmy@ wry Sl I B
Gper pageds) o1
I gaeT J | fAd Mggs3T & m?r 3T P E‘;j—;‘jﬂ:“**‘“f i 5
ﬂ o crrret page L i
g U @-Fr < % Run check based on docoype dedaration In page T avalatle
m—u'é‘rwnm (HTML) M3 ﬁvmnm (CSS)
fimimg (standards) & fegurfas 9 €t Ages T e |

(&) check HTML/XHTML compatibility with: au 37€& Htg € ffe' HTML5 & fAd ae
Coll

() Check CSS Compatibility with: 33U €& Hg € ff9° CSS 2.1 & fAB ae &3 | Check 3
IfET FT |

feure are fomse 3 fors fe€ | Tda #wahie &t milfmr T M3 Aag B3 I 3T fem &

3 J9; e 94 A I < GATEIC B3 3 If03 &t T ATt @€ ST IFT & g9 IS

e 3J |

g< I AaeT J fq g9 ferted yae g8w9 &f =93 a9aqr (feg fomerzg féeade € €2

Je I5), fgﬁgﬁmmw@ﬂ?mada 5% A MEIBIT§ 9 d Jd& € Agd3 7 1 TS
fen SgArete § ya'E A 393 fAe fd HTML 4.01 M3 CSS 1.0 € 3% ¢He d96 &ef I&

&3 Iedt @ MgHg ;




1, Tools=> Compatibility Reports.... & fAd de d9 |
(€) Check HTML/XHTML compatibility

with : 33U 378% Hig € IR HTML

Campaibiny
L Page v  Lne = Imsue Type * Schema

4.01 Strict ?;)_ |‘F|2°5M6!2 a%| - :ﬁl gl com [11] 5 Tncompatbity . CBA0
= stylesjobde 2 ess [171] 14 Inecompanhiiby 55110
(") Check CSS Compatibility with : Fgmy g ¥ =mietesi
& vlg € f&9° CSS 1.0 & fadae
3d |

(€) Check & fABae a3 |
2. f'u-,ﬂ-'?; STH ﬁm ?:?— @-—a- (B-Héa- asr ﬁ-) Found 2 compatibilizy prablem(s) in 3 page(s),
WMEIHIT AT & B¢ d9 fas fa Aefes Hie € ff9 a3 AWAAT (CSS 1.0) € &8
WMEIB3T 541 7 | fev fen 3is 2% Aa3 J9er J mrfee feg U fAge AT AT (CSS 1.0)
AUdE J96 T8 < ¥ '8wdT € €3 At sma me |

&< : fed fag ant € <9 3u7§ yge T8+ 3 ASSIT § T9dIC J9s ©f Aga3 J fen &

o A

THI ALAAMAH (CSS) € YT A 395 ©f 293 96 BT M I.AHAE (HTML) #isted
& Jafed ad | Ug Ufgs™ 3 Viger a3 © &eT 38 feng Hen@t gese € Aga3 7|
At mifenr § ALWAAR (CSS) a8 € &% <t 99 dd Aae d

1. Tools=> CSS Reports.... & fAd ae g3 | CSS Reports &7 ==
STfeT®TaT ITaH &Ad e ET I |
2. Check 9e& 3 afsd 99 | feue g forse 3 fors fe61 - e

d&t fa3but arebt fafamr=t a9

]|

3T 599: M (Activities)
1 WMEIHB3T 9 dd (compatibility checker) & 3& &3, HTML 53 CSS 2.1 &
A8 ae a9 W3 At 7 UfasT SgrTele gaTet I €T AE39s € MEHd &at
J 3t End ST aq |

& de

Jgot &3 aF yast € €39 feb :

1 8TU95 € 3%, MagB3T 9 dd € HaHE ©f femmfmr 39 |

2 Check HTML/XHTML compatibility with : a7 378® Hig € ff9 8Usey =gast €t fane
=G|

3 Check CSS Compatibility with : 97U 37€& Hig € <9 GUsay =aws’ €t fere 56 |

Jot fest yat gt 99:

1 Mgg®3T fauge (Compatibility Reports) ————— Hig € 95 GUsgu et I |




AR 16: a3 f=@, nz-fes, Afsue W3 U= giHHaA (CODE

VIEW, ADD-INS, SNIPPETSAND PAGE TRANSITIONS)

mfgmma € €€/ (Lesson Obijectives) :
fen wifer € #i3 fS9 3 feg a9 € Gar T A<4r ;
o IFfe@IIHTISTI
o W3-foa Tt =93 FI5 T |
e AfdUT Tt T3 JTI& T |
o UH THING § &' JI5 © |

A9 U3 ATsdardt (Relevant Knowledge)

T femmer3d aH GUI €t 93" 578 Yd J Aae I, JEt 6t IS aF & Hemd!

fesnge gaaT I AgeT (Bewds € e 78 At MuSt Sanrete 575 fesddie ddaT Ige
T 3t T yget E HuStaTES aF § WIS aeeTE et 9) |

A gAl a3 8 He 3 aae T 3T feadBHA (IntelliSense) 9 mu@ Wy 3ud a5 &F
fore w2 medt fabe tuniy ST HIeht geeBer J|

a5 fe€ &% W adaT (Working with CODE View)

a3 fe§ €t =93 fa= 9t I, & A¥T BEt Jot fe3 FeH St U &9 ¢

SR GARUAE (HTML) U 576 |

Code View & i@ de a9 |

<body> &dT 3* I™€ J9Hd & T4 |

29T & UBE BT < M I® gIde & ST &9 | MBIt €t fane § S 99 (I Jat ) |
fare € f&5 Mahie & fMdae a9, @vg9s € Bt : hl

SIS

i < 'DOCTYPE himl PLELIC “-//W3C//DTD XHTML 1.8 TransitionalysSEN® “"http:/
B <html xmlns="hTTp: S S www. w3, orglf 1999/ xhtml" >

EY <heads

Bl cmeta content="textshtml: charset=utF-8" hitp-eqguiv="Content-Type™ />
i <titlerUntitled I</titles

% head>

=l <bodyr




6. MBI € g€ I JINT & I8 M3 AUAET & T9C | fen Meie € 575 rdu3 feue

e miedtfabe &t fene & &< a3 1 Align, & i@ de a9 (A1 F13 wedifage & &<
q9), MUS dhy 895 3 = § B ae a3 | fer wedifale € »igng fAgst 254

fAd 'ge 98t 9 87 & &< ad | Center § A& de ad |

7. 31 & €€ J95 Bt > € 93 79 | fors fe6, W3 Sarvmue »y AHs 3 AteT J | TS
az <€ & v <9 93 yRfa® I U feq =t Jait Ig wfew™ d9s 3 IAT afsa
fesegane 3 YaT ded® a9 UG |

feseSHT (IntelliSense) Aféar & ST et Jot f[&3 geHf St UsaT 99 ¢

1. Tools=> Page Editor Options.... & Saesetiai 20l
= - = garerel | wuothnboal | Defekrons | Coderormating =
A& ae a3 | Cake Cadog. | Mitherng || Ptew || Feandiard || Inesmss | ForkFankes |

The folkowained 2 g are For Hhe Coder paes anky

2. IntelliSence ¢aT & B qC A (IATNT s b

VENEEN ¥ HITAL staenes compledion R PP ol waslable cargletion
FI?l'EI')I [# 255 soaberesnt compl etion P PHP parageste infiorms ston
N po S -~ o [+ B NET ket eresnt cawg kticdi Enable the [oloesrig PHE Furebor easbecprme:
3. Aféar 3 fors feG I fem 3T fRT ¥ semmsovens onpionn A |
o o a " [+ Sript geramster Hfomeston ;“;L“ PR .-;uh:h
IH IIS BT ITS Y CASIAH S Aeche
~ = = Srraen
HJI93 & Agas J'| o B ok l
Y] 1Y) [V X pro o fusbe [newrt
HI3<UdS :
uds Jis g famt St Aféar & DT
m‘ [ HIPAL aktrideba vabin quckan
?;r l [V %ELT atirbane ok o gk o
- : [F AFFNET afrbite wabe quphes
nz-fes (Add-ins) B gt

IHeH aHTg w3 femm pfeu=t o 505

[¥ Erbi Code Hupesings for the Fofeing el insnts:
odd MF-fesH (Add-ins) W Jara & 7 e man
AHTET § SUET U5 | IR FEt faAH & ¥ connerrupene
w3-fesw & I &3 o f&ar 3°
SRS ITHAT I T

e http://msdn.microsoft.com/en-us/expression/jj873995.aspx
e http://ww.webassist.com/go/xweb-add-ins

o http://www.expressionextras.com/products/lightbox.htm
o http://Amww.dotnetcurry.com/ShowArticle.aspx?ID=534

ST IS ©F 93 J9d I9 =t frmeT W3-fesn g Aae 7 | fEq =<t A gl ffa #s-
feasn 3858 a9 8¢ T 3 W3-fean § feanes aos Het Jo' e I €ar &t <93 a9 ¢
1. Tools> Add-ins & fAd de ad | Manage Add-ins 57 3Te®Tar 7aH &7d W8T J |
2. Install.... & @' 39 | 7877 W3 M3-fean & B ae a3 M3 feg Open 3 BT I |
3. Yes § A& de aq |
4. T W3-feaH & AHS 935 € BT fen €91 § g9ag |
&< : 3Ug mM3-fean & feane® a9s wet fern feut € Ages T Aaet J | M3-fean efes
v f&9 3ust fenzg 5% fesedans § due ffg Hee gaer J |

]




Afayen € =33 (Using Snippets)

Af&UeR Yot & g7a1 € 96 # fa fimrmer3e faesust ewmar <93 AT 75 | AsfdueH

Tt HI3TYds I¢ I faffa aet =t ffa At ffq 3 feer 9 UFT 7 SgAEle §

g8 BT ITT I IF & T «Jf 3T ATeT I | fene 5% 3ot 5y 3 Aret fHoss M

AHT 9991 | GUBET Afdue § Sues w3 feande aos Bt 9ot &3 gt & useT J4:

1. Panels=> Snippets & fAd de a3 | & a1 m& a1 defaret € fg GUmyy rfdue € fane &
&< ad fA= fa CSS, HTML, JavaScript, JQuary e |

2. Afsue & feande a9 Bet Jo £ 3 JeHt &t UseT &9 ¢
(©) s=t U7 a=°C |gond & §8 I fig rt Afdue § Juer  [RELESEES

Foy |
FLe

gde d|
3 055

(™) View=> Page-> Code & A& 'ae aqd | (Afdue § frige 3 boctpmes
Aufge At 33 fe§ € &% Jf feanae Ji3™ Aer 9) | =1
e1a fags
(8) HTML & femard, 3 Hyperlink folder = feraa | A JavaSieript
23 jquery
(7) Afdue 3 € =79 If8 o a9, §€99& € BTt : Add to _iphp
favorites | fos 5% €8, dg S UAC e AT T Sl

Fﬁ?"’ﬁ'l B mysnippets
(T) AT g3 M3 (F12) € 5% g78+9 ¥ v fenet goa 2y
AaE J | WH.Et3efesd (MEW) € fS A= w3 a3

& ed|
&< : feg gv Afsue fane € &et 3uvd Jof &3t aret = ffewr & Ages T | fepmer
AEdTdt © BT IBY “help” TEIT €7 ITHT 5G|

ut A3t 2uBen (PSD Templates)

fea 29 fsmarelag =0 3uTg MIHA M3 ATUdS UH 98T ©f Agd3 7 | We Iy feies
& YyTdHs de< € &8 &% Hed f3arels ©f < 7993 J, fAn a% fedies 29 Aele &

e <Y faaets e dn m@er J 3 3T f@HnM fgafes M3 3 € fegdd H3®s
w@zﬁmuﬁrmwﬁmwzﬂ NS (HTML) € €93 &% IHT Aruas
29 fsarfes g=T Age wam?jmwmmwww
?éﬁzammﬁeﬁ?aﬂ&wwﬁwméﬁv@éﬁ%m
Gust & U AEle ¥ fS9 Az e AfeT § faw fa Sane dee, gan mrfe |

A g9 famfexs gmar (A ngn) AT A6t IRl § #iHEtsefsy (MEW) €t 293 5%
Wyt SgAEle {9 fomm Aae T | fﬁﬁéﬁmﬁwe’rf&afgﬂzamsm SCHY SUBT

& BIHAT J | (feust iR gg ez a5 1) !




http://www.psdtemplates.com/templates/

http://www.freepik.com/free-psd/web-templates

It fegst eeist § g78+9, M@ de, 378583 d9 Aae § M3 feus’ € =93 J9 Aae J |
w&mmﬁeaﬁéﬁmﬁze’rmwaﬁmaéﬁ

ytA.st (PSD) W3 wH.gErsafsg (MEW) & f&a a9 (Link PSD &
MEW)

fea yw pfeur QuBaU T fan €t 93" 575 3IA<19 § B Mus<e 13T 77 AgET J A MRS
(.PSD) gfe® & mude a3 Aer I | fen pfeur & mize € et fa feret =93 fas” a3t

oY

At I, IoT fe3 MEHTT JeHT € USaT 39 ¢
PSD &TEl® & feude ad (Sery efes € Bet fon MacHs € 293 dist At J) | W3 J&°
€3 MEAg a9 :
l.astyA g6, ferefes & S
psd.html € ™ 5 A< 9 |

2. File=> Import-> Adobe Photoshop
(psd).... & AB A I |

3. g QA AT mI Tfes s M8 aead |
Open 3 B &4 | Import Adobe
Photoshop File &7 3Tfestar gan
&HT WTeeT I (A< A J) |

4. 99 U @ fe9 @ud 9y miruns <t
<93 Idd AT €T BT g AaE
J fand fa 3wt félge gaaT ade
J A9 UH A9 3 J&T Gusag
Compatibility Image & fi@ae g8 3 OK 3 af8T I3 |

5. A9 Ufgw™ A< 3T Save 3 If8aT d9 |

6. fene € He UH IfEF I3, 39 iy € Hig mfeer & &2 a4 (.psd) (SRS 357 J) |

7. Update from Source.... & i@ de agd It »A® 3RS & MU3< &9 Aaw J | feg 3t ot
Ae= 7 fa@fa »i.etsafsg

(MEW) I'Eﬂﬂ-)ﬂg\-)ﬂﬂgl H_HH @- b Cut sittellus gy commods. Sllouam
fegarg ﬁ%ﬂ' HHTFUE' Jar ﬁ' | fE?_l’ I Copy iz el cenue 2 21 Haus

faq afear o = ﬁé;ai%’ém (4, Paste i a2

THE (AT MBI MT T gy :
f3afead (ﬁ- Arfee ?:_5_ afes e OO DRI  Frit Sour= (- |sch-term st sl .
S9aIT) €= € Bt gy g | Gl Tkl i



uw f&9 WS (Page transitions)

AT UHHS Aeeend €F 3gT T 2 ¥ Uwt € <9 i fee'ae & MumTet a9 Aaw 7 | feg

fesites & nims fegae feu@e fw vee agar | givtas § AHS 96 &et Jat f&3 et

dtuBST 9

1. <t Ue 5276, few efes & trans.html & x|
3™ &8 AL d4 | :

2. Format-> Page Transition.... & i@ e aq |
Page Transition ™% 3Te&Tar a1 569

Trarsition effect:

WQEr I (IR B J) |
Wipe dosn
3. fen fedae § muzmTet g96 =m3 376 fea Al
feee § fréae a9 &t A1ga3 T | Event: etica Hrds k|
maT@'c';e’fevslte Enter?;fm—orc'aa o ]| cered |

WZ Transition effect: fere EFTEG'ClrcIe?F fABae ad |

4. Duration (seconds): aH f&9° 5 & efey g3 M3 OK 3 AfEF a7 |

5. A= g9 »3 (F12) € &% §79+4 © << fenet v8q &y Aae J | M. gt.sefeg (MEW) €
ffSeAe M3 dz § eu |

&< : U giins frge feedd e WauSda 5.5 7 fen 3 GUg € Taus I AN JgeT J |

Jg&t fE3tut aretut fafenr=t a9

B3t &9q: aH (Activities)
FEEBT dd M3 I& &3 I W3—-fean &t =93 a9 :
(€) Paypal ecommerce Toolkit

() WordPaste Add-in

(¥) Insert Bing Map Add-in

DHTML Hig HH& J96 974 A9 |

) fue® mifgnm fST g=7e I 29 UT € 9 TU-T4 AfSUeH A® &7 |

1

3 fug® mifgnm f<g At It &3 e fedae § I ST UA 3 A a9
I T

(€©) Random dissolve

(™) Blend

(¥) Box Out

(7) Split horizontal in

4 38587 &9 M .PSD gfew § wwrg (fevlige) a9 |




Jgot &3 aF yrst € €739 feb :

1. W3-fean & Gen &t fenrfunr a3 |

2. Jet f3s Samrelet &t fone g€ 7 W3-Fan § 378587 (I & =93 d9s et
UFaH daet T |

3. B9 € &%, AfaUe & HanAe ot fommfynmT a9 |

4, §E€99s € a, UH TTHHS € HaAe &t fenmfumr a9 |

Jot f&3t yst gr=t 39

1. M3-ffaen — vitg fe= figer 91

2. Afue —— g € &9 =afawm 77 Ager I |

3. it —— g € &< féuge di3T Am Aaer T
4. UH SIHBHSE — Hig € &9 fuser I



mfgna & €7 (Lesson Objectives):
fen mifgmm € »ig f<o gAY feo g95 © Gar 7 A<4r :
o FfESHI T SUBCH § TSES M3 AHS JI5 € |

A9 U3 ATsdardt (Relevant Knowledge)

feg 3ust Ardt S EATEte & Halfe3 dad feanTa fey W3 AueT d9a eue f&9 Hee aoe
J I7e At faer fare gt € feg S UAT € S8 I Jde J 3T feg 5g3 dt Agfea ger T |
feg gust Sawete 3, A9 Uwt € &9 gy v dimt & feyr maer 9, fAe fa &,
grilarete M3 Hale3 9T, S0 Hig »ife 1 ig dee g9 R uA fRe Sy I Aaer J |
few, feg 3urst mni mahie @ &9 nfae Uvtis 3 sfesfia @9 use (DWT) & 5w
Y UA € 99 Udns © faarfes § g% AgeT |

A A ~ @- @- , ﬁ Rﬁ éga_ A ~ ﬂ _ﬁ P . ﬁu\ 5 aw:

1 A< AT St.3=fEw.et (DWT) & #iude aae 7, 3T L gnele € f[Sg Arg 9 UA mue
WY WUS<e T AT |

2 gt feq 3 frrer Sta=few.et (DWT) & 97 Aae J W3 Aet L gAEle § ygfes

IS TH UBC T gE%™ A9t 94 A T |

3 A9 29 Ud & gE8< & g€ AT U © fide AUmS g1 § Ot sese &f ferAs &

Ha© J fie @F ded® SUDHT I M3 IIBIPHT & Ha We ATedr | A fea 3 fammer

fse®ug feqd S ORI I IH dde I6 3T B feTg I U3 I3 Garger I |
FfeatHa ¥ Sude § g8  (Creating a dynamic web template)
FfesfHa 29 Suse § a=8< wel Jof &3 gunt & user a9

1 32T Y UA 978 (CUBe @ I <93 IS Bl |

2 W™ MBHE & AHS a9 fA= fa &7 (IAST9), dust &7 ™, arilefee g UA 199

Ud @ A9 3 Jof 28 fors @< |

N o,

3 36 AUWdT fars § IH® J9& €t Agd3 J frusT fige €U 439 9=ar fam € dee

fS9 gl 9€8'= dd AAT J | AUWdT fors § g8 et 9ot €3 Jent &t usst d9

(@) fAg gAt dee § JueT Ige I d9nd § B I° (e 9y feu fAee Gu ¥z9 I fAE

dee & T A gefem™ 77 AgeT J) | HH UH af8d a9 3 Manage Editable Regions. ...

& fAdde ad | Editable Regions &% STe®Tar IdH &Ad »EeT J (IR ST feue
WEHT) |

(") a1 & ey g, B€wds & &Et : Content 1 g€ Add 3 If&F d4 |

(¥) Close 3 If8F I |




» Il

Editable Regions

R gion rame:
Dither regions on this page: Earanes
haree Dot aminks All Files
‘Web Pages
usic HTML Files
Pictures
= ASP Files
Videas A5PH Files
Macter Page
X Ficript Files
iier VEScnpt Files
SE () PHP Fifes
Music Mavie EEE’LH“
add Remove ; 22
Lz 2k ) Test
File name |paoy Template
Save a5 bype | Wik Pages

4 File> Save & fA® a< J3 | Save as type : 397U 378% Hig & f&9° Dynamic Web Template
Efm—orc'a'cr (3A<TT =8) | Tfes T & ey ad, 8vgds & &t My

Template M3 Save 3 a‘F&s—or aq |
sfeafia 29
gnt sfesfia <9
g9 gde T 3T Jof &3 gert St uweT a9
1 File=> New-> Create from Dynamic Web
Template.... & fAd de a3 (IA<TT =4) |

2 fors &% 28 Sude fane © f<g feyret €<ar|
Sude & B ae 99, §ewas € Bet MyTemplate
W3 Open 3 A3 J9 | fem SUBe € MgA T ST UA
g9 w3 feyret e<ar|

@ Attach Dynamic Web Template
T o Why'Web Sies » mysite w O Search mysie B

Jrganize = ew foldes - W

4 Downlcads L Tate 1if

B Recent plases 1 MyTemplate 302073 523 AR Mizroso
-4 Libraries

1] Dpcumerts

@5' Pusic Lo ! >

File arme | w | | Dynamic Web Temnplate b
Tools * Open |» Cancel

Template List

SUB<e € <93 FdaT (Using a dynamic web template)
SuBe (DWT) g=femT T | Aa9 gt fen Sude & migHd 29 uA

_ Fage
Fpa.. Cirbs
PlszarkFiles o HIEL
e [ Ry
e
.,.|.s... ks mme
.-n T A] U5
4"* el ] breaSierit
et
B DR plsy b SaparPra b SHEF12

3 Erawte fom Dpamc Wab Tamgiin -

COMPANY NAME

Web Page

3 fonrs fe€ fa It fage ufom™ Tanme nigng a=® Auddr fors ST dee & efey
F9& & GdT I WT g1 99 U39 AUGOT &4t & | I “Content” 439 ffg gy e
ofey 39 | fen 9 UF & Au9s 29 Ud € 397 A< a4 | §€7098 € &eT, page0l.html |

4. fen sfedfHa 29
AS dd |

2use (DWT) & €3 murfag wie-

We 2-3 UAt S segIefes &



Ffeatia €9 Suse § mifse a9 (Editing a dynamic web template)

e At FfesfHa 29 SuBe (DWT) § nifse aoe 7 37 3rfesfia @9 Sude (DWT) &
9T § ¥ W A9 UAT T S MU iy wiuSe T A 75 (Qeraes € Be, 3?11?3
WMBI-MBIT BEC & T8 € Agd3 J AT AT dee § Yge3s Ji3 fagt dust € B &

nUge ga&T Ig T J) | FfedHa 27 Sude (DWT) & It &3 migna nifse ga:
1. 3T fAgs sfedfia 7 Sude (DWT) fug serfenr 3 87 § 89 (feu erfes macHs
dwt € &% feyret 8<am) w3 fen 3 € 9 If8a a9 |

2. -_a 3 éﬁg ﬁ?r ﬁ? fa-ﬁ- HT g- au'u' a- ﬁa’ Micrasoit Expression Web
AUGSr 439 & NS & 1439 €7 &™H
73 Photosn au-a-_l- Thezre i 1 fil= sttached to by Templatadwt'. Waould you e to update
it now?

3.g< gfedfua 29 Sude (DWT) & e
(Ctrl+S) 5% A< d9 | fors &% HAW
& OY (3A<IT =H) |
4. Yes & fAdae g9 | fen SuBe § <93 & =€ II® 2 ° Ud MTUS WY U< I AT |
5. fem Sude a% g€ IR fan 29 U7 § U8 »3 fen © gea= § fors 5% eF |
6. “Photo” 439 ¥ f&g feria & feaAge Id IS T U § A= &T |
g g€ ZIg ATST L IATEIE € ST Yat IgT B a1 mBa1 BrEe € 93 J9at I AgEt J |
nfad an € f&g gt ffq s=f srfedfia 29 Sude (DWT) 92T Aae § M3 Ad <9 Ud
fen a2 sfeasHa S ¥ SuBe (DWT) 3% A3 75 | feg ses™ (feamin 3 ) g @ g UAT
3 3T 9239 MUSTETT, feH 5% 999 2 9 UA € nEe & guBe €1 Agd3 U3H J Agait |
f€a s=r sfesfua 9 Sude (DWT) a=78< &t w3 A9 <9 UdAT § 736 el
(AT fAdde 29 UH), Jof &3 WgHd a9 :
1”Content” M3 “Photos” 439" & ARY g3 fed a< Frfeafia ¥ ude (DWT) 576:
(©) “Photos” & ®et feq 439 976, (g 3°€73)
() “Content” @ &t feq 439 976, (8¢ & I&1)
2 FfedfHa 9 SuBe (DWT) § &= e7fes & 5% A< a9, §€wda : MY Template02

8T TS dcc ST AT € 43T § s sH e ST Aga3 J, W fen § s= 8wGe &
Wafaa 99 | §F @t 377 @7 439 of @9T a9 | 7 :smmnmmﬁm
(DWT) 3 I Ja&T 97ge J 3T 8T 3¢T € 439 5™ FI3 | 5dt 3T AT gAg dee yat
39T AU &Jt g
g< fon 32 Ffedfia €9 uSe (DWT) & =93 ST ¥ UdT § 51 SUBC ™% 13 |
1. Folder fe§ €t =93 a9d (¥¥ Us) A'd <9 UAT & fAd de &3 (PageOx.html) I CTRL
+ Click €t 293" 5% feq 3 famer Uat & fAd e ad |
2. Format-> Dynamic Web Template-> Attach Dynamic Web Template.... & A& e a9
(3A<T IJ&T T, ¥9) |




Table Ske [otaView Parek Window Help

s Atrach Dymarmic Web Temnplate u

- Wiy W B+ mynign v o reh it
liganie = M Fiod ey - ke
ala e
furrentaVey ek Sheahn it E Corpule
i wTwc' Wy Temngiete
- ) My Tamplabel?

s Mislc Mose [Dv
B Ramceabbe Disk

WA B

Rlepame | T2 w! | Dyraevic Web Tevglate ¥

L P Todls = g = Caniel
Dhymanic Wek Template ¥ finach Dynamic Web Template...

3 Attach Dynamic Web Template STe&Tar 797 &6d W™ ET J (IA<19 &7 I, He) |

4.8 SUBe & B de ad, B¥wds € &eT, MyTemplate02 "3 Open 3 IfEF T |

5. forse & fons 7% €4 | “ Photos” M3 “ Content” € {9 de'e 52 SUBe & migHd
MUE WY AU T 7T J |

sfestHa 29 2U8< (DWT) € 5% AYU3 UA AT A7/ <9 UAT §
Je@<=T (Remove DWT association with selected or all web pages)
ﬂ@'maﬁ%ﬁ-ﬁéﬁg?ﬂ@? (DWT) & fafer AN 39 T93< €1 Aga3 &d1 J A7 IAT €
HIAMHAT (HTML) #tes ot =93 a9 a7 T = fx sfeafia 29 Fude (DWT) §
mmzmﬂ'aa?zr,fmm’rgﬂﬂ'mﬂmﬁm DWT) f&& & g 3¢ Ut A A9
Y UAT &8 f3¢9 dd Aae T
&< : feg <a1 fage fodwafmy ge@er T w3 feg fEa-Uum™T (one-way) fafonT T 1 e w3
Bw@e & fast &3 9T &3 &3 Afer J | feg St A9 It IfesHa ¥ Suse (DWT) 575
GER) d'ue a) 3T Iu$ feg A8 g99T §Y d95 ©f Ag93 I | Add IAT fan ymrfee 3

sfesfia 29 DWT)WSWUEWW%‘HW?U?@?WUT
ﬁ#wwe’rwaﬁ

1. Folder fe§ (4% U®) € =93 5% A9 < ¥ U (PageOx.html) & fAdae a3 |

2. Format-> Dynamic Web Template-> Detach from Dynamic Web Template & fA& ae
q |

3. feure gre HfAm & <4, Close § fAd ae aqd |



d&t fa3tut arebt fafamr=t a9

%3t S99

aH (Activities)

1

Jat fag are feur fagent € wgAd Ifeaia 29 2ude (DWT)
s
o TUNEe € ST U™ & A3 BTt 2% ©f 293 MIBaT MIBar uAt
feg &<1die d9& et a9 |
o doC € 43d fg o9 & =93 ad&T|
o JoT anilarfee afer & feardge a9 M3 9H UdT € 578 JeEiuaféa
(default.html) &a |

Av A ~

S UBe (DWT) & fSa ad |

H&aS

dot f€3 I yrst € ©°39 e :

1 §e9s € 5%, sfedHa 29 Sude (DWT) € §<n & feras 578 miz§ 2

Jot fa3t yst gt 39

1 Aa9 FfesfHa 9 Suse (DWT) & STt |

2 Save as type: TU SEE Hig 3 ot =93 Ffeafia g Sude (DWT) &
g8 wEt JiSt AEt I



AH& 18: WH.EL.6-- Ag9 ffas wWrueHeams (SEO-

SEARCH ENGINE OPTIMIZATION)
mfgma & €7 (Lesson Objectives):
fer wifer & #ig f&9 3t feg a9 © Gar T A7<d1 :
o WHELE (SEO) T d&HUT § ST T |

e WHE.E (SEQ)9dd €f =93 Jda € |

A9 U3 ATsdardt (Relevant Knowledge)

WH.ELE (SEO) Turele €t fdy A won & ygfes J9s &F yfgnm I A 89 I &3
foys 77T 75| HIY féAe 29 Un € d2C § A99 a9 Ermamﬁ?ra"@w@?m
féxdan § ser@er 7| g 39 faesug § feo mvse &t Agas T fx reg féae faw Ig7 o
ST T M fa* TrbaT A IdaT YuZ STt A 1Y A (HTML) #sted € f&w
fawe-fes WA.€.E (SEQ) 9ag fen3faz fouge féer § w7 fa Sgnfee &t =utur Ffdar &
TuQe ¢ &9 AorfegT qaer J |
Adg féas < wiaTedt (Anatomy of a Search Engine)

Aog feas mefemaaz@zm’ré*amsﬂ?am(crawl) Jaar I (T few et
fezrmreﬂaae;r;r'fewrwzr)lfwwaaqn ferted @TaT I §95 I wied J13 Je
d1=ds nigHd BT g8 ST UAT § B 9 fSg HEe goer &

A9 feAe ST U © Jof feg ISf e fesan se@er d !
1 UH T gfee® (forse & Ha9 a9 3 fiage ufa® 70 gddew It feuret fée as 1)
2 U € 9= (for®e § A99 d9s 3 fAge ufad 156 Jdaen dt feust fée as 1)
3 UH €7 dPH 95
4 Ud I394 (H1)

SN o =13

5 g0 UAT @ 5% f&a FaaT h - =1

6 HZddl ¢ane (§8F) ek e

7 79< (Phrases) Chieck where: S

-~ ~ pu ~ - i+ il pages | Etrors
8 ALT Textfenmefeg ............. M3 JI et | Fa
ﬁ:l""l"?"' | 7 Selected pages Learn rore abouk SEG

& Fandte Mudieifdar er T S Fufgwr . UTEE
FTE WRAE (SEO) ¥ 79 T7 frmrer fifue < Teck | ke |

g3 J | TIHTTECH € MEH'T 3U78 I9d AT fere
THREE SEO)frﬁ’FrETawm@rmzr | feg M= € BTt fa Tubdr Ifdar € st
mﬁﬁﬁamﬁaﬂ?ﬁ It M. (SEO) 599 ot =93 a9 Hae T |

1 Tools=> SEO Reports.... & A& de a3 | SEO Checker ™% 3TTe®TaT §7aH &7d MTgET
J (3A<t9 =Y) |
2 All Pages & fA&'ae a9 M3 Check § @ 'ae a9 | farse & 8¢ a9 (IA=TT 24) |




el <] The derrioi & rssrg,

B =] Thar =hi b o reing.

= ilhuhnﬂ\d:ﬂﬁﬁ'\lﬂhhpm.

Bl 5] The e I3 CONnG plasholoes Conbent o Deat T
_-]Tnl-dimpmlm

] Thae o3 B b rekaging

srebdinies, hid Uit 21 [1°4 2 Emr
rembirni, hiond Jnbtied 31 [254) 2 =rar
renbdinkon. bl {Uinkted T3 [3 ] ‘Alarrirg
Aebinkes, hoand JUingitiesd 71 (4740 L=
rendurraet i (Unsdad 155 [104] Errar
Aenberwanrt b (U aSed 14 [254] (=0

(PRI

o] Ka baraarde ara dafred b e Cuge. readmrreark hird (Un#ad L3 [204] "Waming
ﬂhtik?mmpﬁd‘%mwwh... wakerraerk ol (Lindded 5 A 7 Emnar

] Thee s B 5 wissng The <l B oonipers the beal Uil Bed 19, ahach popesds Dobe 3 placehaides
] Tha +hil> bag i reizmng. gerarariad by an HTML sditar, or in 1a prosice sesrch

5] b s ane defined Tor Hhe Coge.
Frarnd 24 saarchabskty probben|a) in 41 pagaia).

ST AUz mifT § B9< A 3id g6 € &t fene € <9 feu® I Waw 3 afsa a9
Ade 7 | §€99s € &eT, “ The Description is missing “ HfAm € &et, fen § Aot a9 st
META tags € 93 &% 3T SAdfouns § IS &9 Aae J | ffq 79 I&3t € ug'e 7
At I 3T feg Uar q9s &t fa S gArele mudhifen T aret § WA.ELE (SEO) 9d9 &
IHG |

dat fa3tu arebt fafamr=t a9

&3t 899 M (Activities)
1 WA.ELE (SEQ) Iag € =93 &% fils g=ret aret S uele § 3netd
9|

H&as
Jgot &3 I yrst € €39 fe6 :
1 WA.E.E (SEO) & Hame &t femmymT ag |

2 §€99s € &%, WA.EL.E (SEQ) Tag & €0 & miw& |

Jdot &3t yst =t 39
1 MA.ELE (SEO) &7 Yar &™H JI

2 MAEE (SEO)dUge § — Hig € 9 HaA A 3T A AaeT J |




AH& 19: @91 — Id&taT (FORMS - ADVANCED)

mfgna & €7 (Lesson Objectives):
few wifgmm & »ig &9 3Ht feo od9s € Gar 7 A™<ar :
e TIHES TS A ScEA T ST farBe S AT JId Jue © |

A9 U3 ATedardt (Relevant Knowledge)

I< 3, IHT AU9s S 9 UAT & 98T BT AL HH A ( CSS)WWE&WW(HTML)
T =93 99 ¥4 9| fegt & mefeq <9 Un fagr A El'lﬂelo( Acfed 9 UAT @ &%
gfemat @9 Afee § ge@er gar I, ug SEaHa 29 Aele § g8 BT 3T§
oot fae fa ASP, PHPWFe’fHHzmyque E"]'Hdddﬂ'mézgmhﬁ??
§wwﬁm(h€ﬁmmwmﬁmm)ww IGERCEHELCH
Jféar, Sféan) a9 <f nrfarur féat T

M3=H @94 (Advanced Forms)

WH.ELFEEE (MEW) € 293" 5% AT Ydt 3gT dH Jd6 &8 &9 ¥ AT J |

TTIH € T93° IIS T fardT 37T 3TeTHR & fS9 HET JI3T AT AQET I AT faH 4T/ §-H&
WWWW%IWWWM%WWWW?
ga<t AUTfe3T € Ag93 e J | U'H J9d &de U Ad=d WaHCHS (FrontPage Server
Extensions)& et ¥ Aorfegr &t FgI3 J |

femm feust :

gde UH AI<d MaAHSHS (FrontPage Server Extensions) fed 3aata d w7 fa Helgnree
gde U (Microsoft FrontPage) At HTEIg A™ee MAAUHS < ¥ (Microsoft Expression Web)
€ 93 5% g=¢ I¥ ¥ Ad=d €T uH Fgngns3T (functionalities) & HIEPHT
Fa=r@er I | I&ifa feg Iasia earfant 3° =93t ATEt AT, Ud fere g9v9g w3 &<t
3gsia € F3t g9 feg IFsta yaret Hat A Fait I1 36 g <t fen yaret
IASIT & AUdE JI& & < F JHASIT HIEhHT da=e8< & H® Av=dr |
HElgATee MaAUHS < ¥ (Microsoft Expression Web) & HelgA™ee gd< U (Microsoft
FrontPage)ﬁWEwalmmmmwmﬁm@a
HEIgATee 8d<¢ UH €1 ¥93° J9d HAHS J13T AT AdET J | ITHa HElgAee ede U
v 9 iger Saa&@nt fs=sune fas fa CSs3, HTMLSWGEE‘THTB-IEWUI
%H%Tfsﬁ%rﬁa’@wghva’ﬂﬂ'gﬁmﬁmd'dﬂdH&d'@E!°r@ds g9 Aae J, A
FUTsT 27 Jnféar itz fige ede UH HI=d MaNeHs & Aide gaeT 7|

Hag IHT muS f€egde € Bl Ton g8 I'gY 7 A Hdd IIST = F JHfedr
=Telgd ed¢ UH AI=d WaACHS § AUde gdeT J 3T gl fen Ans € f<9 ont argt
mwﬁiﬁuﬁhﬁrﬁqdd g9 AAE J | 37T § Seun 9 AT 995 »Et fen &
awl%amaams'@ﬂs'wfwamaﬁr@za @“—Qruzrﬁwam




2°9 Ad=9d (Web Server)

I mrugféar famer (Operating system) & &9 fea-fage 29 Aa=9 € =93 o9 Haw T |
fez, mret Mt A (1IS Internet Information Services) & a&Tee M3 AISd €< »rudféar
fAreHT € fS9 AHS aadt T | aBTTEe mrudféar farer fae’ fa fed »iam.ut (Windows XP),
femer (Vista) W3 @5 7 € f&9 & et et m | (11S Internet Information Services) fes-fase
ger I 8u vy 39'3 BT Sarfee € wet stq afder 7 fagt € fe9 femdteat €t farc3t wie
gt T | IAT et et A (1S Internet information services) & f&3 femer (Windows Vista)
w3 7 © {9 feane® a9 Fawe T | famer Areardt © g At 38U efes ©f =93 a9
Aae T |

&< : Td< Ud AI<d MaHSHE (FrontPage Server Extensions) femer (Vists) @5 7 m3 &5
2008 ¥ &9 Qudgu &9t I | IAT ede Un Aa=a ManecHa (FPSE) € amit & www.iis.net 3°
38 a8 a9 AFY J | ¥ < ¥ JAfSar M =t FPSE € &t Aurfe3T fée g5 M3 FPSE &t
293 &8 gHt fen & uefanw g Aae I |

g9q & g=T8<T (Creating forms)

WH.E.3EEE (MEW) € 77 J9rngns3T ©f 93 5™% IHT €0 § 9T AdE J ITH &
g 73 STCTHA T A9l § Hed Jd6 Bl 96T U3 deHt 8 U 9 ¢

1. File> New-> ASP & fA&'ae a3 w3 few Ua & dform.asp € ™ &% A< &7 |
2. TIH TS dd M3 JoT f[E3T IHS &9
(©) fedted € a1 € BT Input (Text), & feaHde a9 | Kl cfon>
() fesited € -1 W39n & St Input (text), § fearde J9 |
() fewiteg € ureleT dar § fedar a9 € &Et Drop-Down [(H
Box, & fesHae a4 | _sutrit |
() Input (Submit) & fesrge &g |
< 3I3T 9N IN<9 ST fourg migng foyret e<ar|
fedtes & fewGe 3 ufo®™ 3T fen eoH & THeH T J9s S Agas JIge fem &
SIH3H § THHEIT J96 © Bel Jot fE3 MeHd ad:
3.Ufg® Input (Text) §H3 3 € T 9 BT &9 | Name e ixd
- @ fS9 Name §eElU a9, OK 3 IfBT J9 |
4.:g’)=|€1:lnput (Teﬂxt)a‘l'&??@@a:ﬁ&?aﬁj Name: —
v fS9 Email & €U g9, OK 3 a8 a4 | _rosis |
= Hm-u[a:v-nl
5. 39U 85 g9 3 € T9 af&d g9 | Drop-dowm == F b i 1
Box Properties € &% STe®™dI 979H &dd mM@Er

T |
6. faQfa gt festes € urdter dar & Areawdt § fedar a9 39 T fen @et femtes
T 9 JISET € BTl IIG IV FEE I8 § AT I35 € AgaI J |

S5ke ey dform.aspt =




(©) fors fe€& feg &5 (Null) I3 (no value) € 7% fse®e sau 8= I, 3t fen

gege et Remove § A& de a9 Aaw T |

(%) Add...., 3 If&a &9 | Choice: © f&9 Red z7feu &9, OK 3 a8 a9 |
() Add...., T IfBF &9 | Choice: & fST Blue ey a9, OK 3 IfST 39 |
(M) Add...., 3 af&F &3 | Choice: € €T Green ey a4, OK 3 Ifda a4 |
(T) = Name: (selectl) & se%< &gt cane € Color & 9€8 |

7 OK 3 If8F 9 |

FTeTEH § §<@<T (Creating a database)

(l:}lo

g9r © &9 fedst JI3t aret Areadt § AT dds € & 3u7g e AeaTdt € MEHd
fanme A3 I SIBst T8 FeEn € Ag93 I | WH.ELFEfEE (MEW) 3U5 ®Et seran
g&T AET I M3 SeEH fegt i%at § viuE My f&F a9 T I | IeEA § g8 i

f&a a5 & Bet Jot fd3 Fent St udeT &9
1.894 3 Ao U™H Jf&F 4, Form Properties &

fA&"ae a9 | Form Properties 7% STesTar 7oA

SHT e J |

(8) Send to database & fA® de a3 (&5<: &de UA

Hd=d MaHS A& ©f Agds Uet J)|

(™) Options.... & A& ae ad | Options for Saving
Results to Database &% 3Te&Tdr I79H &Hd
Wger I (IA<IT 2H) |

(8) 38R § =0T BT Create Database.... &

fi3'ae a9 | WH.EFEBE (MEW)
J (gTare fAge MuE Wy g5 BEt
Afg@ar gaeT J) | OK 3 af8T Ja
qusiy (Popup) & a8+ 9 |

3

e 2=
Ftabase Rtz | savnd Fiokds | Acional Feid: |
Cornetion
[atabese Conrechon bo Lisss
hd Aid Cornechion
rmatn Dobsheen,, I o she Bl fuam |
Taab ke £o hokd Fonm resulte
| k|
LRL of confi imetion pags dopionall:
| o |
LAL af grror page {op tonal]:
| |
o |
£l

M el Ex i e5sion Wb i

Expression Weh has successfully oreated o datsbess for wou.
The detatess can be found &t "fpdb) diormamds”.
s using the Detabese Resuls Wizard, use khe dats oommesction *dform®

(1) Saved Fields <9 & fAdde a3 |

fonrs fe€ Stes sTean € fIRe mmue

MY HY T AT 965 1€ 99 OK 3 IS8T a9 |
g< € famg § ug 3u74 EW ra=g €3 w7 &de
Ugfan g95 € Agd3 I &4t 3T feg eaH an &dt
I |
feq =rg vafew ydt = 3 At vafagw J¢
gMaA S (URL) € 293 7% f ¥ UH & ©Y Aae
JI

Dt ohass Rembs  Soned Feids | addional Finids |

Form Fakds ko Savat

Fome Fekd | patsbass Column | A1
Crdor Cokr

Name Hame Sz

Errad Emal =

e
oF Zeneed |




SgAEte € &9 g0 § ugf®a d9aT (Publish the form to a website)
&2 29 UA € J9 gl ofes € 7% gan MuS wy ugfan § At J |
1. Site=> Publishing Settings.... & i@ de a9 |
2.Add.... & A8 ae dq |
(€) Name: € f&9 338t s efeu a9 |
(1) Connection Type: 337U 376 Hig € f&9° FrontPage Server Extensions § fri@ ae aq |
(%) fore Bans & efey 99, §eg9s € &g www.example.com 2EU Fd | |
(1) IAfear ud=Tetsad 28 &3 fard™ mrueT @Hg &7 ™ W3 UHEds TElY &3 |
(T) Add 3 ST a9 |
3.0K 3 IfEFT JT |
4. Site-> Publish All Files to...Name (IP address of the server or computer that supports
FPSE) & A& ae ad |
&< UgfaH 996 © BT I¥ AHT 9T AaeT J |
<9 Ud § gy (Viewing the webpage)
g< fericd S Um AF SAfee § SY AAET T | g€ A IHT 90 & B BT TAIAHS
(URL) 2 IfSF gaar 3* gaH feuret @=ar |
fericg eon € fST Aeddt § FT AFET I M3 A QU AEHE € & immrzin
€3 afsa ager 7 37 85T & ynet € Bt fEa Un A<t f[S9
feyre wigAg sAd M@er I :
FCTEH AURS 8%3d fhdb € &9 Aeg a3 dfemr der I
A fuT gaa fen €839 § gurfenr dfewmr der I w3 e _abme
e®3d fedled St udu I Tag Jer J |
fen seEm § dge © &9, fen & Aeadt § e Mg
IU%S @ BT IAL ICTHA Aeced ©f @93 Jd HaE I 1 & -
feg 3U3 ®et B€ Aufed J Ager I A IAT A'd €% Form Confirmation

Av_Av o [ad . 0N = ~ LaY . O N =y 3
MSdH ?=)_ [EAST ddAT dd Y J M3 I<SdlcdT ?=)_ l6gHMcd s 1o

m

FAST g9 T S

&<2: fam w39 € 9 feo Sorele uet T Onet =93

JI5 & BTt ST WiaAUR T €f <93 Jd | 7ad IAT LAN (Local Area Network) & feg 29
Ad<Jd € 93" dd 97 T 3T M I H SCTHH AURS e&3J ¢ &9 A< JigT dfemr der g
faveT & fpdb T |

Had AT WA & FEEG(MEW) €1 S93° a9 90 § 3T WdH H 3¢9 e&%34d fBne =8 f&<
fpdb 3™ € €%39 &9 yuz dI3T AT AaET J |



Jgot {3t aretut fafenr=t a4
B3t 99 aH (Activities)

1 Jot &3 Bt Areadt fEaat dd6 THI TOH § §6M3 SN ©
f<9 fen Aeddt § A= d9& © BTl d6fedd J9 |

(8) First Name

() Last Name
(¥) Age
(7) Email Address

(@) uriEter a9 (35 MBIT-MBTT I § NS J9, 9 F T
edT 96 ot Hfeur a< -fHas fM&ans €f 9 JdaT)

@) fAet (feme & 57§ M3 s97v 3785 Hig & vee &% feu)
() Aee (fare & 9§ w3 397U 3765 Hig & Hewe &5 feus)
@) fus I3 (Pin Code)

(W) A (Comments)
H&aS

Jgot f&3 I yast @ §39 feb :

1. ¥d< U AI=d Manc i € §Tn § B¥9ds € 5% Mg |

Jot f&3t yst gr=t g9

1. el ATee WaHAUHS 29 & E3su= &t At & BE T
2. et et AR (11S) €T YaT ™1 JI
3. Create Database MTUH& 89N YUt 3TesTar 97aH © fee firset 91



ARG 20: 9UH AT LgATEe § UIfeH dds™ -1 (PUBLISHING

WEBPAGES OR WEBSITES-I)

mfgma & €7 (Lesson Objectives):
fer wifer & #ig f&9 3t feg a9 © Gar g A7<dr :
o T UAT & mruShHTTER (optimize) A& T |
o T T ATEH T wiEHT FIrgT
o MIIAMHAT (HTML) & Mruehiete (optimize) I8 € |

AY9U3 A<avdlr (Relevant Knowledge)

gﬁméﬁméwﬁuﬁwwmw%feﬁ%maﬁ
Aae § | TEUSf&a & Age 9 13T AreT gier I Add Agd3 9« 37 fon € feg sev=
aalmeﬂz?;uafxﬁaa?;?uhw m?;rﬂz—a'as@ruwaa?ﬂ@aﬂﬁzr@?re’rﬂﬁw
forat ot 71

SEATElE & €9 T ¥TfEsT (Examining structure of a website)
S'gArete € gretuafda <t

Sha Wmw

fer® 3n<ts 96 | feg 3amst
a<toms gy & Avge fEo Hee
a9 7 fai =t &2 39 Jge f&a &
me'fevérwfewaamﬂ
Tgrfee € g9 § Sue st dot
f&g e St us=T a9 :

1. TgAfee & 8% |

2. View=> Site> Hyperlinks &

A& ae a9 | fem® STTedaIH § 52 3 BARIT 4 e

——+ R cabndridaFek

) |

3. gHT gw AT € & § 99 »iar 4% »i3 Ay Aae

Hyperinka for sbouk Lef el bl

calarvdar Moo b B
contuct ot Hired B - ™

ruunummuﬁ.tma - g i
it Mg_h_,.- g ?-m-.#u rm'“a

phoke,_yalbery dof b B -

“—# chotn_ode
g iy

F

riwn o el B \ -

e

A hruacter, et
-
.-' 'laj':hl-.‘:i.l".hlt?l::?‘.-
-i?‘_]déuth:i
.-ﬂ resveseteat trd

- __Fﬂmumi

“—ﬂ i _galbery ot hid
B infoerestion ket hivd

P Faqkdefak Hird
\'ﬂ conback e auk. hird

ey et
fhﬂ_! saton sk winl. o=
R it bl
A it s el
T rewmidaf i

a- I ‘.\"-ﬂ_ Wﬂﬂ’;:"l’de*ﬁ!:_\m_‘lﬂ calenchr s Fauk hind
o R h‘“‘-—ﬂ phato_geryidsfouk hire
ﬁV,ﬂ' =) ?‘HHT ):i'ﬂ? | contactideFault. htrmi ) Fnj'l' = M :K_ﬂ S
hﬁafﬂﬁ“—or?aalfuwwwﬁma oY (3A<T
%‘tr) I



SgnATfee € ATElE €T »ieTdT BArQeT (Estimating size of a website)
o AT ufgst It e 7 fa Sarete @ ST eels e
fadasT Areta I 3T AT feg 3T 99 AW T fa 3T &
feeas e mafen y=rfesa evmar &3t aret mum <t & #F
gt feg St uzT g Aawe I fa ferdteg § TaAEle dus 3 Fametting

. Bariblehng
, W SRR Iunmay

ufast fen § 378587 I < fdar erehy &arar|
1. View=> Site=> Site Summary & A& de a3 (IA<tT <) |
2. forse & &< a9 (3A<T 24) | ferdne I3t miretert &t fare § 4 M3 9&F &M,
far=3t, Areta w3 Arearat fa3t aret T

SiEe Summary -

ETIS Description

s M5 e4KE alflesinthecurerkske
[ Fictures 2 J5KR  Picture Files in the current sk= [GIF, PG, BMP, cte)

gk Lnlrked files 3 13KB  Files in the current site sk canmok be reached by starting from vour home
%unk&d files 13 SZKE  Flies in the coerent sibe thsk can be reached by starting from your home pege

o pages 2 EOKE  Pages inthe curvent sk= exczeding an estmated dovinload Bme of 3 s=cond
ﬁ Dler il 0 OKE  Files in the current site Brsk have nok besn modfied in over 72 days
Lﬁ Recently added files L& B4KE  Flies i the current site Bhak hawe been crasted in Bhe last 30 days
‘ Hyperbnks 174 A Feyperlinks in Ehe current site

® Unwerifed hvpetlinks 0 Hryperinks ponting bo oneonfirmed baroek files

=S Eroken Fuperlinks u] Hypetinks pointing to Lnavalable barget files
%cﬂcrul hpeelinks o Hyperlinks ponbing ba Fles qutsids of b oarrent site
L& In-erna bvperlihs 174 Hrperlinks poinking ba ckmer biles within the current zike
L] H - gl =rdg chog 0 otha e =

I8 ¥¥< 8 UAT § Ie78<T (Removing slow pages)
IS IRt yge s UaT e fe9 Bgf meleiT § T AAE T A SUB UA d ¥Be ©
f&g mifm Uer goetnT 0% -
1 Site=> Problems-> Slow Pages & fA® de ad
(SA<TT 2H) |

P Friders

2 W& gu &9, MRS HTML) #etes | ooe 90000
feoserTfaim g fer@e st fen g &8s | o M0
Je ST 30 Afds B T8 ITAGT T UATE | w0 ddee 5 uniedrie
sesBs I g sffds Fuermisaer | . | T

I 8ot € Bt gt fone © f<9 3 Afds ==t
dH3 § €% AaE J | 39U 36% © ST 3 Afds & M8 ae 99 (IA<1a <4) |

= | InFoider

Sicm = | Type

Cowriosd Tme ™




3. fors 5% forse § <0 (IA=T IaT 9) |

e | Tk bl Domrdoad T © Sme = | Tupe = | InFalder

b defaukhiml Homa 8 Saccnds B himl
=] cefeul it Ao B Seronds B html about
MIANHAE (HTML) € Udnitedt & murg 3 forg sar@ <t 9- §3fesg e ds a3 ma

Ae i3t Jet asfesy © ST 38a8s I © f<T Sfamm mit

fen Aféar § gewe Bt Jot &3 gert St useT a9 -

1. Tools-> Application Options.... &

fA® se a9 | Application Options Roplcatio VRS Il
&% STe®TaT gToH &Hd MEEr serevel | configurs Eckces | Rimarts viaw | 717 |
W nenlact e auton.atcak: when Exprescion bleh s
2. Reports View '2"8' -é— ﬁ;rg“—ow- a%r [ heck ¥ Exprsssion Web is tre defauk editer For peges
B'HE:]H o= Ganeral
( e-tr) ! [~ L= your corrent Wircors caker schems

3. “Slow Pages” take at least "3 b b

Assume connection speed of &F B St |
w5y § 5¢ a9 (fen & fasfaen P

Fathito PHF executable For previssing PHP pages:

g ffets & a7 fourfen AeT )| t —
&< : fog 3Tt IEAHS AUtE Ot T |
feg &g Jnféar =& U & mits @ ) Fers ]
J<THT f_tf!’gﬂ- ﬁ- I Applic ation Dipkions il I
st.3=9f®€ .2t (DWT) Goreral | Eonfgurs ckoes Repesvew | e |
= Genesal

Hdd IAT g ud ?;3_ g BEt ocert fesare bssthan [l 2] dovsald.
ma- é:a. ZAUBRZ (DynamiC Web "Clder fles sr= more than |72 ﬂ dersad,

Template) €1 293" AASTT ITSUBT T ‘Sowssm'hasthat |3 =] wmeondeta st
gﬁm%%aﬁ' Assume correddon spead of |55 ¥ | Ehps.

I Cisplay gridings whan sasdng ranorts
®ET Format> Dynamic Web
Template-> Update All Pages & =t
A& ac a9 Haw J M3 MU dds 3
ufgst feg watat 576 fa feg A A [ | caea |
MUZST IS |




a3 € MEaB3T (Code Optimization)

Y Ud ugfan 995 3 Ufas 306 mue 9 UAT § A Jd6 ©f Aga3 gt J | fam 3gter
ST Az unfSg Jee e aB Un e AeR We Ao I fen et vee s AT UA §
A%<l IEEHBS I AT J | 983 3 & Jeg< Bel gt fes-fase nueheia ¢& & =93
Hae 3 :

1. Tools> Optimize HTML..... & fA&'ae &3 | Optimize HTML &% STe&Tar 791 579
M@arJ|

2.fsRswic e dos I naer I fa gt file 3% e rreme 2l x]
az fae fa e nrfe e o3 9, fer set @9 ranvs conmens

% s 5 ~a i B ALETM comments:
e § Tawe @ AranE wefen dan 3 ufesT G e
feg Agat J fa fegt di'e mife § um € <9 & St cmmerks

gerfenT A< | fen Bet fend 998 € BT, Remove St
2 ~ puc. = ’ o R s
Comment 7aHa & f&5° AlHTML COmMMeNnts & g o oy

¥ HTML [adng whitaspace

A8 de 99 mF OK I IfB d9 | feg g aHe ¥ HTML al ahitespacs
-~ U? m | Remors Unussd Conkent
I Marge adiacant tags

2 U7 § WEgs (rudhrEt) 9s mE dat FEee
fa3 gedt & useT 99 Sl ey

.o ~ =~ =~ 0 o o v v . ¥ Tracing [mage and [nb=ractive Budon sttnbubes
1. uyfgst 3' 9= g UA PRI (ure-we fegat @ I- Gereanor an BrogtD 4305

ATEH 5-10 KB ST 901eT T, IBETE FETATEIH W e
&8CTHI)I BestoesCefaks [ [ o ] o
2. Remove Components f&He & I&T ATaT Mretert
(Al) & BT JT |
3. OK 3 IfBF q9 | MBIT-MHB T eTfes AElT & 8¢ I3 |
IBIPAT (brt) & ST FI&T (Fixing errors)
TEAEle § yafer ad9s 3 ufgst 3ug feu wdalst se@er gwler d fa gos fan um €
feg agt ait/mifr &t 3t &9t I fand fa sta dizsT 7rer 91 feg o= it Wiz
SgAfee Uafen d9s % MBT T&T 83t mifrmr 3° gugar| fen & ailt/asst &

SdleTEt w3 fean a9s BET ot &3 aen St useT 9
1. éﬁEIFlTEﬂ? i)_ ﬁ_g_ | Fecalculabe Hyperlinks ] |
. o v p | TheRecskulste Hyperinks command does the following:
2. Tools=> Recalculate Hyperlinks & fAg'ae <7 i
&4 | Recalculate Hyperlink 7% stfestar e L
. =~ - - - Synchroness Web debs, detsbace nformebon, end cebegones
gaH &Ad MG TT J (IA<TT 24) |

This process may tahe several minokas, Dosou wish bo conpinoe?
3. Yes T IfBF 99 | fTT Add oot St AHfmT
J 37 feg WuE Wy S T At 7|




R I

dat faatmt et fafamr=t a9

&3t S99 I (Activities)
1 ufgst geet aret fan <t Surfee &t fegn® sfege g6 I fer §
MUS IHHHCH € &7& 8T dd | MTUST 2 gATEle & fRg M a.amHns

(HTML) &3 & »ueHTeld a4, AT mied3ie 33 § JeT fef |

H&as

1. ATEte AHGt (Site Summary) © €< € 8v99s € &% fenfimr a9 |
2. UTHIAT € 578 a3 MUSHTERHS (Code Optimization) € €ew € femrfym a9 |
3. 29 U € &9 WU Wy »dd fean (™ 3t 39&) I9& & 8er ot formfnT 39 |

Jot fa3t yst g=t g9 :

1. TgAEle € B9 § euT Ber RS © fe9 FIUTEE Mg € 55
g € =93 a9 Aae J'|

2. Aele Mgt (Site Summary) sTUSEaHig & iz € e fimet 91

3. MIAMHA S MEIH3T (Optimize HTML) g © e fiset I

4. FaBaBe f& (Recalculate Links) g € ffg fHser I



ARG 21: 9UA A LgATES § Uaf®H dda™—I1 (PUBLISHING

WEBPAGES OR WEBSITES-I1)

mfgma & €7 (Lesson Objectives):
fer wiferm & #ig &9 3t feg a9 © Gar T A7<d1 :
o Juféar Y=rfesa § g5 €
o UIBHIT MUHS € 575 oH 96 © |
o THUIH T I3 JAd& T |
o TuNfec T HIHU B T |

AY9U3 A<avdtr (Relevant Knowledge)

A Al g% J fd g7 B 3T e M. aAMHAS (HTML) & =93° J9d faafes
13T famr de U AAS 3T IU§ dec & < 9 AI=d © §'3 IHC 996 € Aga3 J 3T H BA
3UF dee & Y AIS | JET 3¢T € He3 © fF9 GUmay I =& Aafen y=eisg o # fa
He3 {9 3u3 dee Bt AUN HIehT gJae@e Js I fegf fSe gy g mUR S gy da J
Wm#wﬁéﬁm&z@%ﬁmaﬁa@fmﬁmﬁ@@%fméﬁamw%
I et SRSt AT MY A MHAS. meﬁﬁﬁammwmﬁw
mmémmme’“@vﬁmwﬁwaﬁ@??%wa

<9 JAféar =retse w%%%am.wu&mme’rmﬁﬁaﬁ@gé‘a
JAféar gw €ar fA=” fa SFTP, Web DAV »irfe & HJehy™ Jaehir g5 | fan & =93 3t
»USt LEATEIR § MUBT J96 € BT J9 AAw J | feqt &9 g9 g+ Ear &F = »irfapur
fée ga fae fa wim »ie 2t ut (SFTP (secure FTP)), WebDAV, FrontPage Server Extensions
wrfe |

"3 fAgsT UA »i3T © Bt ot aas= § few@er T feu Areadt @v um € <9 fe3t
Jet I

fAgs U7 A9 A S, & AofesT &7 g2 I gs G5 »et gt fan <t j=rfesg
faggT fa #wie @ Ut (FTP) & mfgtiar goer 9= & =93 Aae T

<gATfee § yafsd dd&T (Publishing a website)

fea =g Ae AT TEAEle § e BT I 3T, 30 fen & BW JfuBed €3 usfen ags &
Ag93 J fausT fa fediean KWEE%H%WEWIH?EHTWHTUE'@BHG
WWWWU?WW?WWWWWWM
fAst @ 5% At dee & Uafen a9 Aae J | feg »uAst g5 : FTP, WebDAV, FrontPage
Server Extensions MTfe |

e gt dt (FTP) €t 293 &% S gnTfee § Uafen dda € &et o 3 ger &t UseT a4 -
1. €7 Suvele § ¥ fand fa At uafew gos™ 97d< T |

2. Site-> Publishing Settings.... & A& de a4 | Site Settings 3Te®Tar 7aH &wd MEET T |
3. U q95 3 ufgst Iumd SHEGHS AfuGed € et Ut (IP) i3I A7 3HS &™,




AféTT M3 Gad 3™ M3 UHS9s €1 Agd3 J | 8€ 09 € BTt Add AT GA g gnféar €
&% ATEIS Wy 13T I fAns fa 3ov& SuArfee ysfsy d96 et 192.168.1.200 mret ut.

AFTR wF W A (FTP) =78 &ar fegr § 37 Jof &3 sren &t user a9 -
(©) Add.... 3 &f&a &3 | Connection Settings STe®Tar I7a7 &3 MEeT J |
() It f&3t aret fgew & Meg aq
(i) Name: S0 g9 € &9 a™ el J9 (femmer3q feg 3973™ 3HE ™ A SHSIons
dfuged & & AT SHSSHS T Mrel. Ut WEdH ger 9) |
(ii) Connection Type: 39U 378% Hlg € f&<°

FTP & M8 e ad | Site Settings ?
(iii) IAfar y=retsa vafen a9s © &t ug General | Preview | Advanced | Publshing
CLED H_ng|’ﬂ' O(d'é"g'ﬁ' ﬁ', Qﬁ'dd(} @'88' : Pubizhi _»estna -

ftp.domainame.ext | Location: oA ITaH &
fSgugafeu aq|
(IV)@F%W&M?&%%&%?&H’E? | s | | edte Delete St a5 D Fal
FI&T I (fammerzg S9nrfee & wet
STfedacdl/@%3d MTUS WY gfemT Jiar J
, Had Aga3 9= 3T fen &t =93 99)
(v) Credentials: AgHa € fRT gAd €" 3™ w3
UTHSdS "ed d9 | 9.2t MM S (HTML)
WIted 3 vafer g95 Bt fer <t <393 i3t
A7t 7 1M 39 3 aEt erfest & o
MM S . Sted M3 SACIOHS &
fegarg ffa & Ifmdm AeT T |, fAn &% a3 =4 feg et 39 T A<t T | fen Afdar
& fAe I 87 397 afoe fe€ At feg Aag famer Fgdz 9= 3T IAfdar U=relse € 575
HUdd 94 |
(vi)Add I IfBIIT |
(€) Publishing ¢¥ € f&¥ gse%= § &< a7 (3A<19 <) # fq fev a3 gger 7 fa fane
Aele & fane € feg w3 a9 f&3r famrr T
4. OK 3 AT a7 |
fae rrete Aféar @ 5@ dee & vafan qus &et g Wi gt safsg (MEW) fanma I 1w
e’rﬁfwau&f&m(mzm’mwnms’rnm gI&T I I 3T I fIF Jedt &F
USSTad
5. Site=> Publish All files to [NAME] & i@ &< aq | fea =79 vafen d= 3, 29 8w9
o =93 3% T uAfee & 2Y |
<9 Udd (Web packages)
WyST SATele & fore dfued €3 & o AT et €A™ €91 7 29 UdH Af<ur| AT
WSt 29 wﬁzewmamaﬁi@w@?mmgxﬁﬁmmeb
package) ) fetr &t =93 59 Fae T | feg §F afearte der § 78 grt must Saamsie ()
fam fore dfuGed 3* 9re agaT IdE T (including the complete structure) FITE'#T%*HHTFE?
W@a‘em‘ruﬁwymwﬁmaﬁs’rwﬁm

Oiptions:
[l nclude sibstes

|| Otimize HTML during publishing T

[/ Log chang=s durirg publishing

Cancel Apchy




29 U3 € 7% Hge' < gAfee § WaAude J9s BEt JoT fed JeHt & UseT aq;

1. é!aﬂ'rfg? -{':}_ Erg—l FICH Cotatvies Pangk  Window  Help
. o 2y = o] e e, Cirh-ShitHy
2. §|tg?Export toWeb Package.... & i@ 'de a3 (3A=ta et S
W U)I REcent Skes k
. o=
3. Export Web Package &' STeaTdT a1 &Hd MTgET .
EN [a=]
Ul Publishing Settings...
. py - o ~ o . Ay & B Publsh Curvant Fibe ber Lol Chi+Shity
4. 37T eI TS AT SBIT S IS HOE T AT UTT SIATEC g it comromtrics o e cotespinss
& UdH g9 AdE J | Ydt SUATee § UdH 996 & BEF :  Grekralrksnied  colchivm
(©) g¢ B39 I IIHd & 94 (C:\ fora &t J) 1 Add>> e
~ v — — [ SRVEN -~ Eapnit ko P e
3 ABF JT | &€ J9 fo A UH
U © f&9 ydt Sanfee mis & EIET
a = Schact th ribac tou v id B 0o pocdiag e from ol e and chok tha Aod button. [P 4o Mol @ £ cao Bra
a‘rg"]' U‘ | dependendes of kame & oo sebect Ehem, cidoon “Show Depe ndercies.
N~ -~ v L = LH _._.chﬁn'ﬂci.. l
() IAY fomr 09w © wet fifgasT e e e
THT IE SH T3 AAE T | By
. o v — -~ IF '_‘ Fnﬁ
Properties.... & i ae ag ma [+ oo
Web Package Properties 57% il B ] —
- = [ 5. i
Ffe®Tar 9N sHd MEET J | ! Bl
. = - ] bottorss.jog
(2) At dUST T &, Jud &7 D bsest i
&Y w3 fere wet fiw ga=t R Feiskarl
TTEle® nied od Aae T | W o
External dependencies: € f<g N A
gJdt AUst € get gt 9 fagt T I )
ot <93 29 Aele a9t 7|
feg €€ rofea der § A< It fan =t e, 1
eI T O g ldn et s9F ao g0 d fAam & 1 [THEEEEE
fan &% 9Ac 3 ufos™ Ineld d9s St Agag &1
(i) Title: GaAe gan € f&9 erfees § Mg aq,
8eg9s € Bet: WEBPACKAGE | |
(ii) Description: ¢ame gaH © fS9 ATsa<T & i
5 @orgas & ®et - Created using MEW |
349, G g : Crea g G R
(iii) Author: 2ae gan © feg s Mea ad | Eraensl dpendeecss:
. N o - W o
v W btk i i oy v T e
OK 3 IfET 7 |

5. OK I afdaaqd |

6.7 e Ufen e 37 fen 29 Udw & A< d9, TEI% € &™H § 2'fey a4 | §e9ds & &et
. MyFirstWebsit e_DATE ey &3 | | Save 3 B a9 | foirs &7 farse § €4
(3N<TT =) |

7. OK ‘T IfBT A |



s HL | A
ket - £ - [ F| ) sk = mkes | [ 'l ) Falder Syre

fckrees | ) CADocUrard c and Sattigel by Docurants e
- . | o] Tope L
Filis sl Foddar Tasks =2 | Comparn 01 File Foldes 4
- s Compary2 Fin Folder )
' WeliEa iy fiker & Comparyd Flle Folder 4
& m"'““”'”" bo the AN e Fis Folder 4

L R

) e — J WErchabsta 0 1,70 £5 Micnosalt OFfice FronbPag e et Padkads 4
-I4| | _"I

G csse I AC Mg At fer S g Uaw S A= A3 9
w3 ydt T 9 Arfee Ua+ €t fias efes § 5T 39 |
&8¢ : Uad & mAat 5% ufgeres € ®e, 39 §
Hger 39y 3% AT T976 499 3% §€8 |

Pblishirg
Papliberg St

15} Pabioh Charsmd Fla...  ColishitaH

<9 Uadat § fewlae a9T (Importing Web | imimiem.
Package) = e

Hag AT fem 29 Uaw § g0 dfuSed €3 fenude agar g I 3T Iaf &3 gent &
UBITAq :

B tioport Web Package B 2ixl
1. o<1 Afee 9278 (WSt Afee), ol s n dmmamnand anmniror o s oo
Dbt on:
JgAete T & fe€, Gvgas € st Fi Do e rd et b S et rgane oo
. - Ita e Fron Yhinh packac ba mpart:
: MySecondWebsite 2€U J3 | | T ST
i # B _Pream ] ek
2. Site> Import-> Import from Web slanh
Package.... & fA® ae 99 (IA<IT <) | = Bis o
= E!’ ET. LR
3. 997 a9 M3 29 Uad § dae B e s ot
- = o A = o [ P
ad, Open & A& &< &3 | Import Web T et 1 = oo, |
Packag &7% STe®Tdr gTaH &Hd S
Weer I (IA<IT ) |
4. AT AT 3T ffast efes AT %39 § ¥< AAY J A Ydt L gAfEe § ¥< AaY J |
Import ‘3 af8a 9 |

5. Yes to All § A8 e a9 | OK ‘T AT J3 |
g< At fen SaArfee € 9 29 UaT § #ifse g9 Age 1 At 29 UdH & Fomy & grut
M T8 An &9 <93< Bt JY Aae T |

SgnTfeet @ §34U BT (Backup Websites)

Mwﬁmﬁﬁ#ﬁﬁﬁwnﬁwﬁﬂw AT Je3'=d wfe) 29 Afee @r
Ty Agd BT grdter 7 | feg I T fan U Samy g% A feng fan niegst irus €73
mﬁwawmalﬂ?gﬁw&?gmméaﬁnmawmmy
ufgst AT feg a0 J9& 3° ufast feg gatat 976 fa At Sy & femr T |




799 3TF a& fAge MY HAS (HTML) deC (Fetd 21 UAh) I 3T Jof fid 3 Sar <t

T93° Idd IHI S AT T Y & AT J

1. 87 g 3 76, fig At S9Aee § AT aad IftprT T (fSe®e &aHa Het sTgHe
(My Documents) ) |

2. G B39 & g< fan € 9 yat fanfee I

3.fer & anit a9 w3 gt 8 (Bdws) 83 Une 99 faw’ fa U's soete Af g dfued
T eB39 &9

dat faatmt et fafamr=t a9
3t 99 oH (Activities)

1 Jot {3t aret SaaHle € T93° 578 MBI-MB T TSI Y=EisT €t
IHSTAT :
Feature Provider 1 | Provider 2 Provider 3
ISP

Monthly Price
Setup Fee

Disk Space
Monthly Traffic
Ads

Languages

ASP

PHE

Databases

Access
MySOL
Microsoft SOL
Email

POP3 f SMTP
IMAP

Web Mail

Sub-domains

Templates
FTP Access
Static IP address

5 SHATELC €T U BT

(€) frigre 29 Uaw &t ofew § o8 © 3t 29 Uan &t «93° 99
w3 fen & fam edt g I a9 |

() AT MruST 997 fana saeie € 99 Hger fanfee & g+t
FaHs €@ €3 ant a9 |




H&aS
Jgot &3 I yrst € €39 feb :
1. 8vrgds € & 29 Udd © 8vn < foufunr a9 |

J&t fegbrt yrst gret 39

1. yafsfifar Aféamr (Publishing Settings) Wiy & feg fimet 71

2. UIA MUAs _ Mg € &9 st Aiet 9

3. Import from Web Package mums__ Wig® _ sausgs 9 fset I



ARE 22: MEfdar g8 (AUTHORING TOOLS)

mfgna & €7 (Lesson Objectives):
fer wifer & #ig f&9 3t feg a9 © Gar g A7<d1 :
o mrafdar 2% (Authoring Tools) & @€ & IS T |
o IHUAT (KompoZer) € §€7 & AT €|
o HaOHIFT sThife=a (Macromedia Dreamweaver) € 8€17 § AHSE T |

AY9U3 A<avdtr (Relevant Knowledge)

fues mifgmm f&g At WaAdHs <9 (Expression Web) € &% aH d9aT fRy g T I fem 3°
fezrer aet yarg € 9 mufdar & <93 d96 € & QuBTU 95 w3 frrnrer39 €7 dH J9
T €91 f&q fagr 9t I | g9 yfitg mafdar g% €t g9er fen iisGw fee a3t aret 91

aHUHT (KompoZer)

(% cmates _camonres i
- v - e ER e per ree Toe mer ob ;
afiAg  féa Gus AIA e = S L G lm D28 <
WYSIWYG HTML w3ted &1 o sl s iii-ma== LI
- ~ au . [tmkre vt =0 Sl BT EEIN
IHUAT W3C € <1 il <ot T i “
N [T = o 5 =T
UHIT e J | AT Il -
. [ T | | i3
1. www.kompozer.com f&a
ff9 iTe § 8=&T I |
2. Addts & §°3 feyrehut e
Jorfeat MEHd A 9 MI
Aecand fened8ns & yar e [ eealieli o
. = = I i
aa— I Creale anew docunvent oF bermplabe El
3. Start-> Programs—> KompoZer kil of Fls 0 ek b crate?
& A8 I g | & LA bark et
_ = _ I crese axHTFL donmee [ Soct oo
&< . feg 3A=1a aHuAad (kompozer £ e denant based e gl _
-08b3€n-USWIn32) =gAS @- 1‘%4%_ Enter theseh ocation [LRL] of the-template:, ‘or thoose & rx:--.w-'r;ﬁ
et et T | 2 ! S
[ & blank templaba
g< 3nT fen & e s a9 fomr 7 L prm—

W3 IHT MBI-MBIT 2 F O
=93 5% UA g g, AR 3 &y
Ade |

IHUAT O F93° &% UH 95 BTt JoT fed JeHT &f U&aT a9 :

1. File> New.... & fA@&e a4 | Create a new document or template &7 3Te®TaT I7aH
&HT »MEET J (SN TH) |



2. Ablank template & fA®'ae &3, Create & fAB a< 9 |
3.9 dee & efeu ad, aF & Sue Bet Source § ¥ ae a3 |
JIBU ES (Help file F1) € 293" 7% IHT aviwg €t 293 Jdat iy Aae T

FdMEt=ad (Dreamweaver)
39 Fai<t=g & 99 yfia mrafdar e T famet fermua =a3° st Aiet 71
W3 T FIHSI=T HTML 3 CSS €t AS 393 § Aude 3 fewrer gt 3gt &t ndfdue s &
AUde sdeT J fA= fa javaScript, VBScript, ASP.NET, PHP wtfe|
1. adobe.com ¥ f&9° sdH<t=q € gorfes MstHs I8=BF aqd |
2. Adts €°F feureht gerfest e ugeT a3 M3 Areeand €t feanedns § Ydr ad |
3. Start-> Adobe-> Dreamweaver & fAd &e J9 |
JIBU TES (Help file F1) €t 293" % It SoH<1=d €t <93 adat fHY Aaw T |

dat faatmt et fafamr=t a9

B3t 899 M (Activities)
1 & eSarden fe8wa (NetObjects Fusion) § 3885 3 feanes a3
"3 fer 5B IH J3 T |

H&aS

Jgot &3 aE ymst € €39 feb :
1. faw f3& 9 nafdar ¢& <t fane 576 |
2. faw € 9 mufdar g& &t pfeur=t &t 3BT 39 |



ARG 23: AL AAR 2ud< (CSS TEMPLATES)

mfgma & €7 (Lesson Objectives):
fer wifer & #ig f&9 3t feg a9 © Gar T A7<d1 :
o AL AMA (CSS) SuUBe €t 93 J95 M3 fen & 378 =8 T d95 € |

A9 U3 ATedardt (Relevant Knowledge)

ae g Auet fey o8 féegen & femfes agar ael yafas der J faffa fem € =t
fenast € &9 sessHa3T Jet gdiet 7| feg fag fewfes & se@< wet 3u§ g9 agt
mazewmafnwe’rmmwi%rfsﬂarm%*amasﬁﬁaqdo m’rdu-ofem;r
H2393 HudsT €3 <t gefag sfoer e I

7 At fuATfee § famels qae 9 37, 3u S ST UA S HY 3 3w els aas ©f Agas &at
U|mmgﬁmémwmaﬁﬁmek€ﬂmmwf€vmm
w3 Hosz 9@ I 1 ug AT M. AHAE (HTML) #3teq, & <693° 5% Sude &
W@?Mﬁﬁ,gﬁ@éhﬂ@éﬁ??ﬁ%%ﬁéﬁgwma
n@@ﬁfﬁea—?aaﬂa@ﬁl

AT 7" (CSS) ude (CSS Templates)

alan M3 € TaAEie s=< ©t g, fiegade €3 <9 oz Sude fime o& gwt
S&T € =93 a9 Fae J | feat § CSS Templates 77 XHTML/CSS Templates faar #ier
ol

feg Sude fimrdt AE39s § YT aae J¢ Tue fE9 Aue B 75 |
IS AEaEt € BT I&T I¥ SUBC HITHT FaeTET TBMT S gAEler € gt fESt
aret I

o http://ntml5up.net

e http://www.cssportal.com/css-templates/
o Wwww.freecsstemplates.org
o Www.free-css.com
o WWW.templatemo.com
* Www.oswd.org
o Wwww.openwebdesign.org and many more....
IHT AL A (CSS) TUd< €t <93° IoT e JeHT MEH™T od Ad< J
1. Gudaz &3t aret fan &t Sonee § =4 (A7 fen & 89< © Bl A9 feae & =93
9) |




2. 999 3 M3 SuBc & B de ad |

3. famarag SgAfeet 29 UA @ &9 Adt S9ATEie € ATEle B9, ACTEIS Hie w3 ATdT

3A<teT § T fHa® dUH €%39 € 39 3 HI e a8 e I& | U A SEls &

IEEBT dd M3 B39 © L feng »a-fau (unzip) 33 |

3T Brete yifel © oot f&a & S ag Aae I # fa 30§ Sude & 378583 d9s 3

UfTst HAS Has & 39 fa3 frar Y313 e @ g5 oue o fegas fider 71
FCEBT q9s 3 UfowT famrfes & Aga 9 ad |

1. feg T 93 8aBs YUdt de S T THUA S UB ITH UA €T TEIRE SH MH 39 3

index.htm, default.htm A7 home.htm deT J |

&< : 3¢ famit € f&9 3uv§ SEATfee 3 AEls »U J96 € Aga3 Jet J | MuShyT Agast
€ B TEAfee § 9T AT |

Sude § gEeHTElfrar aaaT (Customizing templates)

SuBe & 9Ese e AT AU9s Sane MIled € <93 99 AW J | Ud, Had 3u78 fen €
mmgﬁmma?,gﬁw.ﬁ.w.W(HTML)msﬂzam?ﬁﬁmﬁm@
(MEW) €t <93  Jd AaE T |

feo St &< a9 fa Ad9 SuB< T fa8a® 3= HSSI8 € J M3 W HHAE (HTML)
nFteqd fen AS39F & Alde &dt JaeT 3T AT SUBe AdT &d1 &ud »i=ar | feg watst
g6 fa Ft MY AAHAE (HTML) #3Ted SuBe § Ydat 397 AUde JaeT J |
?ﬂﬁ?éﬂmgﬁgﬁ%ﬁaﬁfs@(MEW)ﬁqdd Jot f&3 »igA™d 99 Aae T :
WH.EL3EEE (MEW) & 98576 |

2. ﬁmﬁ?a@r@(wmﬂ'éﬁm&?%
fSgeudec § erec aq9)|
3. SUd< e%39 ¥ <9 Adhrt eretst § anut
aqd (AT feriae fearas & <93 d9) |
4. I FAAHAS (HTML) wisteg e feg fer
& UFe d9 (FEt®t § G=dfdes (overwritten) € fed HeW ymuz 9=4r , Yes ‘3 If&8F
4d) |
5. 3H U (index AT default.html) & & (3A<TT =H) |
6. T gAfEe § AHSHTEd &J |
7. A9W 93 & €y¥T Bet, View-> Page-> Code & fAdde a3 |
dot f&3T foras Afgz yuz a3 famr &
HI A MH (CSS) €t 293 578 IHT Maand ?ve' Jiféar s & fa<ay d9 Aae 7 (IA=1T
) |
3<Nams Hig & 978 ®Et gAT AL A A (CSS) ¢¥ famrfeag (CSS Tab designer) (http:/
Jwwwhighdots.com/products/css-tab-designer/) &t =93 aa Aae T fre* fa 3nate fea fourfenr

farT T




_m Products | Services | Support | Oedar | Mawe | About

R I

d&t fa3but arebt fafamr=t a9

w3t 499 M (Activities)
1 ALAAAH (CSS) Sude § 38583 a9 | fem Sude € fsafes &
=33 fuest »iform @ &9 gt Sarete @ ffg a9|
2 ALAAAH (CSS) ¥ fsafess § 378585 a9,  unfee € &gt
&<toms Hig 9278 |

H&aS

Jgot &3 I yrst € €39 feb :
1 At AAA (CSS) SuBe €f <93 & 8<wn <t fomfumr aq |

gt f&3t aret yst et 39

1 FEAAAH (CSS) SUBe He3 <9 Haehn ads =&t fan f3s Sanfeet &t fane
sy

©) |

() |

) |




ATG 24: 2F MuBlanas € #au Arsadt (OVERVIEW OF

WEB APPLICATION)

mfgma & €7 (Lesson Objectives):
fer wifer & #ig f&9 3t feg a9 © Gar g A7<dr :
o T WUBTAHE WM™ Ay & AHSE € WaT g A= |

A9 U3 ATedardt (Relevant Knowledge)

AT AT MHAS (HTML), EARAH (CSS) M3 HEIGHEE WaHUHS < ¥ € T93 &5™5
<Y fgmfeféar gaat ity g9 7| feg ved 9 Ua AT SgAeet § 98T aet U5 |
308 FoHig dee & feu@e =att et Sunrfeet § &e di3T deT € fae fa g&qr, a0
&8 (blogs, forums, news) mTfe | IHeHT €t =7 AFI3T & YdT A6 BT fafeT3g < gATetet
g1 AT 9H & fescarde daett & (8995 € BT : IHeHd € AT § I3 it
5, A few G3ue & =93 @ 9 AotfeaT J9et I&) | mue @3yuTet g9 Areardt
HJEMHT gee8eT A Acfed UAT & 0t Aafer €< fed =g Ags3 J|

feg fagt SATelet € e AURS Aenfy ©f Aga3 det I fAe fa e Aesd M3 =9
A9=d | feg Ha=a-AEts Afquféar s & AUde ddet J | Ag=ad-ATEls Afquféar gmr @9
AI<d 3 dF § YA A I< &9 Hew ga9et J; §eves € set e ut. a3 & URA d96 @3
fea 29 Aa=g & Ut Me . féeaued (PHP interpreter) fewes a1 Ifewr g € Agas J'|
fae’ fa gat foar farrr 3

Uatzbasze

. b
A login.php | A

F {-:------------——-—-----———
FHE " L
_________________________________ S
C Send page im HTML -

| Web Server Clienl Corrmpuler
(8) a@fee dfued =9 Aa=g Bt &ar- fes (Login) 53t gAET I |
(»1) €9 Ad=d PHP 33 ¥ &% &ar1-fes & Areardt € yuet ader 7 fq feg sta g AF

&t |
(¥) TH HI=d IB'ee AUGeT § AUES MW I MHAS (HTML) € i[9 gmrg féer 7|

g MUBIIHS I« AT 90 < g MUBIAHG T, »id € AN’ fE9 femmerzg 9 Aretet feg
o FI=d AE18 AAfaUféar Bqrew 37eran € &9 mireterd & Hed AT YU dd& € &t |
o gBTEe AElE Aafauféar S qrew femtes © oot fanme & feu@e wet =gt aet 71

gefee ATels Aafaufdar M3 Aa<g ATfes Aafauféar & grew § wrun feg i@ 3 3wt
feaq =ubyT 29 Arfee 9T Age T, feg femted @ et aret SubyT 3adgT T |



I9q 3fesfia ¥ ATfee & 37T & A Jds BTl IeT8n € Aga3 gt J, feng M 39 3
-7 (back-end) =5 AT FieT T | faraw of 3i® Ag93T © MEHT ITeEN f8Hs &
Wwalgﬁwwmﬁmwmaﬁ@rﬁwwqwsc WMIAAH,
SQL "d=d, §da® 3TeTHH AI=d, OpenOffice.org Base mrfe| ?H"'H' 39T S'Fﬂ‘ gde-nF
wmﬁsmmﬁ E’f%'%’fﬁ(ﬂ'%ﬂ'wm_sf ) € =93 J9 HaT T |
frmegg yfifrag e fiee feomis T

e HEIgHTee ASP 3 HelgHee SQL Aa=d |

e PHP 3 MySQL

o AW H.UT (JSP- Java Server Pages) "3 §3a® 37eT8H HJ=4d (Oracle Database Server) |

Y MUBIIHES § IS8T BT fopmer fitue, mifgni iz g fen €t 7ga3 71 ua, Jet
AUTI& AFfdUT (stock tickers, news tickers) 3° ars&eTd (forums, blogs, Iearnlng management

systems, content management systems, ") Aafaue €t A € &t aet Gus Ran ufast fammg
UBaHsT Gud ey 5 |

faQfa fem nifenm © &9 Gus Fow wiustans <f =93 J1St aret 7 fen @et gt fius @
BTl AOA 95 & 38683 Id AdY J 3 A'E AdE J fd MuBlaHs fa= aH g9t J |

&2 : uifa ffg Gus Fan »iustanst Gudsy 95, ud fer wmifgme & feg =33t aret
MUBtaHsT PHP 3 MySQL €t 293" daett 0& # fa ig 3° Fu Safamm Are =@ dHtans
(H®) J | fer Ans © 9 At gt @ ¥ Wusidns § 38683 d9 AT J |

deT Horr e fArer (Content management systems)

dcT HaTH' e fAFer 2 MuBStans get 96 w fa Sane, arfedn W3 Haehishr dee
& HaH d9s € B! faarfes digtit At g5 | 3Rt %91 geger ufost It fiy g9 T,
feg A9 I W™ 93T ATt B T MUBTIHS J fer € =93° yd AATd & o st 8o
WWlﬁméW%mmmmamwﬁs@ﬁm?
oy 99 et ad Aaw 7 | fegT f&9°  ggfegas:

- Joomla - DotNetNuke
- WordPress - mojoPortal

- Moodle - Umbraco

- MediaWiki - Mambo

- Atutor - PHP-Nuke

féead e X (Internet forum)

féega e @9 €7 »ay I fa & MrasTes S9ATEle 3 9997 dd¢ I& HE 89 HAAT(HERT)
T gu ST MUt IBa 3 qoe I5 I 333 San © feu feg ger a:

e Users -fAgaT yms AT dH'e UAe dder J |

e Moderators -fAg3T Igrde daeT I (UAe JaeT J AT § F (threads) & e 8T I) |
e Administrator ~fAT3T 891 & H&H d9eT J |



&oH € 2T gag fAgx HAAT § greT J ©R§ Une (POST) fagr Afer 7| @ag Uit
Uret & 9% AdeT J A 5T & g € AaeT J | fon 575 9 €3 i =utir 3w Uer
g€ J | g% HAYY oM feg 75

. phpBB - Phorum
-vBulletin -vBulletin
- PHPWiIind - ASPNetForum

&< : IHT §8T9T M3 /AT S9H € &% EeIdes YT UdHA § 89 Aaw J | fene &t fapmer
fiye T3 I g aA I9 |

ut gyt (PHP)

Wtarg.dt (PHP) A gretue Sane YA Ae fenmua 39 3 =93t Ae @8t Gus Aon Aafauféar

BJed I | UbaA gt (PHP) Fa=g-AEls Aafouféar Sqrew &t 3g7 It femmer yfifa 9 ug
fevwww@wgﬁeaﬁwwmmﬁﬂﬁemw@ﬁm

— Av

WA gW (PHP) 33 € s & 9 UA § ¥ I'8wd d& gre 3 Ufg®T 29 Ad=d 5'% YA H
aﬂwwa(ﬁ@ﬁ&vwmﬁs%&mmﬁml

Ut arg.ut (PHP) €t 293" 996 &t IHt feg a3 fsy Aae o ¢
o FfedfHa ST deT & g8 |

o 3T § fedaT JI&T (M) |

o IAH & FAST M3 YU JI5"|

o 3TCTHN {9 ST § HHS JI&T, IBIC AT HUT JI&T|

Het WA fag. A% (MysQL)
HET WR.fI8. W% (MySQL) fea Gus AgH RDBMS J %3 ¥ Musidnst € f&9 sTean
¥ Bt g 3 YfHu 7 | iret iiA.fa@ s (MySQL) € &3 feu afeu=t Ay 75 =

o IIH UBZETIH(Cross Platform) (feg 3, feaam nife @ et fHser )|

o f&a 3 fprmer =t (Multiple Languages)

o forr fS9 Je o aet 9 9T SaHsd Hge 75 |

o ¥fAz 3faz (ACID compliance) 3 9 a€t g% fer ffg Anis |

&2 : IAT ufa®T Aeerden fAe’ fa Select, Create Wfe € @93 I9d STCTHH Alecamd I oM
FI&T fAY 9o T | =39 RDBMS ATecamd ffa fadhHT AdeHeH € €93 ade I&
fAe’ fa HelgAee SQL ma=d, Het AA.fa@ Wm® (MySQL) mfe | Aag It fam =t
RDBMS € &% HA.fa8 & (SQL) 3 IH d9& 79 A'ee J 3T IHI A'€ Ao o fa Hret
ARfIEAHS (MySQL) 3 I F3&T HJgdr fed faar It J |




Wt gt (PHP) w3 vet A fa@ w's (MysSQL) & feawe s 9T
(Installing PHP & MySQL)

fegst T MUBIIHST 3 I JI6 BT TG J67 o3 & fearne® J9s € Aga3 J

(©) 29 Aag=q fA= fa miu™s (Apache) AT fEedsa < feae™anHs HI=J (11S-Internet Information
Service) SgHI=T |

(o) Utmg. At (PHP) 5.4 (A7 §ug &7 =9d)

(¥) 3¢EH HI=d fA= fa Het AA.fa@ & (MysSQL), Hetgnee #A.fa@ H® (SQL)
AI=d Mrfe | (Add AT 3e9H TBT < ¥ MuSlans & fewfes aoar g9« 9) |
fa@fa §ug € Areecany § fenes 3 aafeae dasT yafas 7, fen set At feng mirs

ke

I 5% qI& € BT LU (WAMP) Areeand § 378553 dd AdE J |

U (WAMP)

U A7 “Windows Apacha MySQL PHP” €w
AEcand Aed SdH<l=d =& fder g fam e fev

Apachsa 2.4.1

WUt (Apache), Het Wi.fa@ s (MySQL), 3

WA (PHP) & e fifars ae fiog Shpmrarer 0o A

T w3 welgaree (45 @ f¥g feo wgg evhr 3dta AR

5T IBET T | QST q96T | W J9°T Ra-fe T MyAdmin 204

FUsT & s ads & &g fmer avr Sgrer §  SaiBuddy 1.3.3

W3 Y ITSET HI9I & Aged gt 71y Kbebug 2.2.3 :

A S

(WAMP) € 5% fen & feq =9 € &9 7t A9 Uaw
& feane s 95T It MATs T ATeT I |

&¢ : Ieifa feg Bustanst fagt U (WAMP) 3° feare™s a3t A7 Aaett g |, fem
wfgr & 9 fammerag gerfes™ U (WAMP)ET wufas g | fa@fa fegst &t
IIATHSIT §I3 91 UGS M3 MA'S 7 | Biatan mufad dfufedt € i U (LAMP)
(Linux Apacha MySQL PHP) €t =33 a3t At |

U § 58585 W3 ffAe® d9sT (Downloading and Installing WAMP)
1 U (WAMP) (Wampserver2.4-x86.exe) & Jof €3 ae féa € 3 s8a85 99 ;

http://sourceforge.net/projects/wampserver/files/wampServer%202/\Nampserver%202.4/




Setup - WampSenver 2 - 0

®

Setup Wizard

n| ' Welcome to the WampServer 2

S i Wampssrver 2,400 YoLF computer.
WampServer AN
[tis recommended trat you dose al other applhations before
Powered by EErIRA.
Alter Way (
Chids Mext to combnue, ar Cance! to ext setup.,
The French

Open Source
Sservice Provider
hitp:fisww. alterway.

WanpSeryver 2.4

Apache D 1404
MySQL : 5.6.12
PHP E.4.1&
PHPMyAdNIn = 4. 8.8
S5qlEuddy 1.3.3
ADebug 1.2.3

LMewt: 1| cance

2. 8583 BT I AT M3 Wampserver2.4-x86.exe 3 € 9 AfSF a9 | Welcome to
the WampServer 2 Setup Wizard &#d W™8TT J (A< 2H) |

o Setup - WampServer 2 e

Licensa Agreement @
</

Piease read the following impertant information before continuing,

Fiease read the fdloning License Agreement. You must accept the terms of this
agreement befare continuing with the rstalation.

>

= 1 ampServer

by
Craator : Riomain Bourdon
Maintainer ( Uporade Readmap @ Herve Lederc - herve ledercBalterway. fr

EHU GEMERAL PUBLIC LICEMSE
Version 2, June 1931

<

Copyright {C] 1989, 1991 Fres Software Fourdation, Inc.

1T accept the agreement
[#)1 do not accept the agreement

<Badk | hests Canes



3. Next 3 Jf8a &3 | Licence Agreements Ao feuret fder I (In<ta &7 J) |

4. 1 Accept the agreement & fA® ae a3 %3 Next 3 S a |

w Setup - Wampserver 2 =

Select Destination Location
Wiherz shiould WampServer 2 be instaled?

l Setup will Fetal WampServer 2 into the following folder .

Ta condinue, dick Mext. IF you would like to sclect a different folder, cidk Browse.
:tvanip

| | Eowse...

&t least 385 .4 ME of fres didk spacs = requirsd.

<gak | MNet> || Cancel

5. fagst i€ fe®e Sans T €7 397 afas fe& Mz Next S afSaT a1

) Setup - WampServer 2 = iR
Select Additional Tasks @
Wrich additional tagks should be performed? ' '
Select the additional t3eka you weould ke Setup to perform whie ingtalling WampServer
2, then chick Next.
Additeral icans:

[ create a Beskiopicon

< fiack i| Bkt = cancel |



6. Hdede & MTF g6 € BT Create a Quick Launch icon 3 Create a Desktop Icon
¥5" & 9 (f&) a3 | Next 3 IfST a9 |
R i |

o Setup - WampServer 2

Ready to Install n
il

Setupis now ready to begin instaliog WampServer 2 on your computer,

Jick Inztall to continue with the installation; or dids Eack f wou wart to review or
change any setfings.

Destnation location:
C:lwamp

Additonal tashks:
Additional icons:
Create a Quidk Launch icon
Create a Degiop icon

| <Bade | Tnswml ) | cancel

7. Install 3 BT JF | ot €3 nignTa T8 fed Windows Security alert f&3 swa
W4t |

o Setup - WampServer 2 =
"4 Windows Security Alert

@ Windows Firewall has blocked some features of this app

Windows Frewdl has bocked some features of Apache HTTP Server an &l public and private

netweorks.
Mame: lApache HT TP Senvar
Publisher: Apache Software Foundation
Path: C:wamp'bin'apache\apache2 4. 4'binhttpd, ex=

Allow Apache HTTP Server to communicete on thess netwarks:
[ Frivate networks, such as my haome ar work network

[ Public networks, such as those in airports ard coffee shaps (not recommended
because these networks often bave litle or mo security)

What are the riszs of alowing an app through 2 firewsll?

Almamean !- Cancel




8. Allow access 3 AfBd &9 | PHP mail parameters 3&* &3 »igna aad WM<t I

@ Setup - WarmpServer 2 - OIS

PHF mail paramelers @

Flezse specfy the SMTP server and the address mal 1o be usad by PHP when using
the furction mail(. If you are not zure, just leave the default valuess,

SMTP:
|b|:a|hust |

Ernazil:
|rnu Eyourdomain] |

. Mext >

9 gHI fen Fams & €3 Aae T, Next 3 SfST a9 |

o Setup - WampSarver 2 - o BN

h Completing the WampServer 2
‘u' Setup Wizard

Setup has finished instaling WampServer 2 on your computer .
WHITIIJEEI"FET The application may be laundhed by selecting the irstaled
icors.,
Powered by
Click Finish to exit S=hup.
Alter Way TN T i

The French
Open Source
Service Provider
hitp:llwww.alterway. ir

Laurch Wampserver 2 now

Wampservar 1.4

apache Z.4.4
Mg 5.£.12
PHFP : 5.4.15
PHFMyAdmin @ 2.8.4
5918 dy 1.3.3
¥pebug 2.1.3

<Back | Finish



10 Finish 3 If&F a7 |
Ao

Y § SHAe JIaT (Testing WAMP)

feg faeran a3t At I fa 9 a9 fa &t <9 Ao<g At 31T && W 9 faur T B d9&

T &et Jot e gert at UseT ad :

&< : e eam 2 {9 Agg mretas &dt fHseT 3T, Start-> Programs=> start wampserver

Hdcae 3 AfBT 9 |

1. farer 23w € ff9 U (WAMP) Welds [ 3 If8T d9 (IA=I9 Ia 4, ¥9) | fex
iy feyret fder T (In<ia 28) |

Powerad by Altar Wey
¥ Localhost

L0 ) ghptyhdimin

Huick Admimn |
Start All Sepvices

e All Fervices
?‘ﬂﬁmg Put Offline

WAMPSERVER 2.

o T

2. Localhost 3 f8a a9 | ffa @9 UH J&T a3 migATg feyret e<ar ;

[t e ————— |kl - = IEN
& ¥ & bt & | B seogie Al O- %~
-
WampServer
Parmn 7.9 Verstan Mraraise
Server Configuration
Agmche Wersion = 144
PHP Marsion & 3416
Lol Extusmions g Core o bormath 3 colender R chype o date
Wereg i fiter & fip ¢ hozh e
#rjain & rcript il £ 11 e pre
W Reflechion 0 smmman o smndeed o mymqhd B inkcenizar
eap e 21 e b e dom e P00
W Fhar o SimpleiHL o e ard Wombeadar
bt e cpnchazizndlar oo ¢ mibsiring e rongsf
ey & pdo_myzal b plo_sqhie ¢ mhost et
MySOL Version © 5612
Tools
14" phginta{}]
& plhvgesyyadiis
Your Projects
Your Aliases
focatosTphpEnfal = phpmyadmin

Hag 3978 feu Ua sag mBer I 3+ fen e H3wY feu I fa 29 Ag=g yat 397 aH & fagor
T

fen € %< gHt 7879 & =t 4% AaT I M3 < ¥ Ad=d ©f IIAIHS 3T ©f YA Jd6 € HeT
g8wa € f&9 htip://localhost & e &4 |




erfest § ugfew &3aT (Publishing files)
gl fig We.dMHAS (HTML) eist & uafen gdaT fify g9 7, fer 3gt o <gun
fagt € f&g tareut (PHP) 33 A% der d § St €9 Ho=d § USfar Ji3T Arer grater
g
1. frvren 2on € ff9 WAMP 3 afsa
= . o Y] = WA = D“
ad, www directory & fR@de ad |
BIHS 7 | fon Saws @ €3 Ae ¢ Favorites Mame
WWW%W 4l Downle
Wﬁw@mwmgm 5] Recent
THA sttt Attt a5 | o
m(ﬁp): g% I o0 Ao I5 fAe [ Do "
for LAMP, EasyPHP »fe | got »i@dar- | " E=
WEIT MU (Apacha), Ut .Ut (PHP), '
HEt MAfa@ H® (MySQL), & 38553 a9 Aae § M3 < gAele € feg &3t aretmt
JeTfe3t € MgH9 fen § fesHe™® d9 Aawe J |
®Y : ¥9F UH (WordPress) § fesre™® a9 m3 fen &7 oW &4 (Lab : Install and
work with WordPress)

1. http:// wordpress.org/ v ST =93 W Udw § 38583 a9 (Gus Aan w3 f&3)|
i ulirs a'ﬁ:@zagi%mem?fevfmmaﬂeam

2. 94 A a3t efes § 8%39 C:A\WAMP\WWW\WORDPRESS € f&g Wan¢ae (Extract)
ol

HIS=YTS (Important) : WIACARS YH H € STEM, eTfest =95 U (WordPress) %39 €

EIEfBrFrG'&d I BT Mafy T HaeHt 95 | §€U9s € SEt : TBST € AeIATd IS

fem 33t C:\WAMP\WWW\WORDPRESS\ &#@3 #g< & g fem 3gf
C:\WAMP\WWW\WORDPRESS\WORDPRESS &g *edI |

3. 397 WORDPRESS ¥ &9 Aude 378 € Aga3 J |
(€) WAMP mretas 3 afda 3 Mg PHPMYADMIN 3 af8d &9 |
(%) Databases 3 & 9 |
(€) Create Database € ff9 ™ & 2ty g9 | §€9da & &et, WORDPRESSDB 2Tety
9 |
() Create 3 IfBF dd |

4. 299G & ¥S W3 http://localhost/wordpress/wordpress/ 2Ted && M3 Enter § €98 |
fg 27 Uy foymet o2gr (IA=T &7 J) |

This Folder is empty.




o - cIEN

,' WordPress « Error I '|' )

L + ] Search or enter pddres > | E = Gaogle ~ "“‘ E 3 % =
Thers doesn't seem 1o be 3 wp-config. php file. | nesd this before we can get o
staned.

Heed mare help? We gol iL

ou can create a wp-canflg. php file through a web inberface, but this doesn't
work Tor all senver selups. The safest way is 1o manually create the e,

Create & Configuration Fiie

5. Create a configuration file 925 3 af8a a9 | fea 27 UH feyret €= (In<ta J&*
I

et = - o HIEl|

T WerdPress  Setup Configuiation File [_:-_;

'f- @ localhastiwordpress/wordpress/wp-admi T 77 O | Foogie 2 % B- 'ﬁ b

-

.WORDPRESS

Welcome 1o WordPress, Before getting staned, we need some Information on e
dalabase. You will need to know the followng ilems before proceeding

6. fern Us € »ile 39 A< BTt JoF 2% § Add® dd M3 Let’s Go 925 3 AfBF &3 |
fea <9 uw feyret E<9r (3A=te It J)|

losiisiicuicn] - oS

J i WordPrass  Serup Coefiguration File +

é ._ 1&.- locdhestiveerdpressivwerdpressvgp-admir 77 [l i m" Groogls o -ﬁ n - @ -
L
Database Hame wordpress The name of the
databsase vou
want to nun We
in.
User Mame LSEMname Your MySOL
UsErmame
Passweord assword ...and your
p My
password.
localhost You should be
i able 1o get this hal




(8) Database Name € f<¥ “WORDPRESSDB” & 21U & |

() User Name & &9 “root” & efeu a4 |

(¥) Password ¥ fS9 uH=9s & ey a9 (Had de! YRS &d1 4 3T fen § sl &3
fe§ )i

(1) fer Ue € »iifle 39 7' &eT 97 % § AAd® d9 M3 Submit 3 IfBT 9 | fEa =T
U feuret €<qr (3A<19 Jat J)|

[ Feeo~ | - o

¢ 'MordPress « Setup Configuration File +

'1"_*':"»-'-:-calhosx~.e-||-.. <Swardpressan-admir 77 2 B-cp: Pl & B- & -

@WORDPRESS

All right, sparky! You've made i through this part of the installation. WordPress can
now communicate with your database. If you are ready, time now to..

Run the insfall

o

(T) Run the Install 925 ‘3 Jf& a9 | fFa 29 Uw foyret @29 (Inste Iat T) |

[ Fireron - o
]._ | WiordPress » installation | +-
= @ bcnthost sardpeesssordprmss g sdii = | E- PR O~ §i-

Information neaded

Flease prowide the following mfonmation . Don't warmy. you ¢ an always change these
scitings later,

Site Title

Username adrmin

Usemames can have enly alphanumenc charachers, spaces.
nderscores, hyphens, pareds and e &8 symbol

Password, twice
&, passesnid Wil be
Binmalicaly I_S-tl‘!trlltﬂ o

ik i strength indicaitor

-

(@) Site Title € f&9 few &1 @ s ety a9, @vg9s © € YOURNAME_BLOG
28I 94|

(") Username € fe9 & 2feu dq9 |

(a1) Password, ¢are g7aF € &9 € =<t U=ds § efeu aq |



e = - = IEl
| | WordPress « Installation + |
+ & lacalhost' wordpress wordgpressfop-adeamir oy m' Goagie A K E- EE I™
[T shoedcmmmiiad b 1 o
O T woU ede Thie plank Kedium

Hnt The pessword shoukd b= ol mast s=ven characisrs ong. To maks
¥ abrongsr, usd upper and g er C58e alters, nUmbers and aymens
e " FERCE]

Your E-mail
Dipuble-check your smail address before conbnuing

Privacy [+ mnows searcn engines o mder mis st

Instsl Word P resa

(ur) Your E-mail ¥ fenmuereisnzan | Com
2 élu aa- I _':EWOMPILE-InHaJhtion IL

. 1: & locahort naidpréss wordiess wpsikiin T @ B- g £ f B & - [
(¥) Allow search engines to index this site & 2

mee o (féa 7€) a9 |

(9) Install WordPress 925 ‘F IfSa d4 |

7%%@@@%%%% Success!
feyret fder T

8. fem feg g dv ad|

BT § MAAT FI&T (Accessing the blog)

1. 29 g8wa § §& W3 hitp:/localhost/wordpress/wordpress 2Tfey ad w3 Enter § UH
J9 | ITST IBTST Aoy § ATEaT (IALT IaT )|

@WORDPRESS

WardPrEss Nas been instaled. Were you expecting Mofe sieps? Samy 10
disappoint

| E_— - |
[ may Fist Blog ac an adming [luct anotre._ | & |
| = lacalhost e presse ol ressy - - = | | - Geost= A2l & Em- e -

Manu ~ Q

Hello world!

A gust 7, 20 = UReTtoge e

Ye'elcoame to WordPres<. This i your first post. EQitT oy delete i, then SCat bikog-
zing!

-



2. g€ BAIEs g9 M3 99 fafrer fiue &et fen 9891 ‘'3 IH ad |
®Y : PHPBB & fesHe™ a3 W3 fen 3 W dq (Install and work with PHPBB)

1. https://www.phpbb.com/ € f&9* PHPBB Uaed § 38883 a9 | WU dfuged € %39
v fSo feneets AT ad |

2. fen AT TE® & €%39 C:\WAMP\WWW\PHPBB € f&g Wan¢de a4 |

3. 3976 PHPBB € &€l W& dT 37¢T8H Henfy € Aga3 J |
(8) WAMP netds 3 Ifda g8 3 PHPMYADMIN ‘3 af8d a9 |
() Databases ‘3 I T |
() Create Database ¢aHe g9 € f&9 &™ & ey a9 | §eggs € e, PHPBBDB |
() Create ‘3 B 4 |

4 g gEHT & §F w3 hitp://localhost/phpBB/phpBB3/install 2Ty & M3 Enter § €9C |
fea &7 g8wa feuret €=ar (In<s 24) |

_ =
Intraduction [
i— o localhost/ phpBRY phpBE3sinstall E- oo ,J:" ‘ﬁ" n"' -‘]',I_.'i w
EHiEY Installation
Galect languag=s | Aritish English ...,._f-
OWERWIEN IHaTALL CORVERT
= Introduoction Intro ductiﬂn

:" = VWielcame bo pinpBe3
5. Install 9 & fABae a9 |
6.9 Ud € AF 3 J&T AfE3 Processed to Next step ge¢& ‘3 If8F a9 |

7. Installation Compatibility 7% 27 UH feyret féer 7, 9 UA © A9 3 JoF A Bt
ASd® Jd M3 Start Install §e& ‘I IfST a9 | T 27 uw feuret fder T (IA<to =) |



| Database setings | = i
" w0 locathost/phpEEsphoBBIsnctalldindex ph W C"':m‘ Google 2 & K- @ 2
tariens

ase sattings
lstratar: datails

-

Database type:

ratabase server hostname or

| MySOL with MyS0LI Extansian w

Lttt file DS
| REn stands for D3t Soures Nama
el sethings and lavant anly far Q580
| databaze instails. On PestgreSQL, ase looaiiost
to- connect i the lecal server vis
LMY dormain socket and 127.0.0.1 o
L=ge connect e TOP: For S04 he -anbar
the fenl path lo your catabase file
Database server port:
Lemve this Bank vmle=ss ywou know bhe
sarver operates an A aon-sftandard
oot
ODatabaze nanme:
Databhase usorname: i
Databhase pacsward:
£
£ b}

(8) Database Name: & f&9 PHPBBDB 27fey a4 |

() Database username: @ f@9 “root” ey a4 |

(€) 9 UA ¥ §eH 3 Processed to next step ¢ ‘T IfSF aq | Database connection &
&% 29 Ud feyret fder 3 (IRt 3ot 3) |

P

] .| Database settings g

- o IEl|

iy :E' Gogle L2 % B~ @"
; A

Installation

f‘ ¥ localhost/phpB B/ phpEB3Anstatlindexph

| NSTALL | CONVERT

o Intdueton

o R arTrends

» Database setlings
Admimiatrator detais

Database connection

Tact connackan: Successful conmectian

Configuration file i -
| Proceed to next step |

Bdvancad satings

Create databas=
ables

Final sapa

(W) Proceed to next step §¢& ‘T afda a4 | Administrator configuration 7% 8 UH
feuret féer § (IA<te It 9) |




E'_.,. T — “
i_i dminisrator details +
&= @ localhost phoB2y php B E nnstall dnde p c Broege 2l & B &~

i Admintrator configuration

TIENLS

Default board langoage: Britich English  w

preian Administrator usernsme:

Hegsm fnter o psemame bebwesn 3

0 28 charactars i femsth,

HULA Administrator password:

i Pizate snter & password bebve=g,
S9045T

wi 2T charmoters in lenghh,

Confirm administrator password:
Contact e-mail address:

Confirm contact e-mail:

Proceed to next step

() WBHBAS T TrAdoH : € &9 »rusT 370 2ely ad |
() MBHAIAS ST UTHSTS: M3 T6EIH WSHEIAC ed YRS 183 © &9 um=ds
& T J3 |
() Contact e-mail address: "3 confirm contact e-mail: €% € ffg e--HBE W3IA &
TEY 99 |
(3T) Proceed to next step 52& ‘T IfFF 9 |
(ur) Administrator details 3% =¥ Ua feyret e T, Proceed to next step 5¢& ‘3 afs o
Eoll
() fea =7 UA ©F unet feyret féet T, Proceed to next step 52 ‘I S8 a9 |

(9) EF-H® Aféar M3 Ae=d T.Ma.M® ( URL) Aféar € 5% 29 uw feuret féer T (fan
<t Aféar & 39€1® 57 J3) | Proceed to next step 9e& ‘3 IS a9 |

3¢ : O ®HE € fS9 99 AT EIT HA=T T |

(8) Udet 99& ‘T 29 U fouret fder T, Proceed to next step 9e& ‘3 S8 &9 |

(1) Final Stage ‘3 29 Uw fouret fder  (In<ta 24) |



(Prers = - o IEN|
L Firalstage |-|-
) O babersphpSBippbisimmlinden 3 v C I s P [k IS ST

T

— v\ R i L =
Iy N 1=y .
B nstailation
SERER) |: IRETALL CONVERT
= Intrediction Congratulations!
= Raguiremaris You havs succassiully installed phpBE 30,11, Plaase procead |
» DeedbasE S A e Podliossineg GpLING
| = Adrerestrator detls -

8. < S9H IUF T93< Bet famg I I fen ff5 § dv ad |

HUE%’UH?F (Important:):

=

GdH

& MAA A ddaT (Accessing the forum)

3T7s fem “Install” €&353 & g8 & A3
C:\wamp\Wwww\phpBB\phpBB3 ‘I F& w3 “Install"emunzfema%ﬁ?am

5y

1. e‘aw@mamw http://localhost/phpbb/phpbb3 & eTfeu &3 M3 Enter & €975 |84
& fors 7% 8¢ &9 (AT 2H) |

[ yourdomain.oom « inde page | + |

phpEB yourdoma

B LAET
creating ¥ coremunites Acshart et = WOl FOFUET

1 Board index

F¥lUzar Cantral Pansl (0 new messagas] ¢ View your posts (ZIrang i Mambers- 1) La

It 1= currently YWed Aog 07, 2013 5:03 &m

La=zt wimk was: Wed Aug 0
[ Moderator Contrad Panel ]

Siew unsnowered posts = View unread posts @ View new posts = Yiew ackive tooics M

VOMIR FRET CATESDRY

Your first forum by Adimin G

Dresscrpiion of your fiest fgrom, Wed Aug 37,
am

VIHO B OHLIBE

In total thare are 2 usars online 11 1 registered; 0 hidden and ¢ guest {hasead on users-active ove
minutes)

Mast usars sver oniine was 2 on Wed Aug 07, 2023 5:03am o

& st e e ¢ B-Gese Pl A B & -




2.J< I BafEs At ffq 52 g9 <1 dfAHed I9 Aae 7, €9H € &% dH Jds & BT
JBY TE® €t €93 9 |
Ista At WAMP € 233° 5% WordPress W3 PHPBB & feare ddaT fiy ga J ,fere
wa’rgﬁﬂ'wwscmo-a mmxﬁmaﬁmawamw
f&3 9 uSrae It fa@fa feg <ar fawmer a7 uie T Faer 7| fwrergg 29 gwféar

j=fesd g9 A7 91 & He dd& € BT qeH-gd-deH Jerfe3T et Aredrdt fee 96 Hdd
IAféTT Fhig-eretr feserfegare €3 T 3t fen €t Areardt e ge&T B2 |

gH dfued 3° TuAEle § TI3ST F96T (Accessing the website from
other computers)

g< 3 IAT URL hitp:/localhost €t ¥93° 7% Bd% dfuged ‘T IH d9 39 | Add IAT €
Ffueq & fEg wETH 79 7T dfuGed © Wt W wizsw &t =93 575 gt fen SaAele §
WIRH a95 o ST aae g 37 3uT4 3N fT9 feue migHg HAH SHd M8 J |

I B3 ferudet §3ae BEI 398 | _—
Afagfact Aféar § sese €t Agaz I I gAY TR i
MU (Apache) ST AISI €T RIS AT I | & & mmez Gl oePl & DY Wi
T, WUt (Apache) 29 Ad<g & Aféar ' ' .

C: \Wamp\bln\apache\ApacheZ 4.4conf | Forbidden
§%3d ¥ 99 “httpd.conf” FESIAHE | . o
Trets fog reg detnt s | i 4

fen eets & MaA A dds BT :
1. WAMP »metas ‘T If&F a9 (fAder 29), fea Tuniy feyret <9 (3A<td 3aT J) |

Powered by Alter Way
] Localhost

B phpktyadmin
|E,| wwanw directory

'S
B Service k
E Apache mndules L4
E| Pliaz directones L§
B hitpdconf

Apache error log

B webGrind

Cuick Admiin
Start All Services
Stop All Services

VAMPSERVER 2.4

Apache access log




2. Apache=> httpd.conf & fAdde &9 (3A=TT §Ug T) | httpd.conf T&EIATHE STets
&< Uz Sane mizteq © <9 ug<t 7 (fae Iat feurfem fapur 9) |

e httpd - Notepad = 0
Eile Edit Fommat Yiow Hdp
™
# This i the main Apache HTTP server configuration file. It contains the
= configuration directives that give the sarver its instructions.
# See <URL:http:/fhttod.apache.org/docs/Z.4/ = for detailed information.
# In particular, sco
4 wURL:billp: ffhilpdapache mgfdocs/ 2 4fmodyfdirec Uves hbnl >
# for a discussion of each configuration directive.
- o
gl

3.3t && & <Directory”c:/wamp/www”> FaHS 3 AddS dd (IR 24),
niilg & fI9 Aféar § &< a9 (IA<ta 20) |

III
hile Edit Format View Help

# DuvumenlRoul: The dreclury o
T documeonts. By default, all requ
= symhnlic links and aliases may
=

Documenthoot "cifwamp/wwe”
cMiresc:iony "efwampyfwaoe™ =

£ omilrveo Mo Tag - dos
Order Deny, Allow
Deny from all
Allow from 127.0.0.1
Adlow from ::1
Alerww Mroaen JescAlbioesd
</ Directory >

= Possible values for the Optic
# or any combination of:

4. 7igg AT fonrs Sfemir g7 3T &< a3 I3 “ Deny from all” 7 T | fed & nirfaprr
o< ¥ wet fem &t iz “ Allow from all “ ISt I7dtet T (IR<1T I I) |

# onlnecoffiine tag - dor
) W
oW fTom .0.0.1 |
Al from -:1 Allow fr{:nm s
Allow from localhost Nllow from localhost
</Directory: o Mirectorny =

5. 513 IE gEF § MUBTE I96 BT ITS < F AIT § dHCTIC J9 € Age3 I |
WAMP Hretas srsrﬁwaa' fos Tty feyret e=ar|



Pumare ead by Aller Vilay
] Localhost

e ] phpbyAdimin

ﬁ Werzion 13

[ ] apacne
B Apache modules  #] F o Foime Sevie 5
[ afins direcrories p| B Stop Senvice

[E] ntepetccee
[E] Apache emorlog »  Tect Port 80

[£] Apache access log [C] Install Service
']ﬁ' Rernowve Senace

Apache-> Service> Restart Service & A& 'de a9 |gE MTUS 3e=dd © f<g gn dfuGeq

& €3 few Hfufeq & wret it W33 W A dfued € s as Fuee Sve ot AT T |

fer wiformr & &9 AT 9891 AT 90 & Aoy g9 fifedT I, g It g&aI/@a AT 2
NSRS & feeade € f[S9 378583 w3 fene s 995 Bet Ifin J9 Aae J | S IAEle &
FEEHT II5 M3 fEHe™S I35 € BT A9UI < IHEIC ©f ASddl & I BT |

Had gAt 2F IAFETT Y=esa € 7% AEls-mU Jae 7 3T fere A UR My 39 3 WA
FE-2re =far It fee T8e I& | fen &bt gerfest &t 29 Arfee € &9 fiseant |
Hdd Agd3 9= 3T IS AUt B< |




AAG 25: 9 U M3 <9 MUSBIaHEG € e fea (BASIC

OF WEB PAGE AND WEB APPLICATIONS DEVELOPMENT)

mfgna & €7 (Lesson Objectives):

fen nifgmm € »ig &9 gt feu 995 € Gar T A<ar ;
» ¥ Un ¥ fed™ (Web Page Development) € €7 & mizs € |
o Y WUBIIHS fea™ (Web Application Development.) € 6€7 § AHSE € |
o NET yB2emaN &t gfanme § age €|

AY9U3 A=avdtr (Relevant Knowledge)

<9 Ud et fea™ (Web Page Development)

¥ Ud fassune Gt uat e geer faet fagT uat @ <9 awrfee-Arfee Saasat <f
T93 3t AEt I fa=’ fa HTML, CSS, JavaScript »rfe | 29 Ag<g gvd fAagt @ g 4=t <F
Aafen fe3t Aiet I €97 & a@Tfee ety 3 29 §8w9 fA= fa Het®T eetgean (Mozilla

Firefox), meﬂmfszmnmma(%crosoft Internet Explorer) e @ar YR A AI3T
AT JI

fas fa At Aee T fa Me.dHHAE (HTML) € <93° UF © &9 327 § gone dd&
@éﬁwgmmamwﬁwﬁalwmw@m%ﬁ%%
(HTML)WKWWUBT&UWHHWT@H@?W’@WET@?W
Walﬁmm(m)?mrwa%ﬁr%% (CSS) &t =33 &€n
CIAE § MBIT AI& BT ST AfEt I | ALAAAH (CSS) € 293 39a3T § WS 3 X
mammeaﬁaﬂs’rwﬁaﬁm gdce Nge derd | feg ffq =ubqr 3dtar fder
U?FWWUWWWW%&WWKWW%I fene o
gﬁmméwmmwmﬁmmgmmm
w3 M3 gnd feeaniacifeet § fede® J9s € &t dist Aret |

29 nustans fsEduie (Web application development)

T MUBans & g8 et 3umd IDE fAa=' fa Microsoft Visual Studio AT Microsoft Visual
Web Developer 2010 Express (Free) € #ig93 J | Ug AT AUGS SaAe WSled €f <93 d9
Aaw J fA= fa 32Uz | IDE €1 293" Wie I@3tt (dd) M3 It &% < ¥ f3=suie © Bet
i3t 7t I 1 29 Mustans fsesune 88T unAt & faur Aier I # fa ne=q Afes casaAT
fa=’ fa ASP, ASP.NET, PHP »ife & &% f3nwg a3 A€ & |

Y UAT§ ST AIST € &S YA A 3T AT I M3 S31rt § marst arg=ret (rendering) €
ge"}éﬁ\ara'r@?rg'g feg g+ fagr Arer T (3fdar @’HW?{WWUW%—& =g
ﬁm%wamwaﬁﬁﬁwwmmrawfeﬁaéﬁ
aj@?ro' & f&g few@er §1

Ha 3 : 29 f3esude - a&Tee Afes M3 @9 WUSTaHs - Ad=d Afes |




IBTfae-Ad=d H'S& (Client-Server Model)

aBTTEc-AIed '35 B1 fanedtfa@fes wasw & faur ater T fan &7 &30 few@e gt
dH € ga™ (83F) & AT3T dI3T 7ier I 1 §EU9s € et AT & e fsnnﬂ??é’%vﬂ@‘
szérf?a?waa@@?a?@?aﬁwe’rfeaa?&m

1. 99 29 §gHd & ¥%eT I M3 URL .

WWerCtCCO|?>‘2TE'1'LraE|€TU'I8T@?|H - . 2
(F®Tee) 29 AI=a § T&3T (request) a =
qul

2. Ag=d §&3T (request & YU daeT I M3 fan <t Ao=d Arfes Adfaue & YR A ddeT J |
3. A9<9 ¥'8wd § &3+ IHeT I |
Y g8w9 »ASt Ira=TEl eYeT I M3 T ¥ §8w9 ¥ <9 fonse few@er 91

aBTEle-ATEls/ Ag<a-AEls Afquféar (Client-side/Server-site Scripting)

g MUSTaRS € &9 =93t Are =38! Afque a@fee Arets Afque A A9 ATEls Afque
J Aat T | IBTfEe HTE:I_a’a'&"'fE?EHT@ﬂHEF eI IEEBI AT AT IMI AS UA &
wﬁwwaw@?fwamaﬁi@ﬁ(maﬁ@ﬁ)gmwﬁh@?aﬂ?
Aer I | IF ATee J fa, WWWWWWUH%WE
AT § Ui g8 &9 3ust Hee Joet 9|

AI<Sd €9 Urd & Ud TUF IAS 3 e, a@Tfee Aelg Afquféar o8we € <9
wm?ﬂﬁ@?aﬁgwwaaamaaﬁzrﬂeﬁw mﬂm&m@ﬂaﬁwwa
ﬂ@ﬁwameaﬁ@ﬁ%myuﬁweﬁ—wwwwwﬁh@?
g Arer I | feg & a9aT grdter I fx aufée Aets Afgfuféar udt 397 Hoeg I faagg
&4t I M3 AeS9-ATfes SAERHA! € T93° IH (¥531/Request) & YR H dd& € et a3t
At T

FBee Afes AfquféaT et M S93 ST UA S T TAd eMa gd IR ST I T Jds ©
wet ST At T | gran & g ITeT 999 Wit A ﬁﬁwmamz@aﬁw
AT HUSTYTS 18T & We dueT §& Hie T 7 99 =% dtuw € &g 2o Tus a9 foe
U?mmawmwmf@ﬁmw%wwwwéw
Aer I, yg €0 3t Mustans § I3t (slow) a9 feéer I | a@fée Arels Afquet fmer
fein=g m3 3w Iett g5 fa@fa v Aese M3 a&fee W3 Aoeq fega feegd ¢ ¢fea
93 fog99 sat Faet I5 |

fegm® U feeae & g=ge et (Bewas € &8, WEH & e 3 forw § sfedtast
Heuaa'cs‘r) ‘aT@?Rffes' feg faprer fede fawfer, ”“wﬁﬂmamw
SaHe & AFIS JdaT, WFW%E@WWWW@? E’KE’T&'&"‘@?FITE:E’HWET
ot Aggg gt T

TH UH 3¢EH € &9 e M8de d95 € B, Baies Ud § HIfem3 dds &el,
MEBTEIS YAS 978 € BEI Ad=d s Afquféar € 93" d9s & Aga3 J |




JTElUgeaAe ediHed Yead (Hypertext Transfer Protocol (HTTP))

YA (HTTP) ffq Mustans (éds I # aufeec § Ad=d € 3'% I1% dd& ©f
feama3g fder 7 | A e auTfie dfufed €9 Ad=d € &% Ji% (HY'9) & ©f aAF JdeT
J IS AI=I €3 %ﬁﬁtﬁ(HTTP)W(request)EWEﬁ feg fere S ¥ g8we
o =95 gger T I WA AW (HTTP) Fa3t (request) €T dee feg fagufag ager T fa
IBfEe AISd 3 ot o Ja=Tg ST Iger J | A ffq 29 UH & &l 9631 13t Afet 7 37
8¢ g78%39 Jic (GET) HES € 93 dde” J M3 fA¢ HI=d I 5'¢" YH H Id& SeT T
H’E"’EI'B"'f‘EUUFI?(POST HEs @t 293 JdeT J |

fegz (event) ffx &2teelans I fAgst fam av @ gy feg Truget T, fAas fa Aee &
fST gev=, gad 7€ HEW BT gdeT AT STgHe & TUe AN a U H JdaT, A A
WZH@B‘HT@WHEWUW)-F@'H@%H (mouseover) & I & set affer 71 fede
JI3%49 (event handler) Wwaﬁmﬁnﬁu&mmeﬁ%wa ,7HEe
mmwaﬂ?mﬁ?&e—amm

feg'e 3% (event model) 29 Mustans © &9 & Aeeena middteayd T # feg
faaufas qde-ahfse?aﬁ?a@@a‘rwemawaw@?rafswmw
Ui €7 €3 fa= 2fdam (trigger) a9aT I feg fagurfas ager 7 fa fEa feee o= fa=
ySifaferr gaat gdiet I A7 feee e T8 uw fae feee Aus § AOAgTed dosT
gdter 71 feg &2 a9 fa a@fée Aels 3 feee § €ug Garfomr Ater T (raised) M3
A9=d Arfes €3 feee & Agf®mT (handled) AreT 7|

gatea M3 AHS (Cookies and Sessions)

gata 2 9 879 © 9 AT Iad It I8t AredTdT (37eT) gt I | A IHT L IAEle fae
fa ebay.com & €y I 3T 3AT ” Items you viewed ” AIHS & J& MTelerdt & e digrder &
T I9 fa g9 Wie A7 g¥ foat e & fog oae e gs (8 39 fa ae gt
dfuBed & Hea8s A diHege =t g9 fée J); ffa =9 Aele fas fa EBAY feg fagt
Aegrdt & fae foaras aoa Juet I Aefa fE'FI'cB'dH'd'U"TLrIHd J9 39 <YT I& ¢ feg muas
hﬁar&zr!;re’rgﬁﬁw@mekv T €7 2ane eetnt & f¥g AET gad Jfew
Arer T fag & gatd (Cookles)fatlTFl"?TErl

7T AT I¥ AN gE §F el § §%E J 3T ¥ Ao=d MYt (HTTP) I39
THIT 2 §EHT & UH Aredrdt IreT J | fene gy ¥4 29 8w g% AredTar TUH
gaeT I 7 fo 2ae et @ f¥T Ao o«ls|zre°ruelzr|f82rf8nar$3nwﬁr3wzr1%r
gt fagst mreter & = At €9 yuz 1St ATt § Mz GFg ¥ g8we © <9
feufemr aer I

gt & St #ignAutedt i3t At mit § Aaer J | feg €€ erfeeie ger 9 Ae At fam yw
A 3 e feg ot 9de fa 29 98+3 fen Areadt § Ag® o 3¥ |

»H 39 3 FdIT ©f =93 ferlads &et i3t Aet d fAe fa 87 29 U7 § we duer
fags gt Sfer T, wirgtedt 7 IAT St g5, a3t 7 AT o wirfe € &9 gabut
I |



quﬂequQ'ﬁHoé‘ﬂSH Jd& BT I ATTE3T 99& @I SISt AT AdEt J A fa @9 Ad<g
h*l@'é*‘éra'f@?rc’g I%tlo('d d)d'é‘do( CdIGO( U«l?o(del U|b‘€'ddd) ggﬁm%lﬂldd S"C'HH
fé—&u&m:twsonrrsﬂarr?iwzr | few a7 € &9 29 Ad=d o1 € <93 29 TS
T BE MI wITEPAT 50 MTETeHT AT fugEtiT 50 mreterT Tt fere fer@e & ®et g9 Faer
J | feg fer 91® 3 fagga qaer § fa gaia © &9 faust dHa AT I &7 fa oda mireten &
Hg 3 few@er J|
&< 99 fa gata & fam y A € Bgt <t AT Ji3T 77 AdeT J AT IU°F dfued € &9
TerfenT AT FaeT 7 | feg few ots €3 fagee ager T fa gt 7 7879 & fae aafdam
gi3T Ifewr 9| @egas € et 7ad AT MUS ¥ §8Hd § A €€ digT Ater 3 €€
qqmquoewmaﬁ?aﬁwawaﬁﬂmmeféﬁrww
Fete T Areattnt|

AHE < gate €f 397 9t I 7 fa Areddt & Aed J9d JueT 76 | s B9 eetst a5 &
fo 2°9 no=9 @ ©'F 593 t Mg A et A2 aghht At 95w feg ©9 wan T
AemTgs A ¥ TEme §ge di3T A J |

s €T eetst 95 1 fa @9 Ad=d @ €3 Acg I 7 fa 9da Sldted € &t wWdar
ATSdTdT JUEhHT IS, Ud feg Areardt yTe fefae (visit) € &t It sla gt 7 | egds @
9 AdE J |1 UT IHT §= AN BET Arfiar ade 3° AHTs yatee 3 ufgsT miretent § AnHs A
geT Ao 7 | fed fAg an € <9 AvsT €t 993" AredTdl & Ad<d §°3 AT ada € &et ai3t
At 7, W&Tﬁ%ﬁ?@?aﬂﬁﬂ’ﬁaﬂ?ﬂddd gt 7 (@€ € BTt A At
G—orw@?m?rque J)| A Al LEAEI § €3 e T 7 879 § g€ J9¢ T 3T AN
f‘a’??f?;%'aﬂaea's'a—af??wzrl

FBUsT ad fa fa=e’ fea 29 naed masTets widar arete fae fa ef$yu amae (flipkart.com)
# €1¥ (ebay.com) fAgT € 3% gamat It Sieled Ia # fq fed m wfdar d9e o5 & fa=
RI®ET J | Anat § & Suat Aefdar enmar a™me di3T Afer J 3T+ feo ga Sieleg €
AAsT & ygfes &7 J95 |

NET 3=&13t (THE .NET Strategy)
NET & HY 3513t Argeanid & Aafen € @ar se'geT J | feu Areeana fésnedt € feg
A9 3 &< 233 @ gy faet 7 fas fa -
o IBES/AI=T M3 n-cTehrad
EN ﬂ -~ . E;'?_ H @_ - é_ 8_81. wisnnl =todin (NET
JIEST (computing) & 3T | ——

Semvers
o TY-TY I TdT fIeBU T : -
a‘ré’ H‘Igzé‘;ﬂa’ Eﬁ]—g?ﬂ' E’l;‘ 1;:'3_(')_ é’ EE’T Upcrating System of Sorvors, Uesaops and Uevices
WMATE IS8T e U S ST IHH JI&T |

o TP feeayreta Mustans § faesy a9a &t wmrfamr e et fast a3 fag 3°
2IHINS WWWHWWMWWWl

.MET Building

JNET Franniewore Elock Services




29 BTU9s Y- UBeeor, faeretiig Mz Yariiar swmret € &9 arongns3T

& ATYT g9 BET gEsel J |

o feg feeaGuadifastet, mdar, Gusau3aT, Hdfor™ W3 IHIHH® 2T MUBTIHS &

y¥yu § AUde el |
NET y&eeran (The .NET Platform)
HElgAee .NET UBeeoH & 3A=Id © <9 feue »ignd Hy Ud 991 ge 96 | AF 3 Ja&T
Bmg €3 mrudféar famew der I, fan f<T fe3H € ITT UBTEIH ATHS T AW I& |
MUITEaT fAmeH € AT ' €3 A8 B A Ad=d USde ©v 98 dur I v fa @3 Yug &
Ty fas’ fa faa e/ Aa=g (Biz Talk Server),fUdd HI=d, MUBIIHS Hed, WA fa@ A&
A9=d (SQL Server) mrfe & fegm € &9 Sare =8 M § weBE 75 | fa@fa <9 Aafens
U3 It famer ¥ =93 © @9 wrE Tt I8 | 993 AdtHT ReTeT YJehdT ad=remt
At g5 fagt &t fa vez € &3 =93 J13t A7 Aaet 71 fegt Aoefim € ff9 &<
uTUde (.NET Passport) M3 &< mW&de (NET Alert) iHS 75 |
wmemmmmwmhwaﬁww &< (Visual
Studio.NET (VS.NET)) fagr #fer 9 # fa 993 3t 3+t 5% ¥ nafeny M3 Mustans §
g8 € &9 AuTfeaT q9e a5 | A . &< (VS.NET) fzrarfz??“—cfrz—a'ﬁa'emm—c’
fes=rfegare (IDE- Integrated Development Environment) § 7 fa 979 f4-2y =t &
AUde IdaT J |
. &< (NET) SoH=da f&a fa=mune ©r gfenm<t 9T 7 fan fS9 Mt s M3 (CLR) W3
IBTHT & M TIHIIT # a7 &2 Ehd™ ATt ITaT=T @0TaT SIfT AT AdET IS |

NET @dH<da & I7ar (Components of the .NET framework)
39, feg edH=ad ATfee Wrudfear fAamer & Ag 3 Gug d<t 7 | fer .NET SoH<da e
Agat famer Mustans 7 fAng fa &3 €°3 s&fonr Ater 71
1. I™E BIred I&STEMH (Common
Language Runtime (CLR)) €dH=dd €T o web rorms opikf
yfiT 371 7 | feg mraviae & Madiee
FICT T, AT T & I IIET I, MTEHAC

rnatra and XMl Clas<es

f"; N ﬂ a ﬁu o a_ . 2"’; @ {ADOLNET, SOL, X5LT, XPATH, XML_)
= 3 IE ) _-g Eﬁ = x
7, IBIt BT © 9 asItat i i S E g —
b 5
(handling exception) é— %ﬂ' (101, sfring, -net, serurty, threading, rolledions )
WW%M@M&EJUS": In Commaon Language Runtime
Time Compller (JlT) U?Tﬂ- fa’ (debug, exception, type, chedcing, LI compiler)
fecaitsite 9w a3 § duUEs a9
< BT HeT3TeT & <93 JIeT I |
At 2% g (CLR) €7 fan &t g & Aide d9er J A fene as feearlsiee Saew

(CIL-Common Intermediate Language) ¥ f&¥ y=afia a3t A7 Aot T |



2. TIHSIF §H IB™H Heﬁfsm?myw@?wmﬂmawaaﬁafﬂ?fa

RFETT HaH HH AT (XML), Afa@faet némire, o= agatans ma fere &%
ﬁwwae’rmsﬁl@rzﬂ

3. 3T (DATA) MIAH HH HF (XML) IB™H 32T HEAHE M3 MAH M H M S (XML)
WWW(XML)EWWUIf@UWWWW(XML)Wﬁm

WWWWW(XML)WWWWWW(XML)c'ﬂo(Ho IS5 & Gl
Srge@erJ|

4. 29 Aaferd , 29 9 W3 3 v {35 Y-y SI& &AM I& 7 fa 3727 (DATA)
M3 AR MHAS (XML) & ST Q Tt 75 | 29 Aafeny € <9 s AHs Jet 95
ﬁﬁmﬁh@amammmwwﬁ W(ASPNET)E’ﬁJE’%’HE:T
T =3 WY Za8aHt 29 7an (Web Forms) 7 fa 397§ 3+t 5% <9 At.g mret
GUI)MW%@?E?WT@@MI’E?WWWT&%’#HW
(GUI) MuBtarsT ge8< &9 AarfeaT qaer J |

Ayt NET (ASP.NET)

@WU’T NET feq 29 f3Buie eaH=dd J| feg 593 We dfSar € &% ITsT <9
MUBIaHE & g8 < &9 vew ader T | feg Ad=d ATele Aafauféar eaasdt T 7 fa g53t
(request) & 3% 27 U & s@< &9 Hew goe7 T | g5 e T8we I e T ufost fagt
Ut § &3 fog ufost gt fapu I €T Us s 2eid 37er & Un aov I& | fem @&t 3wt
WESITES SIS, WWWWWHEWL& &2 € 93 JId 5
Aae 7 | E.W.Lﬂ.NETWEQ%WEWFﬁWEWé%wmgw
geget 7 I fegst & 29 g9 (Web Forms) afde g5 |

fegst eont 3 YaeriHar aoe AN AT . NETWWW?;%T%BEWU R ES
AT MUt PuBTaRs € JfSar fan <t g fAgst fa as SIew I&eEH (common
language runtime (CLR)) € »i5q® = fA=’ fa fegms gffa w3 Ft FT9Y (Visual Basic and
C#)Eh—v'aaﬂa—trznﬁw;rsnmtﬁ NET &t =93° 575 geT¢ Ate 76 99 udt 39+
e §dties I 35 |

fegt umt & feaiisiee g€ & At 'S »d (NET CLR) Mag® duTfesd gmar
Futfes aigT AreT 7 | 87 3 aoe AR fea 2rehd (Just In Time (IT)) Sufess 35 & ¥
HFﬂ?ﬂ'a_a’I'e'U ge% fder J fAgs fa YAme € €3 s3er 7|

WA NET UF soH<dd B auTfee feec © oot 7 fa naed €3 75 (¥%<) aae 75
fEEm"‘c’H'afes & yoaf3 gae J |
SIH=Id UH €t Afa3t § <t gevet duer I M3 Ud YATHIT STele ATEtas (Page Processing
Life Cycle) & €9& Un & €3 fatigdes duer T 1 Aée HaA ¢ (State management) €
yfafenr & fagr Aater I fan <9 Aoeg ffa ot AT Su-<9 Ut € STt Jet ga3tt
(requests)ermuwe?wa—oﬂﬁaw-&u?zﬂ

29 UdH T ®Ee AEla® (Life cycle of a web page)

ATUTE €A AT (ASP) YaraTiHar € €93 d9€ AW, T ¥ Ud ©f faedit @€ §g I Aiet I Ae
F&fee fai UH & YTU3 995 © ST 9531 (requests) SHET T | et »ret WA few § U
FaeT T, fsne?mﬁfsﬁﬁwwﬁmwawswﬁwe@%sﬁ?amﬁ
W@zmﬁmg e Qe T 17T TS (rendering) YA T FEt T It Um R HEE

.\




(fieait) 43 T A<t I 999 ITF a8 9 feg fAd ean 75 # fa I3 fadmer 3Ter
(F@@Tee 3) & WAl Uar € fife’ (Fe=q € €°3) UhfHar € et U Jav I8 3T fea &<t
53T (New request) &t & w3 €7t URA'H gaavet AfEt I | YA fHar € et viAg U7 €3
me@ruﬁhwauma(mstback)faw#??n

gMAU (32). 5<S(ASP NET) € &% @9 Ud § g=8<T (Web page
created with ASP.NET)

gAAW & € =93 gov AN 83T fAgT sesTe Ji9T AieT 7 fareT fa siustans < mils
Tuge € <9 593 7t famrer ygre Uer 7| &8 & 29 U= & fdeait 8¢ gg et J 7e
gefee fan y Ud § Y'U3 J96 € et 63T gAeT I I EMA Ut &2 Ud € sEle Arelas
v &9 feshitmsenns, 30t 5% fst39s JdaT, Ace & fanda daa™ M3 End st
JueT, feee I3%9 a3 § IB 8T W3 I3fdar AHE T |

Initizlization 1

1. §g 3 (Initialization) : 29 eaH &t fieat € f<9 A9 3 ufodt weasT 7 Tuget 7 €9
¥ fesfee (Init) fe2e |fend €3 Ffernm AteT 9 3T A A8 a% Ud € B! festihsenns
wﬁwraﬁl%nwmmawwmémaﬂgwmamwm
UH € 3 fem-Une-8a (IsPostBack) yruget gt 7 # fa feu Aa3 qaet 7 fa Ade U
53T MA% ¥&3T (original request) I A @wg <8 fed UAEET (postback) §&3T I | 7ad
UHegd (PosBack) H9 (True) I 3T UH feastHw&elams &dt a3t Arat |

feg €v ras I fig € A dt. Yareriiar (ASP programming) M3 € AW (32) &<
GaraTiiar (ASP.NET programming) € feedra 3 W39 &t weas= Iruget 7& |
H& B IAT MUS IBTee dfuSed 3 25 ITHHT T IJ I€ 9N § Ad=d €3 Ifmm
J M= B2 fa €aT € <9 2 It (§1%sT) & g99T IAc €t Agas 7 I EMA At (32) 3
JararhaT (ASP.NET programming) »3 fem-Ure-&4 (IsPostBack) ymudet & &7 grt
WE@%Waﬁ@ﬁﬁz TTHBHT (S13BT) @7 37¢T A HaQ J | A fa & mA At
yargHar (ASP programming) € 3% 3974 25 83T €f Yl Areadt €9aT AT U=ait |

2. férewteféar ded® (Instantiating controls): »a&t 7 fefe I €9 T &F (Load)
feee fan fe9 9 eon € A 3t 9fews dedw 83 a3 AT 76 W3 8T &t =93 aist
At I | fer 3gT AT 37eT YU3 996 M3 ded® & SOHTeT € WaT g wedr 3T 7 €U Sy
Ua € €3 Ae 8gT § Tun aufee € a& gfamT Arer 3 3T 8o vy my § YRz a9
o< |

3. farefdar W3 Aéde § H&da JaaT (Restoring and Maintaining State): &fSar &
Y96 Add HgeT 9631 UHeSd J 3T ded® Yrudetit & 81 AredTdl 7% &3 Ji3T At

UFE@'WWWWB‘WWWI

4. feg'e I389 d9 § & FI&T (Running Event Handler code): ¥#d & UH &%
B3 fAe fa ges afda (ButtonClick) & UReSd (PostBacks) €M™ d¢d® AT3T
qer J|

5. 3fdar (Rendering): 33fdar 3° ufgst UA M3 AT deds © Bet fe@ Aee & e

dI3T A7ET J | UH 999 d<d® € &EI 3’39 HEs (Render method) & I d9eT J |




Av

IS AT HEANC (State Management) 2% fos &% 28 7 fa emAt. (32). 8¢
AETBAT € §g3 It HU3=TYTs Ufos § g ger J |

M AMT. (32). & € f&9 Ace H&AN'C (State management in
ASP.NET)

Aee HoTH ¢ a@Tfee ATfes W3 AI<d AElg MUt €t farest e gemsr féet J 7 fa yst
U € 375-3'% MUBIIHS MEA'd FeT & A3 Jue &g AofesT aaer I |

gefee AEle €3 32T €t AT & HoH Jds © et fef Ade, ded® Ace, gV J¢ &5
M3 FATH St wTUEST gt I |

AJ<d €1 ATEls 3 Ade & HaH dd6 € BT MUSTaHs Aee, ANa Aee, UeTel% Yyded M3
SCTEH AYTIE3T FI9IHT MTUHST e I8 |

IBTET ATEIT AST HE AN E MTURSG (Client side state management
options):

(©) feg Aee (View State): feg Aee yuget Ag fead fAd Um € ®et et ga3t ©
ﬁﬂaﬂ‘o’m(values)aﬂ—e’o«do T AZdd9d ﬁﬁtrlf?ﬂmmﬁé’r%aa‘@?aﬂé‘r
At T 79 OW e € et 83t fadt areardt neg ISt ATEt I 7 MUS wy & UAesd
gaeT J | 7€ UF & YR A dI3T Arer J 3T uw <t Afast (Hee) M3 deiw g Aefdar =
wﬁw@rma@wawﬁaweﬁwwaﬁswwaﬁ
Ied' Hiar UlHe MWSWWG@?WWW& Hiar U'ETIGH HCC

(view-state) AfFaT U featHBetRTes 3 GRS (parsed) ATt ARt T w3 Uw @ &9
yruget feseranms fanes g<t T |

() ded® Aee (Control state): fed €t =93 ded® & g9 We H3d™ ¥ I e
ATEIdT § Fed I96 Bel A3t Atel I | ded® AT YTude! 3us fan uH dedw ©f
yTyget ArESaTdt & Aed dd& at mrfarT féet I |

AJ<d ATEIS AZ<C H&AH<C (Server Side State Management)

©) MuBtaws ree (Application State): NUBIAHS Aee & <93 I89s A sdat &
Aed J9& Bt a3t Al 7 | fagst fa 83t faz seset 59t »3 fAnd 993 A9 o
WWWU%%W@WMMUWW@(R)W
HttpApplicationState I&™ & fea HeF T MUSAHS Ace HIEMT ge=get I | fan
5% € UTH IS 9% MUSTAHS AT § Aed dI3T AT AdeT J # fd Arat Mustans
< ot feyetdar gt 7|
() AF& AS< (Session State) : few €t =93 €< 13t At T A€ ¥ ATeadt 7 fan
H"'Fl'Fl'Fl?)'E'B'Eﬂ'del g, & AT a3 AreT e 7 | fen f&9 adfim va3=yes gt 9|
& FH AT (B2) &% (ASP.NET) I&™H HttpSessionState € =93 fai fins €t ¥y Areardt

éﬂ?ﬁmggﬁmﬁaﬁﬁrfm@wag|@d€l°r|e)-|¢udlge|Erl

war faghdt arghut fafa=T a9



53t 99 M (Activities)

1 gt A9 € fede § Hartele 2fdu (MakeMyTrip,) €F 293" 5% €9 96
BE MI MEBTELS T M3 SfBY ad< (ebay & flipkart) 3% ydteTdt a9 ©
2JT € 9SS d4 |

dgot fe3 o yrst € €39 feb :

1. IBee AI=ST W3S ©f fegraurar & fanmfmT a9 |

2. g% Bugast et fAg gt astfee Arets rafaufar (Client -Side Scripting et €93° &9
Ha< J |

3. feg'e I'3%9 (Event Handler) 79 3wt &t AHge J femmfipy &9 | IRCTC 70X & 995
AN TU3s 8T g3 feee € get 576 |

4. fe2e 3% (Event Model) st derd ?

5. UH BTete AEla® ASP w3 ASP.NET 3 fan 3gt m&ar 7 fen <F fenrfin a9 |

6. {35 NET féeayrety Ao=at 979 €7 w3 §9T € Hu 8w g9 St &R

7. 3T “Postback” g7 ot AN T, fer €F femfymr a9 |

8. ASP.NET ¥ f&9 3wt mee Haan e (State Management) §79° & AMSE T ?

1. fEBra'ﬁI@?‘o’u_cmT)-rEr fAgaT fq ®ar3Ta 3 IEARS &
fou@s @ st Soer T |
2. AC° 29 Ud Bt §&3T 3+t At 7 3T 89 €aT ©f <43 ddeT J, MI
n?meagﬁﬁfﬁmexﬁa-c-gmwwe-zr?fw _ EJgidt=eddder J|
3wﬁ?mm@nwwaew@ﬁaﬁﬁw@m€hvw
(HaTEfage) ) oftgT wrer &, waﬂﬁmammemmm
4.%@3#@%@?%&3§WWUH%@W@WW
(AIHfage) 3T AeT I M SYUF § Uad ¥ dfuBed 3 st Ater J |
539 U §°3 eor € <9 grd g9 99 I ¢ ?”;G”o( S35 & Bt
Afgfuféar »mi <93t Aiet T
6. Sn yfafonr & afde g fAn f<9 Ao=g UA & AredTdt § a8t a3t &
@%fﬁﬁﬁwa—wwgﬁﬂwm
7.8 AW (32)&<C (ASPNET) ARs € YW A'Eddt & Hed 96 € &et
IBTH ©f <93 ddet I 7 fa fAde Ans & f&9 dt feyret féat T
8.HttpApplicationState & fea feg fagt Aeadt I 7 fF yat mustans €
fEg saa vt T
9. LES f3® Y-y TA&BfAT I& fAgztmt NET
WEmDATAWXMLW?;@T@Wam
10.8 77 0t (82) 32 (ASPNET) @ e Areles & f&g , ,
me' HH® Jer J |
11.JIT €T ya™ &™ g |




ARs 26: fegns ¥ fs2®ud WiaAdw (VISUAL WEB

DEVELOPER EXPRESS)

mfgma & €7 (Lesson Objectives):
fer wiferm & #ig &9 3t feg a9 © Gar T A7<d1 :
o fegn® 9 f3RBUT WA A €1 S92 s B 2 ¥ UA § 928< € HdaT|
o fegns 9 fsSsus Many F &t 993 5% €9 AUStans & 78 € HaT|

Agfag Arsardt (Relevant Knowledge)

St ufgst We. 3 AT (HTML), Al WA H (CSS) W3 9 WaAyns g9 iy g9 T |
nidr Tue 3 ufost 3o feg nwg &3t Aet 7 fa ufgst fegt fefimt § va 3* gaa6 |
&< : nidl Tue 3 ufgst welgnee fegns 29 f3T8uUg 2010 Many \ § 78583 w3
fére™® a9 |

SN AV

Agdt wreardl : feg HisE® 29 faesuie M3 29 »ustans € Heat fegauar €3
aefag 7| &7 fage €9 A39 & Areardt HIEhdT gaeTet aret 7 | 99 famer Freardt &
e @3uTe It IBY TES M3 /AT MTEBTEE AT € 293 a9 |
fegms 29 fsSsus 2010 HaAy A W3S § €< (Launching
Visual Web Developer 2010 Express Edition)
feq =9 feane®Hs ydt 9 3, Jo &3 I° €91 € #gHd Yad™H § 9878 !

1. Start-> Programs=>Microsoft Web Developer 2010 Express 3 IS a9 |
&< ufgst =79 fen & 83 d95 3 3U™4 ¥ T8 Bdiar|

= Start Page - Microsofi Visusl Web Developer 2010 Express - B “
Fle | Edits w1 Debisgi - Tk Sanerne (Hiha
e e e B8 B TR SREP R ) Mot Nyl (6] O = -
al Web Developer 2010 bqress
(et Started Latest Mews
-E _—Je,”-_-.'.':._r Fleons Ntk S et il WEWS
j Cpen Profect.. | Dpen Wk S, o lok i R
LEr Frojecic
 §
(! Clons page afbar project foed o
[l Shezen paga o clartugn

131




Acfed SgATeter § g=T@<T (Creating Websites (Static))

fegns 9 fssug WaAUn €t <93 o IR S UAT § e Aae d, femn § seGe &
emmsﬂwmamﬁe &% 993 HSeT g8er 7|

1. File=> New Website..... & i@ a< &3 | New Web Site € 5% 3Tfe®Tar IaH &Ad
»eET I (IASIT IJ5T J) |

MNew Web Site ? n
Installed Templates T v ;il
S ASPNET Vish Site Yisual Basic A Tt
Viwal Bask, = b | An empty Web site
Vs L= i

@ ASPMET Emply Web Site Visual Basic
HEPNET Dynamic Data Entstr... Visual Basic

-i; ASPMET Dynamic Data Ling.. Visual Basic
e

?';H':‘ WCF Senvice Visual Basic

Web focatione | . | File System ¥ O ebertes Web d | v Browse., |

(8) 3US YaraTHar IHT & g5 ©f Aga3 I (M S gnTEle fae fa Aig.et M.
(HTML), At. WA (CSS) & g=8< &et fen € Agaxs a4t J) | fsese MBans fen
39T &3 fe6 |

() AT ITeTHH THT T  ATElE § §ST AAY 9,Ud fen € BE 39
J | fene @ fS9° ASP.NET Empty Web Site §fﬂ8—o(?aa'|

(8) AT AT IT TS WHM S (HTML) € 293" 995 &t g< Aae 7 (AT It Sarmete
f&9), wie.dtut (FTP) eAe.dtut (FTP) €f 293" &% AT It 9 Ad<d Bl <93 a9
Aae 9) A 1% fHHeH (Ba% dfuGed) € =93 9 Ade J | File System & fAdae
aawn?maﬁr@za@%é*amfwwawaamawwgfevfeﬁa
Ho=d 3 USisH &9 Faw T |

(}) MUST Ba% 993 fana safee € &5 Faws § <, Gewds € T,
C:\Websites\Web1 | OK ‘T Ifda ad | fomms feb fea st Sgnrete feyret a<ait
(3A<1T 29) |

ZIr§ Yarariiar €f Agad

o




0| Webl - Microsalt Visual Wes Devaloper 2011 Eipress - o lEN
Bl i fiew Wibite Beug Todls Wodew b |
e e [ B R e B S e [ g

Rl T
L wetbcandiy

-? Eehrbiom Eepl..

CREESEs WY Web St Progs -

1

T

2. g AT FE AR € fET 9. AU (HTML), At AHAH (CSS), A= Adfaue
(JavaScript) »rrfe grfest & ArfH® a9 Aae 7 | 9.2t MHAS (HTML) eeist § s
ad, File> New File.... & fA@ e a9 | =t mreter™ § W3 ad& et Add New Item
SESTHT I9H SHd M (AT <) |

A Mew Item - CWebisiisWeD 1, * e
Inztslled Template Sowtins Befauh Chirch Il Therelnet i)
Visusl Bass T
isual £F ﬂ HTMLPsge | @ | Visuzl Basic e Nepeol iz
L Nt A HTML page thelt can mvhade clend-
Onlire Templates 1 secde code
G e e el ek Iﬂ- Hcnipt File Wiul Basic .
ol ke o SO Clasees Vaual Basic
Al
_1ﬂ R File Vauel Bave
B svesght1aBomtrege  VaustBesic
-
"'ll Shmdight Applcation Vaual Basic
=
?; Shoeshght-enabibed WEF Ser Vsusl Backe

Harme: [ JHTMLBags, ham Blece code in t=parate file
P’ el st poige
(€) Aga® a3 M3 HTML Page & A& 'ae ad |

(») Name: & f&9 Te® @ & ¢ElY a4, 8€9da & &t default.htm | Add ‘T afga
g |

3. 2EAEIC € T AHS W E.dt WHAS (HTML) eeist § 8¢ J3 (IA=g =4) |



= Web1 - Microsoft Visual Web Developer 20710 Express - 8
Erh: Edit Yiew W:hjftl: &cbug Tools ﬂjﬂdmv ];t:lp
S @ 8B 90 - ok [ B
ikl—m"-'lLLt Transition ~ - k
default.htrn = = Solution Explorer
<IDOCTYPE himl PUBLIC ™7 u3cyoTo s (SRS ITE 3y | 5 | iG]

5 W ebsites\Web1y
a ||] defaulthnm

®OGIOT] 2

Sehtml smins="hrtp S wew w3 L org 1900 slim]
theads

ctitlerd/rities : = web.config
£ heads :
F<badys B -'-‘:J Sofution Expl... E [ratatiase Exp...

< /body Prapertics (] i X

<fhtmls DOCUMERT
L

0%~ m=al]

IDEI.IL_]‘I =] Spht H Source |1| .Han:hqr-:-und

Ready

(©) fen Sgrrele & fg og.dt. MU A (HTML), BT, "WHAH (CSS), ATe™Hafdue
I avaScnpt)gﬂeﬂawa?)ETsﬂwe?fm?m

() HEgWBt 3T TUS 996 & STl JfSaT 439 |

(%) famrfes, a3 w3 Aufee fe§ € fegag Af<T a9 ([4 fa feg Manims 29 =@
&Hd & wrET ?)|

(A1) yruget Aféar € &gt yruget f&3 (An.eh.safew (MEW) &t 399 |

4. g< femrfes f<€ ST Afew I M3 I3 dane & feande a3 (WH.Er.39fdw (MEW) &
MEATT) |

s.a@wéﬁ—%aﬁl

HElgHee fegn® 2 faesua Wanay A € &9 “mini” 29 Aded AH® dev d (fem &

mwmwa)wfﬁémgﬁﬁwammwwma

feg €€ =g3<=qar A AT fore <9 Ho=g € MuEF d< 3 ufosT It Saarfee & SrAe

Jd e T |

6. fen anfee § ¥ g8+ © ffu Ty &g, CTRL+F5 §e9Q IS v g@ra € few
foue aE =39 § 2F (FUs 29) |

W g _—-{ Port Mumber | A= “

] hitp: fflocalbost: 55972, W eb 1/ defacit.htm |

% localhost 35970 %eh] Adefauit htrn .q_i LRL |.-|:| i n' &-L: il

Website designed using Microsoft YWD 2010



7.CTRL+F5 & U'H gad IHT < gAEle § 98'8€ 7 37§99 ¥ <9 fsesuie Aa=q
(Development Server) 9%eT J M3 frre zawr g fauret fder I (Irete 21|

fAmer 2 @ fS9 ASPNET fSS®Ude Ad=d Wetds 3 € 9 Jf8d dd, IA<IT fe9
feure »igng fea fez feyret @<t (In<ta 29) |

& ASP.NET Development Server - Port 35972 ﬂ
ASP_NET Development Server %
Runs ASF NET Applicasions locally
Root LIRL:
Fort: JE:EEITE
Vitudl Path [zt
Physical Path; o Webstes\Web 1\
ASP MET Wersion: la.0 2031917929

Stop

8. Port: € f&9'Ude 99 M3 Root URL: ¥ f&9°URL & &< d9 |15t feg €6 fHee g&<
&9t 95 7 29 879 € 9 M3d W g9 fI9 feuret fée g5 2

9. f8=®UHe <9 A=g & Ja< BET Stop ‘I ABF & |

fegm® 29 fs=wyug Many R € <9 g J¢ fs<®une raed § 29 g8+ €3 &3+

Ire I ufgst Aa=g- mmww@?mmaﬂ?WM

UH 39 3 EAA (32). 8T 5B IF TS UaT § ¥ TEw9 3 Ive I ufost {HH 995
©f Ages It J|

¥ WMUBaEs § 98T (Creating Web Applications)
fegm® 29 f3=%ug (Visual Web Developer) & 293" &% Al ¥ MuUBldnat § g7
A< T |
1. File> NewWebsite & fa@'ae a@ | New Web Site € &% STe®Tar I7dH a7 MgeT &
(SA=TT =) |

Fiowe Wt Site : HEN
Sowt by | Dcfach E - neined Fegr plase N
Type: Wivewt Banic
S AsPHET Wk Site Vo uiml B P ¥ =
1 b A iy Wk e
BEN  ASPNET Bmpty WebSite  Vibal Basic
v% ASPIET Dymaenic Doba EntiL-Visosl Rasc
:f'fgg KSR NET Diprscnic Dita Ling. Vaosl Basic
-
‘-\1’35 WICF Sersice Visual Basic
Web jocebions | © File Sysem = B ChWebatenwel ] o - ¥ Browre . |

T T



@)femTemplateseaFunal C# & M@ e 39 | femns &t A fegm® C#
g %ﬁmméwawmmh@ﬁgﬁmw o o9 ity
3J T, Visual C# & fAd de aq |

(™) ASP.NET Empty Web Site & A& 'ae &7 | 3AT MBI M ar ety €t ASPNETRF
HuStansT § B 'ae a9 Ao 7, By 3 e ffa yst Aete § g€ &g, ASP.NET
Empty Web Site & fAd'ae d9 |

(¥) 39U 765 f@ne & f&9° File System from Web location: & fA® de &7 |

gl At 3T . ut (HTTP) & < mae T (WU It €9 Ao=q &8 , Me.dtut (FTP &
93 &% AT It 9 Aa=9) AT TEIS fAver (Ba% dfuSed ) & < Aae J | e7El® fAdeH
(File System) & T | It Baw dfued §°F Fuwee &% a1 g3 Faw T w3 Toe & f¥g

o Av

fend <9 AI=9 3 USf®H 99 AT J |
() few SgATete § MR T 8 ‘I AT d9, §EI9s € BT : C:\Websites\Web2 |
2. OK ‘T If8T I9 | fo™s 7% 28 29 ATfee 9 Jiet T W3 SHd W@t )|

g Web? - Microsoft Visual Web Developer 2010 Express = 5 n
Fite Edit View Webste Debug Tock Window Help
Padm oS A 2| = == [ e  Debug M2

O

Solution Explo res 0 x
i R ok

| # CAWebsites\Web 24 |

i web.config

Acqna )

7 Sohuticn Expl.. JOSRIFTETCTR N
= 0%
CaWWebsitesyWeb2', Web Site Proper -
C i s

Ahways Start” True

M WL E

Creating project ‘Web?2'... project crestion successful.

fa@fa feg ASPNET Sunfee I fen &gt gnt =7 efest § &< d13T der I 3 feg
“web.config” WS Wy HWE T 7t T 1 ASP.NET #uslans & sgt Web.config ¥y
Iafeadans efes J | fen ffe 8T Aeadt mv® et 9 7 fa Hfs@s &fdar, AfaGfaet

O(OIGdIde) HH() HCC O(OIGdIde) S'C'HH O(OO(HOH?'rBBT Wﬂﬂﬂmmﬁwm
ﬁﬁarrgai?ﬁ'saaﬁzr

3. grt fen g Aete € ffg We.dt MHM® (HTML), Aerfes /e, ASPNET Ua mrfe &
H™H® Jd AT J | 7dd 3U78 < § HUBIAHS § 878 ©f Aga3 J 3T 398 ASPX gane
o 93 g9t giet I fAvs fa 29 Uv § sfedfia 9 Un © ST aafeam daer I |
FfesHa 7 UA IHS d9& & Set File> New File.... § A de ad | Add New Item
5% STesar I9H a6 Meer I (IAST IaT 3) |




Add New ltem - CA\Websites\Weh2), ?

T~ ety Do =l | Search nstatied Templite 2|
Werunl Bemic =
= Typa: Wicusd C
Viual CF | WebFom [ 8 \isusl ©F Rk
S— A foam for Wet Bpphcatinns
EEEra——
baiter Page Veual O
:_— Web User Cortral Wil C=
@ ADONET Entity Date Model  Vianl C#
-4
q"‘. ADCHMET EntityObject Ganer  Visal ©F
.@L ACCLMET Se¥-Tracking Entit.. Vizusl €2
?ﬂ; AIS-enalhed WCE Service  Misanl €8
Hamés | b [Ocfaultese T Plece sode in siparate filn

fen fore € 9 MBT-MB T mrfeert § e ad IBF T A & g8 © »et fang fa 2%
Haaawmoud A € Aga3 I Web Form ??fH’&TFc’E(Hh-IB’Add ‘T i &9 |
fonrs &8 29 mﬁmammekﬁmmh@mra(sﬂeﬁwﬂ

&2 : ASP.NET &9 UH <t @818 WaAcHS .ASPX det J|

E] Web2 - Microsaft Visual Web Develoger 2010 Express - B

Eile: et Mew \Webgite. Debug Jools: Window Help '
-u:ﬂ ._J;..ruﬂ oy """“"-.‘_illilehug e e
3 g =i

| KHTHL 1.5 Transition | .

‘N P C\Websites\Web2Y,
IDOCTYPE html PUBLIC "-/SW3C//0TD XHTHL B
k: g b 7 EENA v 2 Defauttaspo

ACGE|GE] o,

Ssheml wnlnse iy weeb.config

Clchead runat="server™s

| ctitlero/titles

| afheads

S shady >

o b Form id="forml® runat=Tserver®s DOCURAENT
% et ez B

& Dr=sign (= Split | @ Sounce Background

(©) fem Samrele € f9 Solution Explorer €% W3 A&t €7 J2%T fder T |

(M) ASP € 5% e a3 § g Un © f<u fengss aia famr 91

() Toolbox © f&9 €T dea® gv Is fAgt & 9 Aete € &9 =afam™ AT AdeT 7|

(W) Database Explorer S8nele € {39 S92 1€ 37¢T8H &% HEUI ATU&T &7 275"
féer 1

(T) Properties f&31




AUTdS YIrd™ (A Simple Program)
1. Dafault.aspx & & |
2. Design View feg Afeg ad |
3. Toolbox & §*Ud darg § WG |
4.9 UA T T 398 ded® § FIIT I STUTT |
5. Code View &9 AfST a3 | iH® 13 918 95 § =4 (A= =4) |

Defauft acpor” I

<X@ Pagc Language="C#" AutcEventifircup="truc” CodcFile="Default.aspx.cs”

LIMOCTYPL html AUDLIC "-//W3C//DTD XIMML 1.8 Transitional//CN" “httpi/fe

Fishtml smlns="hrtp: /S, W3, org/ 1999/ xhiml " >
[ thead runat="scrvcr™s
fritlesxd ritles
| <iheadr
= <bady>
<form 1d="form1™ runat="seruver”:
divy

—1-[0-I

k-:usp:i_nb:l ID-"Lobell™ runat-"server” T-:xt—"Lubcl":f{."nsp:Lnl:h:l)rj

« fiiwe lll
| </ formy Conle
A/ bodhys
[ «/hrmT >

6.3 ferum € feo fan St g e dz § eetu ad (W dd, ST Ad=d fer Um &
fS9 ASP 33 9&0< & et fan <t aF 3 F99r | (AUS 29) |

|¢% Labell . Text = "Hello Worldl"; %= |

<form id-"forml®™ runst-"server™»
fdivy
<k Labell.Texl = "Helle World!™; &
Zaspilabel ID-"Labell™ runat-"server" Text-"Label"»</azp:Label>

<fdivy
< torm>

7.3 CTRL+F5 & €96 | 29 §8w9 € 9 a3ta feuret €=ar (In=ls 24) |

RS - o Bl
|1 | hitg://localhost: 57524/ Web2/Default.asps | + |
= P localhost 57524 b2 Default aspo o E - Googie | W% EB- -

Helio World!



Urae € &9 3A<er A& d9aT (Adding Images into the Project)

IMG SRC &t 293" 5% 3Hl Zaw dfufeq € f<5° 3n<lar § AH® g9 Aae 7 | feia & s
395 BEt feuns 27 f53®Ud WanU N 8539 © fend § anit a9 | 7 Uw ufost ot yET
Wa@ﬂkvsﬂeiwamwmaalagfe@feqﬂﬁvaﬁwmaaﬁa?
A T fapur 3 | CTRL+F5 & o€ w3 2 w9 @ 199 fomse § oF
S oA € &9 Su-T9 ézﬁwéea?m&gﬁwé%ﬁ%mﬁueﬁé’a
NUBIAHS § 97 Aae J | fimer Areardt € st Jof fo3t g Adlet & 24 -

o http://msdn.microsoft.com/en-US/library/w9ss7h1a%28v=vs.80%29.aspx

o http://msdn.microsoft.com/en-us/library/x8k61whf% 28v=vs.80%29.aspx

dat faatmt et fafamr=t a9

3t d99 M (Activities)

He &< fa 3wt fea dfues E3ume € steg 9 w3 At Mue y3den
1 9 TegTdt o et fFg & WWW@FFWUIT%HHFE
€ 9997 g9 fa IT§ muS ST UF € dee § aT'ge ¥ St faus-

f[qu= ded® ©f Aga3 U=dll W3 AT fend Heg fas geGar 3t &
feg U7 w9 § Ao Bae | feg feu@e © wet ffa S Um 926 |




A& 27: @9 JAféar M3 29 Aafena (WEB HOSTING AND

WEB SERVICES

mfgma & €7 (Lesson Objectives):

fer wifer & #ig &9 3t feg a9 © Gar g A7<dr :
o Y JAfETT € T&HUT & AMSE T |

o 29 Afend € d&HUT & ANSS T |

A9 U3 ATedardt (Relevant Knowledge)

fugs® wiferm € &9 AT 9 Inféar, ISP »ife @ g9 Ay I T | few € gaaret d&t
fast T :
o ¥ JAfETT AafeR (Web Hosting Service ) fenma3t w3 Argr § »ue 29 AEle &
BT I U9 &t wirfaryT féet T | Argret 7 fa fava run, §3fesy, wirfe vaehnr
goe@ e 95 €T & <9 IHe (Web Hosts) 7t &9 JAfETT Y=retad (Web Hosting
Providers) fagr AfeT 9 | 9 IAC »™ 39 3 MUS feasedHedadd § fAn g7 3 due g5
878 37er Aeg (Data Centre) faar Afer I | frmmer3d 29 gaféar Aeet €< @& 3078
MUt AT € <9 3973 Ao=ad Ju< € wirfaryT <t € fee g | feg an femmer GusausT
73 §3fesy § Tule et digTAer I
o f€eaa e Aafen =rfesa (Internet Service Provider (1sP)) fea duat I 7 fa 30§
szmﬁ?ﬁm -, StTA AN, I9%, AT HSH ©f <93 ddo
fEeda e queﬁwhﬁalmwwgw@?w NS Hafer, Hova
WMI ATTE3T M HI T HJehdT ad<rg et J |
frmarag @9 JAféar Aafen @ fS9 29 Ua W3 &2t erfest @8t Jaféar IH® et T |
eEly gnféar @ ffg 29 € €3 efest § we 3* uie Yafiar 7% File Transfer Protocol
(FTP) aF 27 féegen €f =93 a9 ~ as is’ ”-érnmwd MUBF 137 7er 7| fias A
JAféar Wy 39 3 faHt 29 Un A7 fa#T 29 Aele aféar € &t sla T W™ 39 T He3
29 Uat 32t | I3t fare 3t & fou féead @ mafen =etsqg (ISP) fem afeur & »ius araat
& He3 © f[S9 HJeh Ja=8E 75 |
fea =uad Arele framrmer gigsed I Aaet I »3 fene et 99 UaAT €t Age3 I Aael J #
fa 3Te9W AUdE M3 MUBIOHS fSE®UdT uBeeay fae fa Aver, utmgut, exrut
(32). &< , a53 fe@aa (ColdFusion) »rfe €t AorfeaT feéet T | feust € =93° g9d argd
UBtaHsT fAe fa e/eH M3 deT Harne € et Afque feus A féAes a9s € @ar g
e I

gT-a™aW Secure Socket Layers (SSL) € =33° ader 7 | few et vt Sue of fa suga
SgArete gnféar fammer Hidaitt dett g8 7 fa €T € Areta W3 famy € €°3 faggg
gaeT J |
e Internet Information Services (11S) ¥ Y3de € AW J fAa= fa HTTP, FTP wrfe, feg
AI=d HElg ATee mrudfear fimer e f&a fdmr o= |



ARET=T 7 vruSt gAféar § f8HT 39 3 JusT arget g5 8T mret mmet A (11S) €t =93
Id AoEdT 95 | fer % At 29 Aete, S99H® ITfeddedid e 93T Ade I M3
Wyt fenrag/fasfsar f&9° It AT % W& H o9 Aae T |
o ATEle AT g Afee 3 g2 J f€q Suar 3Hs (B€99s € et www.example.org) I fARg
fa feq g dfufes 7 H&etus dfuBest & §°3 Ire a3 dfewr ger J | feg He=
J fa veetus Sanrfeet fea fiams dfued € €73 T rae s, feg fer 3t 3
fsd9d aaer J fa IT3 I fam 3gT €7 Ta8emd M3 & e<afddr ius GuseT I8
WMT AI=J ©f fdal qu®3T T | @urgds € &t It IaTfee mrudfear famer fas fa
HEtgAee f&3w man ut & €3 fEa gt < gnrfee Ire a9 Aae 7, ug AT mrudfear
famew fa= fa fE37 2003 A fE37 2008 © <9 micfares SgrTfeet IHe o9 Haw T |
o IJUMS 3fedaedt (Virtual Directory) ﬁﬁ%‘&?ﬁﬁ?ﬁﬁﬁ@ﬁﬁ'ﬁl@?ﬁ@@%
JY-TYSHIIT § AT g afuged 83 B39 & TaABET I | SIUS FTfeddedin
I3t afgwee Tandter f&g =aghor Areti 9 i 39 Aete O 99 9T wiET
fewaat AT T ©dT HaH 3T AfeT J | §e9dE € Bvt 395 a8 f¥d S gATEle
www.example.org T, few am € &9 e ivitaineded fen 3ns © I ffa Sggns
gfeddedt g7 AgeT I , §¥wds € &€ www.example.org/help W3 98U d¢T 4
dfugeg €3 sefen, uafer W3 H&A d18T AT AgeT 7 | U9 feg @ M W% @wd © Bt
few 29 ATele er fe fIAT sad wrear | fon € 578 S gATfee € aagraTdt U @
feg rorfesT fue maet I faGfa dee § mms € f<9 Ageg 3 v ag &3 farur 9|
<9 Agfer (Web Service) T3%3 T€18 = ¥ (World Wide Web) 3 € fe@aefaan fsereifmm
v €3 Hu9 a9s e € &a1 J | v 39 3 Muslanst dfued € €3 Faw 7t fEres
ISPt JET TEMT I8 M3 G Aq[T 3 T93tHT ATett I | fere ®et feo Agat 9 fa €
NUBIAHS Bas dfufed € 83 gt adiet I 1 m3

Had fan an € ff9 Musians AT dfuGes fAm e €3 Sevies
RS fénes otat Tet F €9 5t oW a9 fagar 7 E‘.'f’-'f"um
Qv dfues GuBTu aat I 3T fem e U ¥ €3 d ;

SAATING YITL YLAT | ITHT 29 F fEeaae €3
HUSIAHGT € 93 J9aT 4 (fARS fa A (SaaS) faar
Hrer J fAmeT »idg T - Software as a Service) fAE fa
gwd fan &t fsefen fas fa Hefes S5, miae @5

7T 8¢ 99 € T93° J9d NUBIIHE T SqgHST T @

WsoL WSOL

sonr| @ fq"gg

TfoR TS I I TI AT T IfTH T yd0o ST IU3 gervies .gmm
Fue Az o T 377 oo oo Ra st ugo e fag TP e
T A | fegt Ardtyt St & <9 Aafed (Web Service)

fagr ArET T |

¥ nafen € 9 fanedifaBes Aeecenm dude AH® J¢ Is 7 fa f9/a5 €3 €3
Suday §€ g5 M3 TF §dB Il @93 7 Aaw I& | fon 9% & feegem gera A fa
HHlS & UZSHdT eare © <9 =9es di3T ger J fang fa WDSL fagr Arer 31




<9 Adfen fsAfqurs darew (Web Services Description Language
(WSDL))

fea feegew fanfqurs Sarea XML €3 mufez T # fa 9 Aafen gnwmar Un d13t aret
aﬂanaﬂwafawmaaﬁzrlwsmfwwdu-ms gaer J fa mafen & fa< g 7,

WHF%HWWWWWF%WWIWWW?
fegamg HAT & UH ge=8< € et WSDL §ed® SOAP € <93 daeT J |

fAUS mraride AR A §ed® (Simple Object Access Protocol (SOAP)) XML & =33 575
HES HAH SIH<Id EWWUWG%WQWEWWHW
XMLﬁWWﬁ%ﬁHEmWEEﬁ@Uchqw Areardt ot niewT sest
e AUHfeaHs 7 |

SOAP f&fa HE®T HATHIT TdH=dd HJemT Ja=ger J fan &9 fds g1 o<
J6:
1) € feseay , 7 fq fou fagufes goer T fa wam € ffe at T w3 fen & fa= UAA
FBTHAET T
2) MyBtans faefes seefey € f&g Gegdet § feadfsar feut € Ae gt
nfgfenas qaaT|
3) Yrle &% w3 fani e & eamge &et fed AME 3T (convention) |
SOAP ¥ f3& WY JIT 75 :
1. Extensibility (F3ftm w3 WS- grgféan),
2. Neutrality (far St egmide §eas f<u fas fa HTTP, SMTP, TCP »irfe 1) |
3. Independence (fam =t Ya@iiar vas & feaas €< 38|

fég gg3 frmmer SOAP mafen Y=retse Qudaa g | fdar (Bing -searches), Aéd deH,
2dfex d3tHs w3 ¥ fest fEg ag a5 |

dat faatmt et fafamr=t a9

53t aH (Activities)

&893 He s< fa gt @9 €3 Wy S&e § feuBe &t fea ruas €9
Aete =g eT 9de T | fen & yaT d9s € Sel BTt IuTs fAvs ASUn
©f Aiges I €97 € g9uT aq |

Y AEAE © Bl Jof €3 maetas & =93 99 ¢
o https://en.wikipedia.org/wiki/Virtual_directory
o http://support.microsoft.com/kb/172138




e http://technet.microsoft.com/en us/library/cc772350%28v=ws.10%29.aspx

e http://support.microsoft.com/kb/323972

o http://www.microsoft.com/technet/prodtechnol/WindowsServer2003
/Library/11S/b77cf015-017f-489¢-9b5b-65ca4a679392.mspx?mfr=true

o http://www.youtube.com/watch?v=8SGL5BoMvmM

1. 29 gaféar € €<n < fenrfun a9 |

2. IS Frfedaedt (11S) €t femfamT 53 |

3. gAT &9 Aafer 979 ot AHge 7 ? femmdT a9 |
4. AT SOAP =79 &t ST 7 femmfumm 39 |

Jgot fe3t ust get g9
1. FUSPHT 7 a&Tee I fecds ¢ gadiefect & BEt 3T Aied & fI9 Ha=d €3
fagre 3 AT Edt 39 3 AUR HIEhHT Jaa g et a5 & fagr Aer |

-~

2. SOAP ¥ f3s Hy ar= , S I5 |




Jdd Hd3 (ADDITIONAL RESOURCES)

Hag At f[E3w AT L MuSTansT § f3esU a9 € BTt 7 fammeT fifyer 9de J 37 At
“Starter Kits” € 293" g9 Aae J | “Starter Kits” € ydt »usians I fan § 3t Hes €
<9 38=&= a9 Aae 7 | 3AT IoT f€3 nMgHd Aeed foe € 293 dd Aawe J :

1. http://www.asp.net/web-forms/open-source ‘T AG |

2. 997 a9, fAd de M3 Aeded fde & s8a85 a3 |
3. ¥ AEIC 3 J9q AeTded foe St gerfest e e s &< |

AeTed fae & =93° (Using a starter Kit (WINDOWS APPLICATION))

1. http://msdn.microsoft.com/enus/ beginner/aa700775.aspx & f&9° Teacher Starter Kit &
FEEBT AT |
2. 39583 BanHa ‘I A8 M3 TeacherStarterKit(Csharp).vsi ‘3 € 9 B J9 |
A4S 3 fedreht gerfeat &t useT ad M3 C:\Users\USERNAME\Documents\Visual
Studio 2010\Templates\Project Templates\Visual C# folder) € f<9" feare@na & ydt

9 |
3. Microsoft Visual C# 2010 Express & 83 |
D. File-> Open Project....Browse & fA®'dae g3 W3 Yride TS & BT |
5. §Hd< & 35 d9& BT CTRL+F5 & T9¢ |

AeTed fae €@ =33 (%9 AMUBIEAHE) (Using a starter Kit (WEB
APPLICATION))

1. http://code.msdn.microsoft.com/Employee-Info-Starter-Kit-2d386ba7 & f&<° Employee
Info Starter Kit & 38585 J4 |

2. femeT39 TElsT JUH I3t 98T 95 fegt & 8%39 € ffT manedae ad |

3. Microsoft Visual C# 2010 Express & 8% |

4. File> Open Project.... & i@ 33 8@ a3 M3 §ride TEIH & B |

5. §Hd<e § 35 d3& Be CTRL+F5 & €98 &4 |

—

[ X
8) WY H MIHE € g € T90s AT UfIST € 906 €f 293 d9d IY dHS Ufast
fsesy 3 77 §a 95 | §€ 096 € et 7ad AT 2008 MaAAY A M3Hs € Bt fgafes
d13t Aeded fae 3858 dav T 3T A IAT Ynde & ¥Hdr 37 feg 2010 Mams €
fST ge® A<dit | fen & dH 935 € BTt I AdeT J fa 9 a5 & Hamst gese € Agd3

U< |




() AeTed fofe »H 39 3 € YarHar B 9red C# w3 VB & < et 7 | mfgnm J9s
3 ufost €9= =976 § 3883 a7 |

(T) AgH MUBIIHST € BT = ¥ AEle fa= fa www.sourceforge.net @7 o7& 37 |

(F) AC™deq foe € &% dH dda 3 Ufast fen &bt gerfest & Age ug | fem fSg um
JefeaT, Mrydt muse Mfe 979 ATeddT I Age! J |

(T) 7Ad AgI3 I« 3T MIAY H MSHS €7 YIS’ F976 3'86HT d4d (IO © <9 &
39) Add IAT YI'€ AUSH & I& J9&T 9'9€ J |

(F) 7T AT U W3S &8 vigHerfed 7 (fAe’ fa 2010 Wawyw), 3T At mfgnm €
BT WAHY H WSS T 3T T996 3T86H S J9 Aaw J (fA= 2012)

<7 f&a (Additional Links)
o http://mww.microsoft.com/web/gallery/
o http://msdn.microsoft.com/en-us/library/vstudio/dfcw7sd5%28v=vs.100%29.aspx
o http://www.codeplex.com/
o http://msdn.microsoft.com/en-us/beginner/aa700775.aspx
o http://msdn.microsoft.com/en-us/beginner/bb308740.aspx
¢ http://msdn.microsoft.com/en-us/beginner/bb308743.aspx
e http://msdn.microsoft.com/en-us/beginner/bb308747.aspx
o http://msdn.microsoft.com/en-us/beginner/bb308749.aspx
o http://msdn.microsoft.com/en-us/beginner/bb308770.aspx
¢ http://msdn.microsoft.com/en-us/beginner/bb308786.aspx
o http://msdn.microsoft.com/en-us/beginner/bb308809.aspx
¢ http://msdn.microsoft.com/en-us/beginner/bb308817.aspx
o http://msdn.microsoft.com/en-us/beginner/bb308818.aspx
o http://msdn.microsoft.com/en-us/beginner/bb308825.aspx
o http://msdn.microsoft.com/en-us/beginner/bb308861.aspx
o http://msdn.microsoft.com/en-us/beginner/bb308891.aspx
o http://msdn.microsoft.com/en-us/beginner/ff715351.aspx
o http://msdn.microsoft.com/en-us/library/32dbftby.aspx
o http://msdn.microsoft.com/en-us/library/5b13a7k4.aspx
e http://msdn.microsoft.com/en-us/library/8y82wx12.aspx



o http://msdn.microsoft.com/en-us/library/aa288453.aspx

o http://msdn.microsoft.com/en-us/library/aa480728.aspx

e http://msdn.microsoft.com/en-us/library/aa984771%28VS.71%29.aspx
o http://msdn.microsoft.com/en-us/library/asz1fz8b.aspx

o http://msdn.microsoft.com/en-us/library/bb330916.aspx

o http://msdn.microsoft.com/en-us/library/bb330932.aspx

o http://msdn.microsoft.com/en-us/library/d56de412.aspx

e http://msdn.microsoft.com/en-us/library/dd409393%28VS.100%29.aspx
o http://msdn.microsoft.com/en-us/library/fda2bad5%28V'S.100%29.aspx
e http://msdn.microsoft.com/en-us/library/ms173104.aspx

o http://msdn.microsoft.com/en-us/library/ms173109.aspx

e http://msdn.microsoft.com/en-us/library/ms173121.aspx

e http://msdn.microsoft.com/en-us/library/ms173149.aspx

e http://msdn.microsoft.com/en-us/library/ms173150.aspx

e http://msdn.microsoft.com/en-us/library/ms173152.aspx

e http://msdn.microsoft.com/en-us/library/ms173153.aspx146

e http://msdn.microsoft.com/en-us/library/ms173160.aspx

e http://msdn.microsoft.com/en-us/library/ms379570.aspx

o http://msdn.microsoft.com/en-us/library/ms950421.aspx

o http://msdn.microsoft.com/en-us/library/x9afc042.aspx

o http://msdn.microsoft.com/en-us/library/x9fsa0sw.aspx

e http://msdn.microsoft.com/en-us/library/zt39148a.aspx

o http://msdn.microsoft.com/en-us/vcsharp/aa336800.aspx

o http://www.asp.net/sql-server/videos/designing-relational-database-tables
o http://www.w3schools.com/ado/default.asp

e http://www.w3schools.com/sgl/default.asp

o http://www.iis.net

e http://msdn.microsoft.com/en-us/library/hh147278%28v=vs.88%29.aspx



fegms g3t 2010 #Wandw »stas § 578583 W3 feanes ag|

1. Download.microsoft.com € f&9" fegm® AgStS 2010 Manyw »EtHs § 3E58T
9|

!

8¢ A IAI FEEET FA€ T 3T Gmasionn
Sofesy & fre a9a & met ol St
dfueat € 83 féne® g9a M3 sfy

v 39 fEnedns € Bt d96 W3

e BEls fEne®a § g2 | N —

Eaveis

N Vil OF i s

2.fen & DVDI W T mI fim

ST feAe® J9aT Ide J B QO Vol Basic 1 s
dfuges ‘s DVD & fem-e coll e .
(o9 gt feg 8, A=aF q@aad T :
3t 1SO efe® 3 =g afET a7 P L

DVD Wy mry g2 § AT=ait) |

3. X:\Setup.exe ‘T € 9 BT I

(Replace X: with drive letter W6, e it Wl €9 20110 Exprress Sehim L] ]
assigned to DVD) Visual Studio Welcome ke Setw G \etial O 2000
2010 Express Setup 3TesTar gan s i

oors obebarred applcstions . This wizand v Bgued & wou theou gh the s Dallation process [F s
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5% Fans feyret fder T (IAsts S i et

)|




S = ]|

G Vistal ¥ oo
Express

B s b cara Py rosd and cirderctarsd oF dha g b aned vt ores dea eor baed i Hrea Bocrsm
berre, Yo maest acoept Hhell ceess besres ba fore oo cory rebal | Ehe softreare.
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1. download.microsoft.com & f&9° Microsoft Visual Web Developer 2010 Express &
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Destination Folder & &% Fans fauret féder T (3A<ta 20) |

0 Microscft Visua! Web Developer 2010 Express Setup = & |

Destination Folder

O Vistal Web Developer 20
Expresis
Installation lcation cannet be changad, Click hare for mora information.
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